summaryrefslogtreecommitdiff
path: root/gnu/packages/game-development.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/game-development.scm')
-rw-r--r--gnu/packages/game-development.scm64
1 files changed, 43 insertions, 21 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index c57ea5a908..fa7875d077 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -8,7 +8,7 @@
;;; Copyright © 2016, 2017, 2020 Kei Kebreau <kkebreau@posteo.net>
;;; Copyright © 2016, 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016, 2017, 2018 Julian Graham <joolean@gmail.com>
-;;; Copyright © 2017, 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017–2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017 Manolis Fragkiskos Ragkousis <manolis837@gmail.com>
;;; Copyright © 2017 Peter Mikkelsen <petermikkelsen10@gmail.com>
;;; Copyright © 2017 Arun Isaac <arunisaac@systemreboot.net>
@@ -163,21 +163,22 @@ is used in some video games and movies.")
(define-public deutex
(package
(name "deutex")
- (version "5.2.1")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/Doom-Utils/deutex"
- "/releases/download/v" version "/"
- "deutex-" version ".tar.xz"))
- (sha256
- (base32
- "07w3asqxx89wl2wfv1z3cak8v83h3ys3b39mq9qq4gyf3xdhs76n"))))
+ (version "5.2.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/Doom-Utils/deutex"
+ "/releases/download/v" version "/"
+ "deutex-" version ".tar.zst"))
+ (sha256
+ (base32 "0psb2za6ldrlak7s8pjvli98ij5yiwjx8j1ms2v7rj9yadx0xv8h"))))
(build-system gnu-build-system)
(inputs
`(("libpng" ,libpng)))
(native-inputs
`(("asciidoc" ,asciidoc)
- ("pkg-config" ,pkg-config)))
+ ("pkg-config" ,pkg-config)
+ ("zstd" ,zstd)))
(home-page "https://github.com/Doom-Utils/deutex")
(synopsis "WAD file composer for Doom and related games")
(description
@@ -277,14 +278,14 @@ PCM data.")
(define-public gzochi
(package
(name "gzochi")
- (version "0.12")
+ (version "0.13")
(source (origin
(method url-fetch)
(uri (string-append "mirror://savannah/gzochi/gzochi-"
version ".tar.gz"))
(sha256
(base32
- "0h8yvk7154kd8zdfa9nqy73blrjq2x19kv305jcnwlmm09vvss59"))))
+ "1vcvf04qqzs3q8kaild2x7qvkwc6bwzfsisb78147b8z747j7hj0"))))
(build-system gnu-build-system)
(arguments
'(#:phases (modify-phases %standard-phases
@@ -298,7 +299,7 @@ PCM data.")
(native-inputs `(("pkgconfig" ,pkg-config)))
(inputs `(("bdb" ,bdb)
("glib" ,glib)
- ("guile" ,guile-2.2)
+ ("guile" ,guile-3.0)
("libmicrohttpd" ,libmicrohttpd)
("ncurses" ,ncurses)
("sdl" ,sdl)
@@ -1071,7 +1072,14 @@ to create fully featured games and multimedia programs in the python language.")
(method url-fetch)
(uri (string-append "https://www.renpy.org/dl/" renpy-version
"/pygame_sdl2-" version ".tar.gz"))
- (sha256 (base32 "1bmr7j9mlsc4czpgw70ld15ymyp4wxrk9hdsqad40wjwdxvvg2dr"))))
+ (sha256 (base32 "1bmr7j9mlsc4czpgw70ld15ymyp4wxrk9hdsqad40wjwdxvvg2dr"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; drop generated sources
+ (delete-file-recursively "gen")
+ (delete-file-recursively "gen3")
+ #t))))
(build-system python-build-system)
(arguments
`(#:tests? #f ; tests require pygame to be installed first
@@ -1090,11 +1098,6 @@ to create fully featured games and multimedia programs in the python language.")
"/lib -Wl,-rpath,"
(assoc-ref inputs "sdl-union")
"/lib -Wl,--enable-new-dtags -lSDL2"))
- #t))
- (add-before 'build 'drop-generated-files
- (lambda args
- (delete-file-recursively "gen")
- (delete-file-recursively "gen3")
#t)))))
(inputs
`(("sdl-union"
@@ -1118,7 +1121,18 @@ developed mainly for Ren'py.")
(method url-fetch)
(uri (string-append "https://www.renpy.org/dl/" version
"/renpy-" version "-source.tar.bz2"))
- (sha256 (base32 "1anr5cfbvbsbik4v4rvrkdkciwhg700k4lydfbs4n85raimz9mw4"))))
+ (sha256 (base32 "1anr5cfbvbsbik4v4rvrkdkciwhg700k4lydfbs4n85raimz9mw4"))
+ (modules '((guix build utils)))
+ (patches
+ (search-patches
+ "renpy-use-system-fribidi.patch"))
+ (snippet
+ '(with-directory-excursion "module"
+ ;; drop generated sources
+ (delete-file-recursively "gen")
+ ;; drop fribidi sources
+ (delete-file-recursively "fribidi-src")
+ #t))))
(build-system python-build-system)
(arguments
`(#:tests? #f ; Ren'py doesn't seem to package tests
@@ -1131,6 +1145,13 @@ developed mainly for Ren'py.")
(("xdg-open")
(which "xdg-open")))
#t))
+ (add-after 'unpack 'fix-include-paths
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "module/setup.py"
+ (("/usr/include/fribidi")
+ (string-append (assoc-ref inputs "fribidi")
+ "/include/fribidi")))
+ #t))
(add-after 'set-paths 'set-build-vars
(lambda* (#:key inputs #:allow-other-keys)
(setenv "RENPY_CYTHON"
@@ -1168,6 +1189,7 @@ developed mainly for Ren'py.")
(inputs
`(("ffmpeg" ,ffmpeg)
("freetype" ,freetype)
+ ("fribidi" ,fribidi)
("glew" ,glew)
("libpng" ,libpng)
("python2-pygame" ,python2-pygame-sdl2)