summaryrefslogtreecommitdiff
path: root/gnu/packages/game-development.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/game-development.scm')
-rw-r--r--gnu/packages/game-development.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 41de1fe722..06bf4041df 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -840,7 +840,13 @@ programming language.")
(build-system cmake-build-system)
(arguments
`(#:build-type "Release"
- #:tests? #f))
+ #:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-cmake
+ (lambda _
+ (substitute* "CMakeLists.txt"
+ (("DESTINATION .") "DESTINATION lib/love")))))))
(inputs
`(("luajit" ,luajit)))
(synopsis "Lightweight immediate mode GUI for LÖVE games")