summaryrefslogtreecommitdiff
path: root/gnu/packages/game-development.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/game-development.scm')
-rw-r--r--gnu/packages/game-development.scm4
1 files changed, 4 insertions, 0 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 4cd3804d19..0b08b04f51 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -1069,6 +1069,10 @@ games.")
(arguments
`(#:scons ,scons-python2
#:scons-flags (list "platform=x11"
+ ,@(if (string-prefix? "aarch64" (or (%current-target-system)
+ (%current-system)))
+ `("CCFLAGS=-DNO_THREADS")
+ '())
;; Avoid using many of the bundled libs.
;; Note: These options can be found in the SConstruct file.
"builtin_freetype=no"