summaryrefslogtreecommitdiff
path: root/gnu/packages/freedesktop.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/freedesktop.scm')
-rw-r--r--gnu/packages/freedesktop.scm98
1 files changed, 44 insertions, 54 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 481cb3cd1d..5519f04b11 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -286,14 +286,14 @@ freedesktop.org project.")
;; Updating this will rebuild over 700 packages through libinput-minimal.
(package
(name "libinput")
- (version "1.15.5")
+ (version "1.16.2")
(source (origin
(method url-fetch)
(uri (string-append "https://freedesktop.org/software/libinput/"
"libinput-" version ".tar.xz"))
(sha256
(base32
- "15ww4jl3lcxyi8m8idg8canklbqv729gnwpkz7r98c1w8a7zq3m9"))))
+ "1ab0q4iya07kvjd2g1vzamj9h57qldi15h3b8324vg3szr88qggw"))))
(build-system meson-build-system)
(arguments
`(#:configure-flags '("-Ddocumentation=false")
@@ -372,7 +372,7 @@ the freedesktop.org XDG Base Directory specification.")
(define-public elogind
(package
(name "elogind")
- (version "243.4")
+ (version "243.7")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -381,7 +381,7 @@ the freedesktop.org XDG Base Directory specification.")
(file-name (git-file-name name version))
(sha256
(base32
- "141frvgyk4fafcxsix94qc0d9ffrwksld8lqq4hq6xsgjlvv0mrs"))))
+ "1ccj3cbs9nsfg497wg195in1a7b9csm1jdm7z6q7vvx1ynpjxlxz"))))
(build-system meson-build-system)
(arguments
`(#:configure-flags
@@ -420,14 +420,6 @@ the freedesktop.org XDG Base Directory specification.")
(("join_paths\\(bindir, 'pkttyagent'\\)")
"'\"/run/current-system/profile/bin/pkttyagent\"'"))
#t))
- (add-after 'unpack 'adjust-dbus-socket-address
- (lambda _
- ;; Look for the D-Bus socket in /var/run instead of /run. Remove
- ;; this for versions > 243.4.
- (substitute* "src/libelogind/sd-bus/bus-internal.h"
- (("=/run/dbus/system_bus_socket")
- "=/var/run/dbus/system_bus_socket"))
- #t))
(add-after 'unpack 'adjust-tests
(lambda _
;; This test tries to copy some bytes from /usr/lib/os-release,
@@ -738,14 +730,14 @@ Python.")
(define-public wayland
(package
(name "wayland")
- (version "1.17.0")
+ (version "1.18.0")
(source (origin
(method url-fetch)
(uri (string-append "https://wayland.freedesktop.org/releases/"
name "-" version ".tar.xz"))
(sha256
(base32
- "194ibzwpdcn6fvk4xngr4bf5axpciwg2bj82fdvz88kfmjw13akj"))))
+ "0k995rn96xkplrapz5k648j651wc43kq817xk1x8280h16gsfxa6"))))
(build-system gnu-build-system)
(arguments
`(#:parallel-tests? #f))
@@ -774,7 +766,7 @@ applications, X servers (rootless or fullscreen) or other display servers.")
(define-public wayland-protocols
(package
(name "wayland-protocols")
- (version "1.18")
+ (version "1.20")
(source (origin
(method url-fetch)
(uri (string-append
@@ -782,7 +774,7 @@ applications, X servers (rootless or fullscreen) or other display servers.")
"wayland-protocols-" version ".tar.xz"))
(sha256
(base32
- "1cvl93h83ymbfhb567jv5gzyq08181w7c46rsw4xqqqpcvkvfwrx"))))
+ "1rsdgvkkvxs3cjhpl6agvbkm53vm7k8rg127j9y2vn33m2hvg0lp"))))
(build-system gnu-build-system)
(inputs
`(("wayland" ,wayland)))
@@ -796,7 +788,7 @@ applications, X servers (rootless or fullscreen) or other display servers.")
(define-public waylandpp
(package
(name "waylandpp")
- (version "0.2.7")
+ (version "0.2.8")
(home-page "https://github.com/NilsBrause/waylandpp")
(source (origin
(method git-fetch)
@@ -804,10 +796,10 @@ applications, X servers (rootless or fullscreen) or other display servers.")
(file-name (git-file-name name version))
(sha256
(base32
- "1r4m0xhvwpcqxrqvp3hz1bzlkxqj2jiymd5r6hj8xjzz536hyprz"))))
+ "1kxiqab48p0n97pwg8c2zx56wqq32m3rcq7qd2pjj33ipcanb3qq"))))
(build-system cmake-build-system)
(arguments
- `(#:tests? #f)) ;no tests
+ `(#:tests? #f)) ; no tests
(native-inputs
`(("pkg-config" ,pkg-config)))
(inputs
@@ -909,41 +901,39 @@ multiplexer to the KMS/DRM Linux kernel devices.")
(license license:expat)))
(define-public wev
- ;; There simple tool has no version or release yet.
- (let ((commit "cee3dfb2a8b40ee303611018c68ae182d84a7f46"))
- (package
- (name "wev")
- (version (string-append "2020-02-06-" (string-take commit 8)))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://git.sr.ht/~sircmpwn/wev")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0l71v3fzgiiv6xkk365q1l08qvaymxd4kpaya6r2g8yzkr7i2hms"))))
- (build-system gnu-build-system)
- (arguments
- `(#:tests? #f ; no tests
- #:make-flags
- (list "CC=gcc" (string-append "PREFIX=" (assoc-ref %outputs "out")))
- #:phases
- (modify-phases %standard-phases
- (delete 'configure))))
- (native-inputs
- `(("pkg-config" ,pkg-config)
- ("scdoc" ,scdoc)))
- (inputs
- `(("libxkbcommon" ,libxkbcommon)
- ("wayland" ,wayland)
- ("wayland-protocols" ,wayland-protocols)))
- (home-page "https://git.sr.ht/~sircmpwn/wev")
- (synopsis "Wayland event viewer")
- (description "Wev is a tool that opens a window, printing all events
+ (package
+ (name "wev")
+ (version "1.0.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.sr.ht/~sircmpwn/wev")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0l71v3fzgiiv6xkk365q1l08qvaymxd4kpaya6r2g8yzkr7i2hms"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no tests
+ #:make-flags
+ (list "CC=gcc" (string-append "PREFIX=" (assoc-ref %outputs "out")))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure))))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("scdoc" ,scdoc)))
+ (inputs
+ `(("libxkbcommon" ,libxkbcommon)
+ ("wayland" ,wayland)
+ ("wayland-protocols" ,wayland-protocols)))
+ (home-page "https://git.sr.ht/~sircmpwn/wev")
+ (synopsis "Wayland event viewer")
+ (description "Wev is a tool that opens a window, printing all events
sent to a Wayland window, such as key presses. It is analogous to the X11 tool
XEv.")
- (license license:expat))))
+ (license license:expat)))
(define-public exempi
(package
@@ -1398,7 +1388,7 @@ wish to perform colour calibration.")
(define-public libfprint
(package
(name "libfprint")
- (version "1.90.1")
+ (version "1.90.3")
(source
(origin
(method git-fetch)
@@ -1407,7 +1397,7 @@ wish to perform colour calibration.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0fdaak7qjr9b4482g7fhhqpyfdqpxq5kpmyzkp7f5i7qq2ynb78a"))))
+ (base32 "1fs0qrfrqnvc6kcsg81l5p89n8jnsx9dr1pzxpb8ghwas8c9v52i"))))
(build-system meson-build-system)
(arguments
'(#:configure-flags