summaryrefslogtreecommitdiff
path: root/gnu/packages/fpga.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/fpga.scm')
-rw-r--r--gnu/packages/fpga.scm70
1 files changed, 35 insertions, 35 deletions
diff --git a/gnu/packages/fpga.scm b/gnu/packages/fpga.scm
index b2717d2233..f07c7260f7 100644
--- a/gnu/packages/fpga.scm
+++ b/gnu/packages/fpga.scm
@@ -260,40 +260,40 @@ Includes the actual FTDI connector.")
(license license:isc))))
(define-public nextpnr-ice40
- (let [(commit "c192ba261d77ad7f0a744fb90b01e4a5b63938c4")
- (revision "0")]
- (package
- (name "nextpnr-ice40")
- (version (git-version "0.0.0" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "git://github.com/YosysHQ/nextpnr")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0g2ar1z89b31qw5vgqj2rrcv9rzncs94184dgcsrz19p866654mf"))))
- (inputs
- `(("qtbase" ,qtbase)
- ("boost" ,boost-with-python3)
- ("yosys" ,yosys)
- ("eigen" ,eigen)
- ("python" ,python)
- ("icestorm" ,icestorm)))
- (build-system cmake-build-system)
- (arguments
- `(#:configure-flags `("-DARCH=ice40"
- ,(string-append "-DICEBOX_ROOT="
- (assoc-ref %build-inputs "icestorm")
- "/share/icebox"))
- #:tests? #f))
- (synopsis "Place-and-Route tool for FPGAs")
- (description "Nextpnr aims to be a vendor neutral, timing driven,
+ (let [(commit "fbe486df459909065d6852a7495a212dfd2accef")
+ (revision "1")]
+ (package
+ (name "nextpnr-ice40")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "git://github.com/YosysHQ/nextpnr")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1fmxsywgs45g88ra7ips5s2niiiwrkyxdcy742ws18dfk2y4vi9c"))))
+ (inputs
+ `(("boost" ,boost)
+ ("eigen" ,eigen)
+ ("icestorm" ,icestorm)
+ ("python" ,python)
+ ("qtbase" ,qtbase)
+ ("yosys" ,yosys)))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:configure-flags `("-DARCH=ice40"
+ ,(string-append "-DICEBOX_ROOT="
+ (assoc-ref %build-inputs "icestorm")
+ "/share/icebox"))
+ #:tests? #f))
+ (synopsis "Place-and-Route tool for FPGAs")
+ (description "Nextpnr aims to be a vendor neutral, timing driven,
FOSS FPGA place and route tool.")
- (home-page "https://github.com/YosysHQ/nextpnr")
- (license license:expat))))
+ (home-page "https://github.com/YosysHQ/nextpnr")
+ (license license:expat))))
(define-public arachne-pnr
(let ((commit "840bdfdeb38809f9f6af4d89dd7b22959b176fdd")
@@ -340,7 +340,7 @@ FOSS FPGA place and route tool.")
(define-public gtkwave
(package
(name "gtkwave")
- (version "3.3.104")
+ (version "3.3.106")
(source
(origin
(method url-fetch)
@@ -350,7 +350,7 @@ FOSS FPGA place and route tool.")
(string-append "http://gtkwave.sourceforge.net/"
"gtkwave-" version ".tar.gz")))
(sha256
- (base32 "0kw9a33gx60kn069yhx5pyk39x1z3pwaj8l1qqwq943v62lx23fj"))))
+ (base32 "1pyij6dlmapjyzrmn255fkf8gyhz8i4vaipd75a68i2bnq021nn8"))))
(build-system gnu-build-system)
(native-inputs
`(("gperf" ,gperf)