summaryrefslogtreecommitdiff
path: root/gnu/packages/fontutils.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/fontutils.scm')
-rw-r--r--gnu/packages/fontutils.scm44
1 files changed, 30 insertions, 14 deletions
diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
index 7455d3381a..6784dc7cf6 100644
--- a/gnu/packages/fontutils.scm
+++ b/gnu/packages/fontutils.scm
@@ -9,7 +9,7 @@
;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2018, 2019 Ludovic Courtès <ludo@gnu.org>
-;;; Copyright © 2019 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2019, 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2020 Roel Janssen <roel@gnu.org>
;;; Copyright © 2020 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;;
@@ -302,7 +302,7 @@ fonts to/from the WOFF2 format.")
;; In Requires or Requires.private of fontconfig.pc.
(propagated-inputs `(("expat" ,expat)
("freetype" ,freetype)
- ("libuuid" ,util-linux)))
+ ("libuuid" ,util-linux "lib")))
(inputs `(("gs-fonts" ,gs-fonts)))
(native-inputs
`(("gperf" ,gperf)
@@ -397,6 +397,8 @@ X11-system or any other graphical user interface.")
(sha256
(base32 "0gbxyip4wdibirdg2pvzayzyy927vxyd6dfyfiflx8zg88qzn8v8"))))
(build-system gnu-build-system)
+ (arguments
+ '(#:configure-flags '("--disable-static")))
(inputs
`(("zlib" ,zlib)
("expat" ,expat)))
@@ -519,16 +521,18 @@ using the above tables.")
(define-public libspiro
(package
(name "libspiro")
- (version "0.5.20150702")
+ (version "20190731")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/fontforge/libspiro/releases"
- "/download/" version "/libspiro-dist-" version ".tar.gz"))
+ "/download/" version "/libspiro-" version ".tar.gz"))
(sha256
(base32
- "153ckwj6h3wwlsgcppzqj8cymv1927hi8ar8fzpchq5q89cj2kai"))))
+ "0m63x97b7aciviijprvy85gm03p2jsgslxn323zl9zn7qz6d3ir4"))))
(build-system gnu-build-system)
+ (arguments
+ '(#:configure-flags '("--disable-static")))
(synopsis "Clothoid to bezier conversion library")
(description
"Raph Levien's Spiro package as a library. A mechanism for drawing
@@ -539,7 +543,7 @@ smooth contours with constant curvature at the spline joins.")
(define-public libuninameslist
(package
(name "libuninameslist")
- (version "20190701")
+ (version "20200313")
(home-page "https://github.com/fontforge/libuninameslist")
(source
(origin
@@ -548,7 +552,7 @@ smooth contours with constant curvature at the spline joins.")
"/libuninameslist-dist-" version ".tar.gz"))
(sha256
(base32
- "18c9pcz81wm26q2m7npmvh9j3ibjs2hycxfh5xic2xgjfw40v2qn"))))
+ "10ri80c64xb4rhbif3sr87y5vhi3m702zb0m02imvj1jib9rq0m8"))))
(build-system gnu-build-system)
(synopsis "Unicode names and annotation list")
(description
@@ -565,15 +569,15 @@ definitions.")
(define-public fontforge
(package
(name "fontforge")
- (version "20190801")
+ (version "20200314")
(source (origin
(method url-fetch)
(uri (string-append
"https://github.com/fontforge/fontforge/releases/download/"
- version "/fontforge-" version ".tar.gz"))
+ version "/fontforge-" version ".tar.xz"))
(sha256
- (base32 "0lh8yx01asbzxm6car5cfi64njh5p4lxc7iv8dldr5rwg357a86r"))))
- (build-system gnu-build-system)
+ (base32 "0qf88wd6riycq56d24brybyc93ns74s0nyyavm43zp2kfcihn6fd"))))
+ (build-system cmake-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)))
(inputs `(("cairo" ,cairo)
@@ -584,7 +588,7 @@ definitions.")
("libSM" ,libsm)
("libX11" ,libx11)
("libXi" ,libxi)
- ("libjpeg" ,libjpeg)
+ ("libjpeg" ,libjpeg-turbo)
("libltdl" ,libltdl)
("libpng" ,libpng)
("libspiro" ,libspiro)
@@ -598,8 +602,20 @@ definitions.")
("python" ,python)
("zlib" ,zlib)))
(arguments
- '(#:phases
+ '(#:configure-flags '(;; TODO: Provide GTK+ for the Wayland-friendly GDK
+ ;; backend, instead of the legacy X11 backend.
+ ;; Currently it introduces a circular dependency.
+ "-DENABLE_X11=ON")
+ #:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'do-not-override-RPATH
+ (lambda _
+ ;; Do not attempt to set a default RPATH, as our ld-wrapper
+ ;; already does the right thing.
+ (substitute* "CMakeLists.txt"
+ (("^set_default_rpath\\(\\)")
+ ""))
+ #t))
(add-after 'install 'set-library-path
(lambda* (#:key inputs outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out"))
@@ -756,7 +772,7 @@ maintain the Noto Fonts project.")
("desktop-file-utils" ,desktop-file-utils)))
(inputs
`(("json-glib" ,json-glib)
- ("sqlite-with-column-metadata" ,sqlite-with-column-metadata)
+ ("sqlite" ,sqlite)
("fonconfig" ,fontconfig)
("freetype" ,freetype)
("gtk+" ,gtk+)))