summaryrefslogtreecommitdiff
path: root/gnu/packages/fontutils.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/fontutils.scm')
-rw-r--r--gnu/packages/fontutils.scm19
1 files changed, 13 insertions, 6 deletions
diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
index 30143eba34..69e35cda0e 100644
--- a/gnu/packages/fontutils.scm
+++ b/gnu/packages/fontutils.scm
@@ -7,6 +7,7 @@
;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
;;; Copyright © 2017 Nils Gillmann <ng0@n0.is>
;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2018 Ricardo Wurmus <rekado@elephly.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -54,15 +55,18 @@
(define-public freetype
(package
(name "freetype")
- (version "2.9")
+ (version "2.9.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://savannah/freetype/freetype-"
version ".tar.bz2"))
(sha256 (base32
- "12jcdz1in20yaa55izxalg3hm1pf7nydfrzps5bzb4zgihybmzz6"))
- (patches (search-patches "freetype-CVE-2018-6942.patch"))))
+ "0kg8w6qyiizlyzh4a8lpzslipcbv96hcg3rqqpnxba8ffbm8g3fv"))))
(build-system gnu-build-system)
+ (arguments
+ ;; The use of "freetype-config" is deprecated, but other packages still
+ ;; depend on it.
+ `(#:configure-flags (list "--enable-freetype-config")))
(native-inputs
`(("pkg-config" ,pkg-config)))
(propagated-inputs
@@ -375,7 +379,7 @@ applications should be.")
(define-public graphite2
(package
(name "graphite2")
- (version "1.3.11")
+ (version "1.3.12")
(source
(origin
(method url-fetch)
@@ -383,7 +387,7 @@ applications should be.")
"download/" version "/" name "-" version ".tgz"))
(sha256
(base32
- "0z5dcgh8r3678awq6fb8igik7xmar5m6z9xxwpkkhradhk8jxfds"))))
+ "1l1940d8fz67jm6a0x8cjb5p2dv48cvz3wcskwa83hamd70k15fd"))))
(build-system cmake-build-system)
(native-inputs
`(("python" ,python-2) ; because of "import imap" in tests
@@ -533,7 +537,10 @@ definitions.")
("libxml2" ,libxml2)
("pango" ,pango)
("potrace" ,potrace)
- ("python" ,python-wrapper)
+ ;; FIXME: We use Python 2 here because there is a bug in Python
+ ;; 3.7 that is triggered when Py_Main is called after Py_Init, as
+ ;; is done by fontforge. This will be fixed in Python 3.7.1.
+ ("python" ,python-2)
("zlib" ,zlib)))
(arguments
'(#:phases