summaryrefslogtreecommitdiff
path: root/gnu/packages/fonts.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/fonts.scm')
-rw-r--r--gnu/packages/fonts.scm79
1 files changed, 69 insertions, 10 deletions
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index d5806cda36..b24425ca22 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -14,7 +14,7 @@
;;; Copyright © 2016, 2017, 2018, 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016, 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2016 Toni Reina <areina@riseup.net>
-;;; Copyright © 2017, 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017–2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017 José Miguel Sánchez García <jmi2k@openmailbox.com>
;;; Copyright © 2017 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2017 Clément Lassieur <clement@lassieur.org>
@@ -38,6 +38,7 @@
;;; Copyright © 2020 Simen Endsjø <simendsjo@gmail.com>
;;; Copyright © 2020 Tim Van den Langenbergh <tmt_vdl@gmx.com>
;;; Copyright © 2020 Nicolò Balzarotti <nicolo@nixo.xyz>
+;;; Copyright © 2021 Antoine Côté <antoine.cote@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -314,14 +315,14 @@ The Lato 2.010 family supports more than 100 Latin-based languages, over
(define-public font-liberation
(package
(name "font-liberation")
- (version "2.1.1")
+ (version "2.1.2")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/liberationfonts/liberation-fonts/"
- "files/4743886/liberation-fonts-ttf-" version ".tar.gz"))
+ "files/5722233/liberation-fonts-ttf-" version ".tar.gz"))
(sha256
- (base32 "1jkg8j8jx7ffj13z5ilw7dids99dyypljm1pv06ycmghw1pw3qlf"))))
+ (base32 "1q7qx9bpn1gqjh1zbb8n9fkzwz8skn41hyy61186g4c3y8q4js8l"))))
(build-system font-build-system)
(home-page "https://github.com/liberationfonts")
(synopsis "Fonts compatible with Arial, Times New Roman, and Courier New")
@@ -711,7 +712,7 @@ for use at smaller text sizes")))
(define-public font-gnu-unifont
(package
(name "font-gnu-unifont")
- (version "13.0.04")
+ (version "13.0.05")
(source
(origin
(method url-fetch)
@@ -721,7 +722,7 @@ for use at smaller text sizes")))
(string-append "mirror://gnu/unifont/unifont-"
version "/unifont-" version ".tar.gz")))
(sha256
- (base32 "064ilpbnz62cwmpajszs2b08x2zg7yh9whlaiqhjzi7bir3im94j"))))
+ (base32 "0kkgagnyhl92pwgnvf1vjrc1ql8lk5khb125sz18ck8vnxk4i3pr"))))
(build-system gnu-build-system)
(outputs '("out" ; TrueType version
"pcf" ; PCF (bitmap) version
@@ -1031,6 +1032,27 @@ Sans Pro family.")
(description "This is the typeface used by Mozilla in Firefox OS.")
(license license:silofl1.1)))
+(define-public font-fira-go
+ (package
+ (name "font-fira-go")
+ (version "1.000")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/bBoxType/FiraGO")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "10rcfg1fijv00yxv5n9l3lm0axhafa1irkg42zpmasd70flgg655"))))
+ (build-system font-build-system)
+ (home-page "https://github.com/bBoxType/FiraGO")
+ (synopsis "Multilingual extension of the Fira Sans font family")
+ (description "FiraGO is a multilingual extension of the Fira Sans font
+family. Based on the Fira Sans 4.3 glyph set, FiraGO adds support for the
+Arabic, Devanagari, Georgian, Hebrew and Thai scripts.")
+ (license license:silofl1.1)))
+
(define-public font-fira-code
(package
(name "font-fira-code")
@@ -1371,6 +1393,43 @@ programming. Iosevka is completely generated from its source code.")
"Sarasa Gothic is a programming font based on Iosevka and Source Han Sans,
most CJK characters are same height, and double width as ASCII characters.")))
+(define-public font-space-grotesk
+ (package
+ (name "font-space-grotesk")
+ (version "2.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/floriankarsten/space-grotesk")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1aiivn0rl7ydiyqvsr0fa2hx82h3br3x48w3100fcly23n0fdcby"))))
+ (build-system font-build-system)
+ ;; TODO: Package fontmake and gftools and build from source.
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'install-license-files
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (doc (string-append out "/share/doc/" ,name "-" ,version)))
+ (install-file "OFL.txt" doc)
+ #t))))))
+ (home-page "https://floriankarsten.github.io/space-grotesk/")
+ (synopsis "Proportional variant of the fixed-width Space Mono family")
+ (description
+ "Space Grotesk is a proportional sans-serif typeface variant based on Colophon
+Foundry's fixed-width Space Mono family. It retains the monospace's idiosyncratic
+details while optimizing for improved readability at non-display sizes.
+
+Space Grotesk includes Latin Vietnamese, Pinyin, and all Western, Central, and
+South-Eastern European language support, as well as several OpenType features:
+old-style and tabular figures, superscript and subscript numerals, fractions,
+and stylistic alternates.")
+ (license license:silofl1.1)))
+
(define-public font-go
(let ((commit "f03a046406d4d7fbfd4ed29f554da8f6114049fc")
(revision "1"))
@@ -1787,7 +1846,7 @@ This package provides the TrueType fonts.")
(define-public font-jetbrains-mono
(package
(name "font-jetbrains-mono")
- (version "2.210")
+ (version "2.221")
(source
(origin
(method url-fetch)
@@ -1795,7 +1854,7 @@ This package provides the TrueType fonts.")
(string-append "https://github.com/JetBrains/JetBrainsMono/releases/"
"download/v" version "/JetBrainsMono-" version ".zip"))
(sha256
- (base32 "19wbggnmqs3k1wdqy7l7imnx23g7hh159pl32nz3mzz8s8sqfdix"))))
+ (base32 "1acrgv2q9vxviirpi01xy67pkkswyssw4dn5pgyvrnjxr85cgjrg"))))
(build-system font-build-system)
(arguments
`(#:phases
@@ -1822,7 +1881,7 @@ in small sizes, the text looks crisper.")
(define-public font-juliamono
(package
(name "font-juliamono")
- (version "0.025")
+ (version "0.031")
(source
(origin
(method git-fetch)
@@ -1831,7 +1890,7 @@ in small sizes, the text looks crisper.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1w8mpl9zc1y4j1f26ikbz5g9dqsszhikp4r9p1d3ch3b5ayb5c3m"))))
+ (base32 "0pcz2qaw0g0gak4plvhgg3m76h4gamffa373r52dzx0qwn1i1cf1"))))
(build-system font-build-system)
(arguments
`(#:phases