summaryrefslogtreecommitdiff
path: root/gnu/packages/fonts.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/fonts.scm')
-rw-r--r--gnu/packages/fonts.scm107
1 files changed, 85 insertions, 22 deletions
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 5a913441e9..f4c62ee69c 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -36,6 +36,7 @@
;;; Copyright © 2020 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2020 Zhu Zihao <all_but_last@163.com>
;;; Copyright © 2020 Simen Endsjø <simendsjo@gmail.com>
+;;; Copyright © 2020 Tim Van den Langenbergh <tmt_vdl@gmx.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -384,6 +385,35 @@ Biolinum is available in both Regular and Bold weights.")
;; The fonts are released under either of these licenses.
(license (list license:gpl2+ license:silofl1.1))))
+(define-public font-libertinus
+ (package
+ (name "font-libertinus")
+ (version "6.12")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/alerque/libertinus/releases"
+ "/download/v" version "/libertinus-" version
+ ".zip"))
+ (sha256
+ (base32 "06pcsd5pijjid7xjxak35jla089krm5hqnbglv8ldncq475q7kb2"))))
+ (build-system font-build-system)
+ (home-page "https://github.com/alerque/libertinus")
+ (synopsis "Font family based on Linux Libertine")
+ (description
+ "The Libertinus font family is a fork of Linux Libertine that addresses
+many bugs in the unmaintained original and adds a new mathematical companion
+font for use with OpenType math-capable applications like LuaTex or XeTeX.
+
+The unified Libertinus family consists of:
+@enumerate
+@item Libertinus Serif, forked from Linux Libertine;
+@item Libertinus Sans Serif, forked from Linux Biolinum;
+@item Libertinus Mono, forked from Linux Libertine Mono; and
+@item Libertinus Math, an original matching OpenType math font.
+@end enumerate\n")
+ (license license:silofl1.1)))
+
(define-public font-terminus
(package
(name "font-terminus")
@@ -431,7 +461,7 @@ for long periods of working with computers (8 or more hours per day).")
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/adobe-fonts/source-han-sans.git")
+ (url "https://github.com/adobe-fonts/source-han-sans")
(commit (string-append version "R"))))
(file-name (git-file-name name version))
(sha256
@@ -680,7 +710,7 @@ for use at smaller text sizes")))
(define-public font-gnu-unifont
(package
(name "font-gnu-unifont")
- (version "13.0.02")
+ (version "13.0.03")
(source
(origin
(method url-fetch)
@@ -690,7 +720,7 @@ for use at smaller text sizes")))
(string-append "mirror://gnu/unifont/unifont-"
version "/unifont-" version ".tar.gz")))
(sha256
- (base32 "1fg908qadh14kfbpzqfj3vgzlxgx68sdlwhl2prz7arq5r45dami"))))
+ (base32 "04l2sbg6il78qsj3jxqfbz5k1xzihvw8vdlckgkp4zfr0nh2q7h7"))))
(build-system gnu-build-system)
(outputs '("out" ; TrueType version
"pcf" ; PCF (bitmap) version
@@ -817,7 +847,7 @@ It contains the following fonts and styles:
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/belluzj/fantasque-sans.git")
+ (url "https://github.com/belluzj/fantasque-sans")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
@@ -900,7 +930,7 @@ Powerline support.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/adobe-fonts/source-code-pro.git")
+ (url "https://github.com/adobe-fonts/source-code-pro")
(commit (regexp-substitute/global
;; The upstream tag uses "/" between the roman and italic
;; versions, so substitute our "-" separator here.
@@ -925,7 +955,7 @@ designed to work well in user interface environments.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/adobe-fonts/source-sans-pro.git")
+ (url "https://github.com/adobe-fonts/source-sans-pro")
(commit (regexp-substitute/global
;; The upstream tag uses "/" between the roman and italic
;; versions, so substitute our "-" separator here.
@@ -950,7 +980,7 @@ work well in user interface (UI) environments.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/adobe-fonts/source-serif-pro.git")
+ (url "https://github.com/adobe-fonts/source-serif-pro")
(commit (regexp-substitute/global
;; The upstream tag uses "/" between the roman and italic
;; versions, so substitute our "-" separator here.
@@ -993,7 +1023,7 @@ Sans Pro family.")
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/mozilla/Fira.git")
+ (url "https://github.com/mozilla/Fira")
(commit version)))
(file-name (git-file-name name version))
(sha256
@@ -1038,7 +1068,7 @@ correct spacing.")
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/FortAwesome/Font-Awesome.git")
+ (url "https://github.com/FortAwesome/Font-Awesome")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
@@ -1075,7 +1105,7 @@ vector graphics.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/sunaku/tamzen-font.git")
+ (url "https://github.com/sunaku/tamzen-font")
(commit (string-append "Tamzen-" version))))
(file-name (git-file-name name version))
(sha256
@@ -1172,7 +1202,7 @@ typeface, by mimicking Comic Sans while fixing its most obvious shortcomings.")
(package
(name "font-iosevka")
;; When updating, also update the hash of the Iosevka variant(s) below.
- (version "3.1.1")
+ (version "3.2.2")
(source
(origin
(method url-fetch/zipbomb)
@@ -1180,7 +1210,7 @@ typeface, by mimicking Comic Sans while fixing its most obvious shortcomings.")
"/releases/download/v" version
"/ttc-iosevka-" version ".zip"))
(sha256
- (base32 "1xnkfr11rdjnin2fvgkp9vxxigfbfdncr0wy6n78mlm3p1pqwfrm"))))
+ (base32 "16iqr4zjlshrgzcs3sjp3gz777gpi069r7p7scqi6vap9acqjvph"))))
(build-system font-build-system)
(home-page "https://be5invis.github.io/Iosevka/")
(synopsis "Coders' typeface, built from code")
@@ -1203,7 +1233,7 @@ programming. Iosevka is completely generated from its source code.")
"/releases/download/v" version
"/ttc-iosevka-slab-" version ".zip"))
(sha256
- (base32 "1n3lh015mvsdbyygpg3p3yqjpqdn1fdvjh1bhi2ggjanhifjsgzh"))))))
+ (base32 "0knsb1b0wqv50r7f9128xvq344x7hnvgm7kh1dxaahlck910z62x"))))))
(define-public font-iosevka-term
(package
@@ -1218,7 +1248,7 @@ programming. Iosevka is completely generated from its source code.")
"/ttf-iosevka-term-" version ".zip"))
(sha256
(base32
- "1mwzwpdppmcf03fgb5q6ksj0kk93wwaz2isk24wj1cm66r8psxk0"))))
+ "0nyq6iq9xjn9nqwh1fh4v0pvblycmm8ssw7y3vcjv1ymbkdqfqhr"))))
(arguments
`(#:phases
(modify-phases %standard-phases
@@ -1240,7 +1270,7 @@ programming. Iosevka is completely generated from its source code.")
"/ttf-iosevka-term-slab-" version ".zip"))
(sha256
(base32
- "0fiwxkf2gv38ia695wh8cvnb58sqs3fixjd33q1pp9cps94wzjpg"))))
+ "1blhhbnk2hyaxjrz88icd2gwyniq5idxd0h6rqx6vjcack6094z0"))))
(arguments
`(#:phases
(modify-phases %standard-phases
@@ -1261,7 +1291,7 @@ programming. Iosevka is completely generated from its source code.")
"/releases/download/v" version
"/ttc-iosevka-aile-" version ".zip"))
(sha256
- (base32 "15kz8ahlynnb79s2d367a1fallc4l3j3957yj43qrymayagkh8sv"))))))
+ (base32 "1zg0gn4gcf3w8n8jzf93y9ninyn3bci31c5zss3mxzz1lzfm8zd5"))))))
(define-public font-iosevka-etoile
(package
@@ -1275,7 +1305,7 @@ programming. Iosevka is completely generated from its source code.")
"/releases/download/v" version
"/ttc-iosevka-etoile-" version ".zip"))
(sha256
- (base32 "0q9299mc595m251v9zj9b0zparl2qq8dwx090l0jkfpr2az9xr8q"))))))
+ (base32 "1061yaf35f19dcym4k552q1yzbsbc98r3glm9frslirra9f33sl2"))))))
(define-public font-iosevka-sparkle
(package
@@ -1289,7 +1319,7 @@ programming. Iosevka is completely generated from its source code.")
"/releases/download/v" version
"/ttc-iosevka-sparkle-" version ".zip"))
(sha256
- (base32 "0nhvcnvl11iqmsxsyrxlbnwy9z1vdhqv6p3g7fig9ra6n5j9k5kn"))))))
+ (base32 "1c1s9j6qgyhn4md0kql0x2201nbs5jx3612jf8q020gm484xqq03"))))))
(define-public font-sarasa-gothic
(package
@@ -1358,7 +1388,7 @@ monospace, slab-serif fonts.")
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/google/material-design-icons.git")
+ (url "https://github.com/google/material-design-icons")
(commit version)))
(file-name (git-file-name name version))
(sha256
@@ -1628,7 +1658,7 @@ formatting.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/uswds/public-sans.git")
+ (url "https://github.com/uswds/public-sans")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
@@ -1711,7 +1741,7 @@ This package provides the TrueType fonts.")
(define-public font-jetbrains-mono
(package
(name "font-jetbrains-mono")
- (version "1.0.3")
+ (version "2.001")
(source
(origin
(method url-fetch)
@@ -1719,8 +1749,17 @@ This package provides the TrueType fonts.")
(string-append "https://download.jetbrains.com/fonts/"
"JetBrainsMono-" version ".zip"))
(sha256
- (base32 "0zvhwmpdwpm4vywmm6i9a4najz0c7vfi411yikgkd66l5hwd1p6f"))))
+ (base32 "0r3dk3kn536rik4mvpcjin9mwmifl3v8mawvb4a5l59pww0vcxzq"))))
(build-system font-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'install-license-files
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (doc (string-append out "/share/doc/" ,name "-" ,version)))
+ (install-file "../LICENSE" doc)
+ #t))))))
(home-page "https://www.jetbrains.com/lp/mono/")
(synopsis "Mono typeface for developers")
(description
@@ -1897,3 +1936,27 @@ languages, it contains Japanese characters, including Kana glyphs and more
than 5,300 Kanji glyphs, as well major international phonetic symbols,
operators and special symbols.")
(license (license:non-copyleft "file:///LICENSE_E"))))
+
+(define-public font-catamaran
+ (let ((commit "7559b4906f9c9148fb22c6f89508c3053a78a296")
+ (revision "1"))
+ (package
+ (name "font-catamaran")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/VanillaandCream/Catamaran-Tamil")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1wpp41l7j2kpgnyavhgxcc5wp852a4wqsnwravn39gp980s84yxw"))))
+ (build-system font-build-system)
+ (home-page "https://github.com/VanillaandCream/Catamaran-Tamil")
+ (synopsis "9 weight Tamil and Latin type")
+ (description "Catamaran is a 9 weight Tamil and Latin type. Catamaran
+is a stylish type with a polished yet relaxed feel. Its versatility makes it
+suitable for a wide range of uses.")
+ (license license:silofl1.1))))