summaryrefslogtreecommitdiff
path: root/gnu/packages/fonts.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/fonts.scm')
-rw-r--r--gnu/packages/fonts.scm27
1 files changed, 13 insertions, 14 deletions
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 1195695d7a..b0cb78c5cb 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -99,13 +99,14 @@ in print. With attention to detail for high resolution rendering.")
(name "font-ubuntu")
(version "0.83")
(source (origin
- (method url-fetch)
- (uri (string-append
- "http://font.ubuntu.com/download/ubuntu-font-family-"
- version ".zip"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://salsa.debian.org/fonts-team/fonts-ubuntu")
+ (commit (string-append "upstream/" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "0hjvq2x758dx0sfwqhzflns0ns035qm7h6ygskbx1svzg517sva5"))))
+ "1d2xrjpxy70f3nsgqiggwv6pj06qglf5vj2847pqx60w3ygi903g"))))
(build-system font-build-system)
(home-page "http://font.ubuntu.com/")
(synopsis "The Ubuntu Font Family")
@@ -621,7 +622,7 @@ languages, plus Greek and Cyrillic.")
(define-public font-gnu-unifont
(package
(name "font-gnu-unifont")
- (version "11.0.02")
+ (version "11.0.03")
(source (origin
(method url-fetch)
(uri (string-append
@@ -629,16 +630,14 @@ languages, plus Greek and Cyrillic.")
version ".tar.gz"))
(sha256
(base32
- "1di8i44c163b9l5f08jcrjfijnqz0j7p7hpfvf8dcms6cm6s4wvy"))))
+ "171zhm52c4rzpn19qcq4n9nyfbcjl38v50zslhvgpjdcmc5jvhav"))))
(build-system gnu-build-system)
- (outputs '("out" ; TrueType version
- "pcf" ; PCF (bitmap) version
- "psf" ; PSF (console) version
- "bin" ; Utilities to manipulate '.hex' format
- ))
+ (outputs '("out" ; TrueType version
+ "pcf" ; PCF (bitmap) version
+ "psf" ; PSF (console) version
+ "bin")) ; Utilities to manipulate '.hex' format
(arguments
- '(#:parallel-build? #f ; parallel build fails
- #:tests? #f ; no check target
+ '(#:tests? #f ; no check target
#:phases
(modify-phases %standard-phases
(replace