summaryrefslogtreecommitdiff
path: root/gnu/packages/flex.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/flex.scm')
-rw-r--r--gnu/packages/flex.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/flex.scm b/gnu/packages/flex.scm
index 82a2e98d98..0b290857fa 100644
--- a/gnu/packages/flex.scm
+++ b/gnu/packages/flex.scm
@@ -64,16 +64,16 @@
(home-page "http://flex.sourceforge.net/")
(synopsis "Fast lexical analyser generator")
(description
- "Flex is a tool for generating scanners. A scanner, sometimes
+ "Flex is a tool for generating scanners. A scanner, sometimes
called a tokenizer, is a program which recognizes lexical patterns in
-text. The flex program reads user-specified input files, or its standard
+text. The flex program reads user-specified input files, or its standard
input if no file names are given, for a description of a scanner to
-generate. The description is in the form of pairs of regular expressions
-and C code, called rules. Flex generates a C source file named,
-\"lex.yy.c\", which defines the function yylex(). The file \"lex.yy.c\"
-can be compiled and linked to produce an executable. When the executable
+generate. The description is in the form of pairs of regular expressions
+and C code, called rules. Flex generates a C source file named,
+\"lex.yy.c\", which defines the function yylex(). The file \"lex.yy.c\"
+can be compiled and linked to produce an executable. When the executable
is run, it analyzes its input for occurrences of text matching the
-regular expressions for each rule. Whenever it finds a match, it
+regular expressions for each rule. Whenever it finds a match, it
executes the corresponding C code.")
(license (bsd-style "file://COPYING"
"See COPYING in the distribution."))))