summaryrefslogtreecommitdiff
path: root/gnu/packages/firmware.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/firmware.scm')
-rw-r--r--gnu/packages/firmware.scm48
1 files changed, 24 insertions, 24 deletions
diff --git a/gnu/packages/firmware.scm b/gnu/packages/firmware.scm
index 8d0b824784..7a57300b41 100644
--- a/gnu/packages/firmware.scm
+++ b/gnu/packages/firmware.scm
@@ -52,31 +52,31 @@
(patches (search-patches "ath9k-htc-firmware-objcopy.patch"))))
(build-system gnu-build-system)
(arguments
- '(#:phases (alist-cons-before
- 'configure 'pre-configure
- (lambda* (#:key inputs #:allow-other-keys)
- (chdir "target_firmware")
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'pre-configure
+ (lambda* (#:key inputs #:allow-other-keys)
+ (chdir "target_firmware")
- ;; 'configure' is a simple script that runs 'cmake' with
- ;; the right flags.
- (substitute* "configure"
- (("^TOOLCHAIN=.*$")
- (string-append "TOOLCHAIN="
- (assoc-ref inputs "cross-gcc")
- "\n"))))
- (alist-replace
- 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (fw-dir (string-append out "/lib/firmware")))
- (mkdir-p fw-dir)
- (for-each (lambda (file)
- (copy-file file
- (string-append fw-dir "/"
- (basename file))))
- (find-files "." "\\.fw$"))
- #t))
- %standard-phases))
+ ;; 'configure' is a simple script that runs 'cmake' with
+ ;; the right flags.
+ (substitute* "configure"
+ (("^TOOLCHAIN=.*$")
+ (string-append "TOOLCHAIN="
+ (assoc-ref inputs "cross-gcc")
+ "\n")))
+ #t))
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (fw-dir (string-append out "/lib/firmware")))
+ (mkdir-p fw-dir)
+ (for-each (lambda (file)
+ (copy-file file
+ (string-append fw-dir "/"
+ (basename file))))
+ (find-files "." "\\.fw$"))
+ #t))))
#:tests? #f))
;; The firmware is cross-compiled using a "bare bones" compiler (no libc.)