summaryrefslogtreecommitdiff
path: root/gnu/packages/finance.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/finance.scm')
-rw-r--r--gnu/packages/finance.scm77
1 files changed, 21 insertions, 56 deletions
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index bbc245e2da..2914d7a95f 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -11,7 +11,7 @@
;;; Copyright © 2018 Adriano Peluso <catonano@gmail.com>
;;; Copyright © 2018, 2019, 2020 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2018 Arun Isaac <arunisaac@systemreboot.net>
-;;; Copyright © 2019, 2020 Guillaume Le Vaillant <glv@posteo.net>
+;;; Copyright © 2019, 2020, 2021 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2019 Tanguy Le Carrour <tanguy@bioneland.org>
;;; Copyright © 2019, 2020 Martin Becze <mjbecze@riseup.net>
;;; Copyright © 2019 Sebastian Schott <sschott@mailbox.org>
@@ -92,6 +92,7 @@
#:use-module (gnu packages popt)
#:use-module (gnu packages protobuf)
#:use-module (gnu packages python)
+ #:use-module (gnu packages python-build)
#:use-module (gnu packages python-crypto)
#:use-module (gnu packages python-web)
#:use-module (gnu packages python-xyz)
@@ -632,7 +633,7 @@ other machines/servers. Electroncash does not download the Bitcoin Cash blockch
;; the system's dynamically linked library.
(package
(name "monero")
- (version "0.17.1.7")
+ (version "0.17.1.9")
(source
(origin
(method git-fetch)
@@ -652,7 +653,7 @@ other machines/servers. Electroncash does not download the Bitcoin Cash blockch
"external/unbound"))
#t))
(sha256
- (base32 "1fdw4i4rw87yz3hz4yc1gdw0gr2mmf9038xaw2l4rrk5y50phjp4"))))
+ (base32 "0jqss4csvkcrhrmaa3vrnyv6yiwqpbfw7037clx9xcfm4qrrfiwy"))))
(build-system cmake-build-system)
(native-inputs
`(("doxygen" ,doxygen)
@@ -742,16 +743,24 @@ the Monero command line client and daemon.")
(define-public monero-gui
(package
(name "monero-gui")
- (version "0.17.1.7")
+ (version "0.17.1.9")
(source
(origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/monero-project/monero-gui")
- (commit (string-append "v" version))))
+ (commit (string-append "v" version))
+ (recursive? #t)))
(file-name (git-file-name name version))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; Delete bundled monero sources, we already have them.
+ ;; See the 'extract-monero-sources' phase.
+ (delete-file-recursively "monero")
+ #t))
(sha256
- (base32 "1dd2ddkxh9ynxnscysl46hj4dm063h1v13fnyah69am26qzzbby4"))))
+ (base32 "0vpvpvsbbj547yir15g84qy9l9lwbip795zlliz79i7d66l23b1w"))))
(build-system qt-build-system)
(native-inputs
`(,@(package-native-inputs monero)
@@ -780,6 +789,7 @@ the Monero command line client and daemon.")
;; Some of the monero package source code is required
;; to build the GUI.
(lambda* (#:key inputs #:allow-other-keys)
+ (mkdir-p "monero")
(invoke "tar" "-xv" "--strip-components=1"
"-C" "monero"
"-f" (assoc-ref inputs "monero-source"))))
@@ -1373,56 +1383,6 @@ following three utilities are included with the library:
@end enumerate")
(license license:gpl2+)))
-(define-public opensp
- (package
- (name "opensp")
- (version "1.5.2")
- (source (origin
- (method url-fetch)
- (uri (string-append "mirror://sourceforge/openjade/opensp/"
- version "/OpenSP-" version ".tar.gz"))
- (sha256
- (base32
- "1khpasr6l0a8nfz6kcf3s81vgdab8fm2dj291n5r2s53k228kx2p"))))
- (build-system gnu-build-system)
- (native-inputs
- `(("gettext" ,gettext-minimal)))
- (inputs
- `(("docbook-xml" ,docbook-xml-4.1.2)
- ("docbook-xsl" ,docbook-xsl)
- ("xmlto" ,xmlto)))
- (arguments
- `(;; TODO: Fix and enable tests.
- #:tests? #f
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'patch-docbook-paths
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((xmldoc (string-append (assoc-ref inputs "docbook-xml")
- "/xml/dtd/docbook"))
- (xsldoc (string-append (assoc-ref inputs "docbook-xsl")
- "/xml/xsl/docbook-xsl-"
- ,(package-version docbook-xsl))))
- (substitute* (find-files "docsrc" "\\.xml$")
- (("/usr/share/sgml/docbook/xml-dtd-4.1.2") xmldoc)
- (("http://.*/docbookx\\.dtd")
- (string-append xmldoc "/docbookx.dtd")))
- ;; Directly pass the path to the stylesheet to xmlto.
- (substitute* "docsrc/Makefile.in"
- (("\\$\\(XMLTO\\)")
- (string-append "$(XMLTO) -x " xsldoc
- "/manpages/docbook.xsl")))
- #t))))))
- (home-page "http://openjade.sourceforge.net/")
- (synopsis "Suite of SGML/XML processing tools")
- (description "OpenSP is an object-oriented toolkit for SGML parsing and
-entity management.")
- (license
- ;; expat license with added clause regarding advertising
- (license:non-copyleft
- "file://COPYING"
- "See COPYING in the distribution."))))
-
(define-public bitcoin-unlimited
(package
(name "bitcoin-unlimited")
@@ -1476,6 +1436,11 @@ entity management.")
(modify-phases %standard-phases
(add-after 'unpack 'fix-tests
(lambda _
+ ;; Fix data specific test failure
+ ;; https://reviews.bitcoinabc.org/rABC67bbd3d0aaee2952ff1cb5da51d1fd0b50c2b63a
+ (substitute* "src/test/rpc_tests.cpp"
+ (("1607731200") "9907731200"))
+
;; Disable utilprocess_tests because it never ends.
;; It looks like it tries to start /bin/sleep and waits until it
;; is in the list of running processes, but /bin/sleep doesn't