summaryrefslogtreecommitdiff
path: root/gnu/packages/finance.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/finance.scm')
-rw-r--r--gnu/packages/finance.scm41
1 files changed, 16 insertions, 25 deletions
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 28bfb28f49..7d7c3ab111 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -165,6 +165,13 @@ line client and a client based on Qt.")
#:make-flags (list "ARGS=-E BaselineTest_cmd-org")
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'boost-compat
+ (lambda _
+ (substitute* "src/utils.h"
+ ;; This library moved in Boost 1.66. Remove for Ledger
+ ;; versions > 3.1.1.
+ (("boost/uuid/sha1.hpp") "boost/uuid/detail/sha1.hpp"))
+ #t))
(add-before 'configure 'install-examples
(lambda* (#:key outputs #:allow-other-keys)
(let ((examples (string-append (assoc-ref outputs "out")
@@ -840,7 +847,7 @@ Luhn and family of ISO/IEC 7064 check digit algorithms. ")
(define-public python-duniterpy
(package
(name "python-duniterpy")
- (version "0.43.7")
+ (version "0.50.0")
(source
(origin
(method git-fetch)
@@ -851,10 +858,14 @@ Luhn and family of ISO/IEC 7064 check digit algorithms. ")
(file-name (git-file-name name version))
(sha256
(base32
- "19m36z98361bqxjdb65597j2kxbly491927c6p9z47s1vxc3raaq"))))
+ "0f24ihglmzphy30pgc49w0rxmsjc76mgcggg078cfsz7xrrk13gf"))))
(build-system python-build-system)
+ (arguments
+ ;; Tests fail with "AttributeError: module 'attr' has no attribute 's'".
+ `(#:tests? #f))
(propagated-inputs
`(("python-aiohttp" ,python-aiohttp)
+ ("python-attr" ,python-attr)
("python-base58" ,python-base58)
("python-jsonschema" ,python-jsonschema)
("python-libnacl" ,python-libnacl)
@@ -875,7 +886,7 @@ main features are:
(define-public silkaj
(package
(name "silkaj")
- (version "0.5.0")
+ (version "0.6.0")
(source
(origin
(method git-fetch)
@@ -885,30 +896,10 @@ main features are:
(file-name (git-file-name name version))
(sha256
(base32
- "0xy25lpgz04nxikjvxlnlckrc9xmsxyiz2qm0bsiid8cnbdqcn12"))))
+ "02n028rz1pshgh7w0af3b291r8lwvhzskm1q98d991gr8rscvad2"))))
(build-system python-build-system)
(arguments
- `(#:tests? #f ;no test
- #:phases
- (modify-phases %standard-phases
- ;; The program is just a bunch of Python files in "src/" directory.
- ;; Many phases are useless. However, `python-build-system' correctly
- ;; sets PYTHONPATH and patches Python scripts.
- (delete 'configure)
- (delete 'build)
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (share (string-append out "/share/silkaj"))
- (executable (string-append share "/silkaj.py"))
- (bin (string-append out "/bin")))
- ;; Install data.
- (copy-recursively "src" share)
- ;; Install executable.
- (mkdir-p bin)
- (with-directory-excursion bin
- (symlink executable "silkaj")))
- #t)))))
+ `(#:tests? #f)) ;no test
(inputs
`(("python-commandlines" ,python-commandlines)
("python-ipaddress" ,python-ipaddress)