summaryrefslogtreecommitdiff
path: root/gnu/packages/enlightenment.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/enlightenment.scm')
-rw-r--r--gnu/packages/enlightenment.scm82
1 files changed, 65 insertions, 17 deletions
diff --git a/gnu/packages/enlightenment.scm b/gnu/packages/enlightenment.scm
index cff5ab14a9..40a5ec1cf4 100644
--- a/gnu/packages/enlightenment.scm
+++ b/gnu/packages/enlightenment.scm
@@ -62,7 +62,7 @@
(define-public efl
(package
(name "efl")
- (version "1.20.7")
+ (version "1.21.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -70,7 +70,7 @@
version ".tar.xz"))
(sha256
(base32
- "1zkn5ix81xck3n84dxvkjh4alwc6zj8x989d0zqi5c6ppijvgadh"))))
+ "0jxfrcz2aq1synxzd6sh9nhxz7fg9qgz0idr8zj6gaiplmwbwrby"))))
(outputs '("out" ; 49 MB
"include")) ; 17 MB
(build-system gnu-build-system)
@@ -312,35 +312,36 @@ embedded systems.")
(define-public python-efl
(package
(name "python-efl")
- (version "1.20.0")
+ (version "1.21.0")
(source
(origin
(method url-fetch)
- (uri (list
- (pypi-uri "python-efl" version)
- (string-append "http://download.enlightenment.org/rel/bindings/"
- "python/python-efl-" version ".tar.gz")))
+ (uri (string-append "http://download.enlightenment.org/rel/bindings/"
+ "python/python-efl-" version ".tar.xz"))
(sha256
(base32
- "1680pgpf501nhbc9arm0nfj6rpcw17aryh0pgmmmszxlgpifpdzy"))))
+ "08x2cv8hnf004c3711250wrax21ffj5y8951pvk77h98als4pq47"))))
(build-system python-build-system)
(arguments
'(#:phases
(modify-phases %standard-phases
- (replace 'build
- (lambda _
- (zero?
- (system* "env" "ENABLE_CYTHON=1" "python" "setup.py" "build"))))
+ (replace 'build
+ (lambda _
+ (setenv "ENABLE_CYTHON" "1")
+ (invoke "python" "setup.py" "build")))
(add-before 'build 'set-flags
- (lambda _
- (setenv "CFLAGS"
- (string-append "-I" (assoc-ref %build-inputs "python-dbus")
- "/include/dbus-1.0"))
- #t))
+ (lambda _
+ (setenv "CFLAGS"
+ (string-append "-I" (assoc-ref %build-inputs "python-dbus")
+ "/include/dbus-1.0"))
+ #t))
(add-before 'check 'set-environment
(lambda _
;; Some tests require write access to HOME.
(setenv "HOME" "/tmp")
+ ;; These tests try to connect to the internet.
+ (delete-file "tests/ecore/test_09_file_download.py")
+ (delete-file "tests/ecore/test_11_con.py")
#t)))))
(native-inputs
`(("pkg-config" ,pkg-config)
@@ -421,3 +422,50 @@ and in creating applications based on the Enlightenment Foundation Library suite
"Simple PDF viewer based on the Enlightenment Foundation Libraries.")
(home-page "https://github.com/kaihu/lekha")
(license license:gpl3+)))
+
+(define-public ephoto
+ (package
+ (name "ephoto")
+ (version "1.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (list (string-append "http://www.smhouston.us/stuff/ephoto-"
+ version ".tar.xz")
+ (string-append "https://download.enlightenment.org/rel/"
+ "apps/ephoto/ephoto-" version ".tar.xz")))
+ (sha256
+ (base32
+ "04kli43sfsy6s660g13pjc0kjmgdcmq8m4qh02vvpcwv60mf9mgz"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'set-home-directory
+ ;; FATAL: Cannot create run dir '/homeless-shelter/.run' - errno=2
+ (lambda _ (setenv "HOME" "/tmp") #t)))))
+ (native-inputs
+ `(("check" ,check)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("efl" ,efl)))
+ (home-page "http://smhouston.us/ephoto/")
+ (synopsis "EFL image viewer/editor/manipulator/slideshow creator")
+ (description "Ephoto is an image viewer and editor written using the
+@dfn{Enlightenment Foundation Libraries} (EFL). It focuses on simplicity and ease
+of use, while taking advantage of the speed and small footprint the EFL provide.
+
+Ephoto’s features include:
+@enumerate
+@item Browsing the filesystem and displaying images in an easy to use grid view.
+@item Browsing images in a single image view format.
+@item Viewing images in a slideshow.
+@item Editing your image with features such as cropping, auto enhance,
+blurring, sharpening, brightness/contrast/gamma adjustments, hue/saturation/value
+adjustments, and color level adjustment.
+@item Applying artistic filters to your image such as black and white and old photo.
+@item Drag And Drop along with file operations to easy maintain your photo directories.
+@end enumerate\n")
+ (license (list
+ license:bsd-2 ; Ephoto's thumbnailing code
+ license:bsd-3))))