summaryrefslogtreecommitdiff
path: root/gnu/packages/enlightenment.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/enlightenment.scm')
-rw-r--r--gnu/packages/enlightenment.scm35
1 files changed, 18 insertions, 17 deletions
diff --git a/gnu/packages/enlightenment.scm b/gnu/packages/enlightenment.scm
index dc3114d58b..ed15cd28d2 100644
--- a/gnu/packages/enlightenment.scm
+++ b/gnu/packages/enlightenment.scm
@@ -31,7 +31,6 @@
#:use-module (guix build-system python)
#:use-module (gnu packages)
#:use-module (gnu packages algebra)
- #:use-module (gnu packages avahi)
#:use-module (gnu packages bittorrent)
#:use-module (gnu packages check)
#:use-module (gnu packages code)
@@ -69,7 +68,7 @@
(define-public efl
(package
(name "efl")
- (version "1.24.3")
+ (version "1.25.1")
(source (origin
(method url-fetch)
(uri (string-append
@@ -77,10 +76,10 @@
version ".tar.xz"))
(sha256
(base32
- "0ajwc8lmay5ai7nsrp778g393h0p4h98p4c22gic2w61fgkcd5fy"))))
+ "0svybbrvpf6q955y6fclxh3md64z0dgmh0x54x2j60503hhs071m"))))
(build-system meson-build-system)
(native-inputs
- `(("check" ,check)
+ `(("check" ,check-0.14)
("gettext" ,gettext-minimal)
("pkg-config" ,pkg-config)))
(inputs
@@ -115,8 +114,7 @@
(propagated-inputs
;; All these inputs are in package config files in section
;; Requires.private.
- `(("avahi" ,avahi)
- ("dbus" ,dbus)
+ `(("dbus" ,dbus)
("elogind" ,elogind)
("eudev" ,eudev)
("fontconfig" ,fontconfig)
@@ -137,13 +135,9 @@
("wayland" ,wayland)
("zlib" ,zlib)))
(arguments
- `(#:configure-flags '("-Dsystemd=false"
- "-Delogind=true"
- "-Dembedded-lz4=false"
- "-Devas-loaders-disabler=json"
+ `(#:configure-flags '("-Dembedded-lz4=false"
"-Dbuild-examples=false"
"-Decore-imf-loaders-disabler=scim"
- "-Davahi=true"
"-Dglib=true"
"-Dmount-path=/run/setuid-programs/mount"
"-Dunmount-path=/run/setuid-programs/umount"
@@ -164,6 +158,7 @@
(let ((curl (assoc-ref inputs "curl"))
(pulse (assoc-ref inputs "pulseaudio"))
(sndfile (assoc-ref inputs "libsndfile"))
+ (elogind (assoc-ref inputs "elogind"))
(lib "/lib/"))
(substitute* "src/lib/ecore_con/ecore_con_url_curl.c"
(("libcurl.so.?" libcurl) ; libcurl.so.[45]
@@ -173,6 +168,9 @@
(string-append pulse lib libpulse))
(("libsndfile.so.1" libsnd)
(string-append sndfile lib libsnd)))
+ (substitute* "src/lib/elput/elput_logind.c"
+ (("libelogind.so.0" libelogind)
+ (string-append elogind "/lib/" libelogind)))
#t)))
(add-after 'unpack 'fix-install-paths
(lambda _
@@ -181,6 +179,8 @@
"install_dir: join_paths(dir_data, 'dbus-1', 'services'))\n"))
(substitute* "src/tests/elementary/meson.build"
(("dir_data") "meson.source_root(), 'test-output'"))
+ (substitute* "data/eo/meson.build"
+ (("'usr', 'lib'") "'./' + dir_lib"))
#t))
(add-after 'unpack 'set-home-directory
;; FATAL: Cannot create run dir '/homeless-shelter/.run' - errno=2
@@ -385,7 +385,7 @@ embedded systems.")
(define-public python-efl
(package
(name "python-efl")
- (version "1.24.0")
+ (version "1.25.0")
(source
(origin
(method url-fetch)
@@ -393,7 +393,7 @@ embedded systems.")
"python/python-efl-" version ".tar.xz"))
(sha256
(base32
- "1vk1cdd959gia4a9qzyq56a9zw3lqf9ck66k8c9g3c631mp5cfpy"))
+ "0bk161xwlz4dlv56r68xwkm8snzfifaxd1j7w2wcyyk4fgvnvq4r"))
(modules '((guix build utils)))
;; Remove files generated by Cython
(snippet
@@ -470,7 +470,7 @@ Libraries stack (eo, evas, ecore, edje, emotion, ethumb and elementary).")
(lambda _ (setenv "HOME" "/tmp") #t)))
#:tests? #f)) ; tests require running dbus service
(native-inputs
- `(("check" ,check)
+ `(("check" ,check-0.14)
("gettext" ,gettext-minimal)
("pkg-config" ,pkg-config)))
(inputs
@@ -566,19 +566,20 @@ directories.
(define-public evisum
(package
(name "evisum")
- (version "0.5.4")
+ (version "0.5.6")
(source
(origin
(method url-fetch)
(uri (string-append "https://download.enlightenment.org/rel/apps/"
"evisum/evisum-" version ".tar.xz"))
(sha256
- (base32 "1ip3w2d476g45sivqvm1madfyqmkni9q2i99qqxk53859jgs91pa"))))
+ (base32 "1l8pym7738kncvic5ga03sj9d5igigvmcxa9lbg47z2yvdjwzv97"))))
(build-system meson-build-system)
(arguments
'(#:tests? #f)) ; no tests
(native-inputs
- `(("pkg-config" ,pkg-config)))
+ `(("gettext" ,gettext-minimal)
+ ("pkg-config" ,pkg-config)))
(inputs
`(("efl" ,efl)))
(home-page "https://www.enlightenment.org")