summaryrefslogtreecommitdiff
path: root/gnu/packages/enlightenment.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/enlightenment.scm')
-rw-r--r--gnu/packages/enlightenment.scm40
1 files changed, 25 insertions, 15 deletions
diff --git a/gnu/packages/enlightenment.scm b/gnu/packages/enlightenment.scm
index 5e34303f14..259c44dc58 100644
--- a/gnu/packages/enlightenment.scm
+++ b/gnu/packages/enlightenment.scm
@@ -50,6 +50,7 @@
#:use-module (gnu packages gtk)
#:use-module (gnu packages ibus)
#:use-module (gnu packages image)
+ #:use-module (gnu packages libunwind)
#:use-module (gnu packages linux)
#:use-module (gnu packages llvm)
#:use-module (gnu packages lua)
@@ -91,7 +92,11 @@
("ibus" ,ibus)
("mesa" ,mesa)
("libraw" ,libraw)
- ("librsvg" ,librsvg)
+ ;; Only enable the optional SVG support on x86_64, as this is the only
+ ;; architecture where librsvg can be built.
+ ,@(if (target-x86-64?)
+ `(("librsvg" ,librsvg))
+ '())
("libspectre" ,libspectre)
("libtiff" ,libtiff)
("libxau" ,libxau)
@@ -127,6 +132,7 @@
("libjpeg" ,libjpeg-turbo)
("libsndfile" ,libsndfile)
("libpng" ,libpng)
+ ("libunwind" ,libunwind)
("libx11" ,libx11)
("libxkbcommon" ,libxkbcommon)
("luajit" ,luajit)
@@ -136,20 +142,23 @@
("wayland" ,wayland)
("zlib" ,zlib)))
(arguments
- `(#:configure-flags '("-Dembedded-lz4=false"
- "-Dbuild-examples=false"
- "-Decore-imf-loaders-disabler=scim"
- "-Dglib=true"
- "-Dmount-path=/run/setuid-programs/mount"
- "-Dunmount-path=/run/setuid-programs/umount"
- ;(string-append "-Ddictionaries-hyphen-dir="
- ; (assoc-ref %build-inputs "hyphen")
- ; "/share/hyphen")
- "-Dnetwork-backend=connman"
- ;; for wayland
- "-Dwl=true"
- "-Ddrm=true")
- #:tests? #f ; Many tests fail due to timeouts and network requests.
+ `(#:configure-flags
+ `("-Dembedded-lz4=false"
+ "-Dbuild-examples=false"
+ "-Decore-imf-loaders-disabler=scim"
+ "-Dglib=true"
+ "-Dmount-path=/run/setuid-programs/mount"
+ "-Dunmount-path=/run/setuid-programs/umount"
+ "-Dnetwork-backend=connman"
+ ;; Add 'rsvg' to the default list (json and avif) of disabled loaders
+ ;; unless librsvg is available.
+ ,,@(if (target-x86-64?)
+ '()
+ (list "-Devas-loaders-disabler=json,avif,rsvg"))
+ ;; For Wayland.
+ "-Dwl=true"
+ "-Ddrm=true")
+ #:tests? #f ; Many tests fail due to timeouts and network requests.
#:phases
(modify-phases %standard-phases
;; If we don't hardcode the location of libcurl.so and others then we
@@ -360,6 +369,7 @@ Libraries with some extra bells and whistles.")
("bluez" ,bluez)
("dbus" ,dbus)
("freetype" ,freetype)
+ ("libdrm" ,libdrm)
("libxcb" ,libxcb)
("libxext" ,libxext)
("linux-pam" ,linux-pam)