summaryrefslogtreecommitdiff
path: root/gnu/packages/enlightenment.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/enlightenment.scm')
-rw-r--r--gnu/packages/enlightenment.scm39
1 files changed, 35 insertions, 4 deletions
diff --git a/gnu/packages/enlightenment.scm b/gnu/packages/enlightenment.scm
index 25b8caf306..ca97104958 100644
--- a/gnu/packages/enlightenment.scm
+++ b/gnu/packages/enlightenment.scm
@@ -31,6 +31,7 @@
#:use-module (gnu packages compression)
#:use-module (gnu packages curl)
#:use-module (gnu packages fontutils)
+ #:use-module (gnu packages freedesktop)
#:use-module (gnu packages fribidi)
#:use-module (gnu packages game-development)
#:use-module (gnu packages gettext)
@@ -56,7 +57,7 @@
(define-public efl
(package
(name "efl")
- (version "1.18.2")
+ (version "1.18.4")
(source (origin
(method url-fetch)
(uri (string-append
@@ -64,7 +65,7 @@
version ".tar.xz"))
(sha256
(base32
- "1vbvsrrpkvvrmvjavwnp5q77kw5i7vmbaj2vq5mnmrbzamvaybr9"))))
+ "09c0ajszjarcs6d62zlgnf1aha2f921mfr0gxg6nwza36xzc1srr"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)))
@@ -196,7 +197,7 @@ Libraries with some extra bells and whistles.")
(define-public enlightenment
(package
(name "enlightenment")
- (version "0.21.3")
+ (version "0.21.5")
(source (origin
(method url-fetch)
(uri
@@ -204,7 +205,7 @@ Libraries with some extra bells and whistles.")
name "/" name "-" version ".tar.xz"))
(sha256
(base32
- "1ljzcq775njhbcaj8vdnypf2rgc6yqqdwfkf7c22603qvv9if1dr"))))
+ "1fslq70z4s6v9ipahnk8s5fgqnqq4njv4rlqv951r1bh1xk5lx7h"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags '("--enable-mount-eeze")))
@@ -298,3 +299,33 @@ that tries to lower the barrier to getting involved in Enlightenment development
and in creating applications based on the Enlightenment Foundation Library suite.")
(license (list license:public-domain ; data/extra/skeleton
license:gpl2)))) ; edi
+
+(define-public lekha
+ (package
+ (name "lekha")
+ (version "0.2.1")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "Lekha" version))
+ (sha256
+ (base32
+ "0zr6i74ik58pbzrd7r9l7sawqbdv0r2c1a9927qkqzwga27x8j15"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f ; no test target
+ #:python ,python-2
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-data-location
+ (lambda _ (substitute* "setup.py"
+ (("'/usr/")"'"))
+ #t)))))
+ (propagated-inputs
+ `(("python2-efl" ,python2-efl)
+ ("python2-pypdf2" ,python2-pypdf2)
+ ("python2-pyxdg" ,python2-pyxdg)))
+ (synopsis "Simple PDF viewer")
+ (description
+ "Simple PDF viewer based on the Enlightenment Foundation Libraries.")
+ (home-page "https://github.com/kaihu/lekha")
+ (license license:gpl3+)))