summaryrefslogtreecommitdiff
path: root/gnu/packages/engineering.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/engineering.scm')
-rw-r--r--gnu/packages/engineering.scm43
1 files changed, 21 insertions, 22 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 0955bb4ae3..af1ea3328a 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -191,28 +191,27 @@ utilities.")
(build-system gnu-build-system)
(arguments
`(#:phases
- (alist-cons-after
- 'unpack 'use-wish8.6
- (lambda _
- (substitute* "configure"
- (("wish85") "wish8.6")))
- (alist-cons-after
- 'install 'wrap
- (lambda* (#:key inputs outputs #:allow-other-keys)
- ;; FIXME: Mesa tries to dlopen libudev.so.0 and fails. Pending a
- ;; fix of the mesa package we wrap the pcb executable such that
- ;; Mesa can find libudev.so.0 through LD_LIBRARY_PATH.
- (let* ((out (assoc-ref outputs "out"))
- (path (string-append (assoc-ref inputs "udev") "/lib")))
- (wrap-program (string-append out "/bin/pcb")
- `("LD_LIBRARY_PATH" ":" prefix (,path)))))
- (alist-cons-before
- 'check 'pre-check
- (lambda _
- (system "Xvfb :1 &")
- (setenv "DISPLAY" ":1")
- #t)
- %standard-phases)))))
+ (modify-phases %standard-phases
+ (add-after 'unpack 'use-wish8.6
+ (lambda _
+ (substitute* "configure"
+ (("wish85") "wish8.6"))
+ #t))
+ (add-after 'install 'wrap
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ ;; FIXME: Mesa tries to dlopen libudev.so.0 and fails. Pending a
+ ;; fix of the mesa package we wrap the pcb executable such that
+ ;; Mesa can find libudev.so.0 through LD_LIBRARY_PATH.
+ (let* ((out (assoc-ref outputs "out"))
+ (path (string-append (assoc-ref inputs "udev") "/lib")))
+ (wrap-program (string-append out "/bin/pcb")
+ `("LD_LIBRARY_PATH" ":" prefix (,path))))
+ #t))
+ (add-before 'check 'pre-check
+ (lambda _
+ (system "Xvfb :1 &")
+ (setenv "DISPLAY" ":1")
+ #t)))))
(inputs
`(("dbus" ,dbus)
("mesa" ,mesa)