summaryrefslogtreecommitdiff
path: root/gnu/packages/engineering.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/engineering.scm')
-rw-r--r--gnu/packages/engineering.scm18
1 files changed, 9 insertions, 9 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 8578789872..b66b8d72bf 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -697,7 +697,7 @@ electrical diagrams), gerbview (viewing Gerber files) and others.")
(license license:gpl3+))))
(define-public kicad-library
- (let ((version "4.0.6"))
+ (let ((version "4.0.7"))
(package
(name "kicad-library")
(version version)
@@ -708,7 +708,7 @@ electrical diagrams), gerbview (viewing Gerber files) and others.")
version ".tar.gz"))
(sha256
(base32
- "16f47pd6f0ddsdxdrp327nr9v05gl8c24d0qypq2aqx5hdjmkp7f"))))
+ "1azb7v1y3l6j329r9gg7f4zlg0wz8nh4s4i5i0l9s4yh9r6i9zmv"))))
(build-system cmake-build-system)
(arguments
`(#:out-of-source? #t
@@ -717,11 +717,11 @@ electrical diagrams), gerbview (viewing Gerber files) and others.")
(modify-phases %standard-phases
(add-after 'install 'install-footprints ; from footprints tarball
(lambda* (#:key inputs outputs #:allow-other-keys)
- (zero? (system* "tar" "xvf"
- (assoc-ref inputs "kicad-footprints")
- "-C" (string-append (assoc-ref outputs "out")
- "/share/kicad/modules")
- "--strip-components=1"))))
+ (invoke "tar" "xvf"
+ (assoc-ref inputs "kicad-footprints")
+ "-C" (string-append (assoc-ref outputs "out")
+ "/share/kicad/modules")
+ "--strip-components=1")))
;; We change the default global footprint file, which is generated if
;; it doesn't exist in user's home directory, from the one using the
;; github plugin, to the one using the KISYSMOD environment path.
@@ -741,7 +741,7 @@ electrical diagrams), gerbview (viewing Gerber files) and others.")
(search-path-specification
(variable "KISYS3DMOD") ; 3D model path
(files '("share/kicad/modules/packages3d")))))
- ;; Kicad distributes footprints in a separate tarball
+ ;; Kicad distributes footprints in a separate tarball.
(native-inputs
`(("kicad-footprints"
,(origin
@@ -751,7 +751,7 @@ electrical diagrams), gerbview (viewing Gerber files) and others.")
version ".tar.gz"))
(sha256
(base32
- "0vmgqhdw05k5fdnqv42grnvlz7v75g9md82jp2d3dvw2zw050lfb"))))))
+ "08qrz5zzsb5127jlnv24j0sgiryd5nqwg3lfnwi8j9a25agqk13j"))))))
(home-page "http://kicad-pcb.org/")
(synopsis "Libraries for kicad")
(description "This package provides Kicad component, footprint and 3D