summaryrefslogtreecommitdiff
path: root/gnu/packages/emulators.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/emulators.scm')
-rw-r--r--gnu/packages/emulators.scm14
1 files changed, 6 insertions, 8 deletions
diff --git a/gnu/packages/emulators.scm b/gnu/packages/emulators.scm
index 0ce04dfaa5..6888672f9a 100644
--- a/gnu/packages/emulators.scm
+++ b/gnu/packages/emulators.scm
@@ -61,7 +61,6 @@
#:use-module (gnu packages glib)
#:use-module (gnu packages gtk)
#:use-module (gnu packages image)
- #:use-module (gnu packages imagemagick)
#:use-module (gnu packages libedit)
#:use-module (gnu packages libusb)
#:use-module (gnu packages linux)
@@ -477,14 +476,14 @@ V2.")
(define-public mednafen
(package
(name "mednafen")
- (version "1.24.3")
+ (version "1.26.1")
(source
(origin
(method url-fetch)
(uri (string-append "https://mednafen.github.io/releases/files/"
"mednafen-" version ".tar.xz"))
(sha256
- (base32 "03zplcfvmnnv7grhacmr1zy789pb2wda36wylmzmar23g0zqbsix"))))
+ (base32 "1x7xhxjhwsdbak8l0iyb497f043xkhibk73w96xck4j2bk10fac4"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags
@@ -538,7 +537,7 @@ The following systems are supported:
(define-public mgba
(package
(name "mgba")
- (version "0.8.3")
+ (version "0.8.4")
(source
(origin
(method git-fetch)
@@ -547,7 +546,7 @@ The following systems are supported:
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "0rwlfjdr0rzbq4kaplvwsgyb8xq6nrzxss2c8xrgw9hqw3ymx4s3"))
+ (base32 "0nqj4bnn5c2z1bq4bnbw1wznc0wpmq4sy3w8pipd6n6620b9m4qq"))
(modules '((guix build utils)))
(snippet
;; Make sure we don't use the bundled software.
@@ -567,7 +566,6 @@ The following systems are supported:
(native-inputs `(("pkg-config" ,pkg-config)
("qttools" ,qttools)))
(inputs `(("ffmpeg" ,ffmpeg)
- ("imagemagick" ,imagemagick)
("libedit" ,libedit)
("libelf" ,libelf)
("libepoxy" ,libepoxy)
@@ -1385,7 +1383,7 @@ play them on systems for which they were never designed!")
(define-public mame
(package
(name "mame")
- (version "0.225")
+ (version "0.226")
(source
(origin
(method git-fetch)
@@ -1394,7 +1392,7 @@ play them on systems for which they were never designed!")
(commit (apply string-append "mame" (string-split version #\.)))))
(file-name (git-file-name name version))
(sha256
- (base32 "1n61v1yqmc69399khcm8gdabqaz8rwwj822m8vm5mbyxnw92icqg"))
+ (base32 "1yfns42rk1l0qprj5ksj9fqsgqpa23xnzxf29r4434p4n18bb77v"))
(modules '((guix build utils)))
(snippet
;; Remove bundled libraries.