summaryrefslogtreecommitdiff
path: root/gnu/packages/embedded.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/embedded.scm')
-rw-r--r--gnu/packages/embedded.scm22
1 files changed, 12 insertions, 10 deletions
diff --git a/gnu/packages/embedded.scm b/gnu/packages/embedded.scm
index 313675814a..1da4141519 100644
--- a/gnu/packages/embedded.scm
+++ b/gnu/packages/embedded.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2016, 2017, 2018, 2019, 2023 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2016, 2017, 2018, 2019, 2023, 2024 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016, 2017 Theodoros Foradis <theodoros@foradis.org>
;;; Copyright © 2016 David Craven <david@craven.ch>
;;; Copyright © 2017, 2020 Efraim Flashner <efraim@flashner.co.il>
@@ -983,14 +983,16 @@ code.")
"0w0dff3s7wv2d9m78a4jhckiik58q38wx6wpbba5hzbs4yxz35ck"))))
(build-system gnu-build-system)
(arguments
- `(#:tests? #f ; no tests
- #:make-flags
- (list "OS=linux"
- (string-append "TARGET=" (assoc-ref %outputs "out")))
- #:phases
- (modify-phases %standard-phases
+ (list
+ #:tests? #false ;no tests
+ #:parallel-build? #false ;not supported
+ #:make-flags
+ #~(list "OS=linux"
+ (string-append "TARGET=" #$output))
+ #:phases
+ '(modify-phases %standard-phases
(add-after 'unpack 'chdir
- (lambda _ (chdir "loader") #t))
+ (lambda _ (chdir "loader")))
(delete 'configure))))
(native-inputs
(list openspin (make-propeller-toolchain)))
@@ -1637,7 +1639,7 @@ PicoBlaze; and Zilog Z80 families, plus many of their variants.")
(define-public sdcc
(package
(name "sdcc")
- (version "4.3.0")
+ (version "4.4.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -1645,7 +1647,7 @@ PicoBlaze; and Zilog Z80 families, plus many of their variants.")
"/" version "/sdcc-src-" version ".tar.bz2"))
(sha256
(base32
- "1kckr20jqa4rp4qcw38lwagmw3yfm3z0xb4kygd0608847qc0vra"))
+ "0xbaj3vx5cp3na1kmyhy4jvhcqwrg648scjbykgq0xmibqb1535f"))
(modules '((guix build utils)))
(snippet
#~(begin