summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/emacs.scm')
-rw-r--r--gnu/packages/emacs.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 48c9a6de2a..d2fa5eb225 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -10551,3 +10551,27 @@ well as take screenshots and lock your screen. The package depends on the
availability of shell commands to do the hard work for us. These commands can
be changed by customizing the appropriate variables.")
(license license:gpl3+)))
+
+(define-public emacs-org-caldav
+ (package
+ (name "emacs-org-caldav")
+ (version "20180403")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/dengste/org-caldav/raw/"
+ "8d3492c27a09f437d2d94f2736c56d7652e87aa0"
+ "/org-caldav.el"))
+ (sha256
+ (base32
+ "1fh4gh68ddj0is99z2ccyh97v6psnyda61n2dsadzqhcxn51amlc"))))
+ (build-system emacs-build-system)
+ (propagated-inputs `(("emacs-org" ,emacs-org)))
+ (home-page "https://github.com/dengste/org-caldav")
+ (synopsis
+ "Sync Org files with external calendars via the CalDAV protocol")
+ (description
+ "Synchronize between events in Org-mode files and a CalDAV calendar.
+This code is still alpha.")
+ (license license:gpl3+)))