summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/emacs.scm')
-rw-r--r--gnu/packages/emacs.scm74
1 files changed, 38 insertions, 36 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 91c6c8c41c..6faa01548b 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -305,14 +305,15 @@ editor (without an X toolkit)" )
"0phz9d8wjk4p13vqannv0003fwh8qqrp0gfzcs2hgq1mrmv1srss"))))
(build-system gnu-build-system)
(arguments
- '(#:phases (alist-cons-after
- 'install 'post-install
- (lambda* (#:key outputs #:allow-other-keys)
- (symlink "geiser-install.el"
- (string-append (assoc-ref outputs "out")
- "/share/emacs/site-lisp/"
- "geiser-autoloads.el")))
- %standard-phases)))
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'post-install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (symlink "geiser-install.el"
+ (string-append (assoc-ref outputs "out")
+ "/share/emacs/site-lisp/"
+ "geiser-autoloads.el"))
+ #t)))))
(inputs `(("guile" ,guile-2.0)))
(native-inputs `(("emacs" ,emacs-minimal)))
(home-page "http://nongnu.org/geiser/")
@@ -771,25 +772,25 @@ provides an optional IDE-like error list.")
(guix build emacs-utils))
#:tests? #f ; no check target
#:phases
- (alist-replace
- 'configure
- (lambda* (#:key outputs #:allow-other-keys)
- (substitute* "Makefile"
- (("/usr/local") (assoc-ref outputs "out"))
- (("/site-lisp/emacs-wget") "/site-lisp")))
- (alist-cons-before
- 'build 'patch-exec-paths
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let ((wget (assoc-ref inputs "wget")))
- (emacs-substitute-variables "wget.el"
- ("wget-command" (string-append wget "/bin/wget")))))
- (alist-cons-after
- 'install 'post-install
- (lambda* (#:key outputs #:allow-other-keys)
- (emacs-generate-autoloads
- "wget" (string-append (assoc-ref outputs "out")
- "/share/emacs/site-lisp/")))
- %standard-phases)))))
+ (modify-phases %standard-phases
+ (replace 'configure
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* "Makefile"
+ (("/usr/local") (assoc-ref outputs "out"))
+ (("/site-lisp/emacs-wget") "/site-lisp"))
+ #t))
+ (add-before 'build 'patch-exec-paths
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((wget (assoc-ref inputs "wget")))
+ (emacs-substitute-variables "wget.el"
+ ("wget-command" (string-append wget "/bin/wget"))))
+ #t))
+ (add-after 'install 'post-install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (emacs-generate-autoloads
+ "wget" (string-append (assoc-ref outputs "out")
+ "/share/emacs/site-lisp/"))
+ #t)))))
(home-page "http://www.emacswiki.org/emacs/EmacsWget")
(synopsis "Simple file downloader for Emacs based on wget")
(description
@@ -993,15 +994,16 @@ within a specified width. It is useful for displaying long track titles.")
"doc_DATA =\n")))))
(build-system gnu-build-system)
(arguments
- '(#:phases (alist-cons-after
- 'install 'post-install
- (lambda* (#:key outputs #:allow-other-keys)
- ;; Add an autoloads file with the right name for guix.el.
- (let* ((out (assoc-ref outputs "out"))
- (site (string-append out "/share/emacs/site-lisp")))
- (with-directory-excursion site
- (symlink "bbdb-loaddefs.el" "bbdb-autoloads.el"))))
- %standard-phases)))
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'post-install
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; Add an autoloads file with the right name for guix.el.
+ (let* ((out (assoc-ref outputs "out"))
+ (site (string-append out "/share/emacs/site-lisp")))
+ (with-directory-excursion site
+ (symlink "bbdb-loaddefs.el" "bbdb-autoloads.el")))
+ #t)))))
(native-inputs `(("emacs" ,emacs-minimal)))
(home-page "http://savannah.nongnu.org/projects/bbdb/")
(synopsis "Contact management utility for Emacs")