summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/emacs.scm')
-rw-r--r--gnu/packages/emacs.scm32
1 files changed, 29 insertions, 3 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index c6008e6a94..3e32998a9f 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -40,6 +40,7 @@
;;; Copyright © 2018 Pierre-Antoine Rouby <pierre-antoine.rouby@inria.fr>
;;; Copyright © 2018 Alex Branham <alex.branham@gmail.com>
;;; Copyright © 2018 Thorsten Wilms <t_w_@freenet.de>
+;;; Copyright © 2018 Pierre Langlois <pierre.langlois@gmx.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -3848,6 +3849,31 @@ use it, call @code{M-x ivy-yasnippet} (but make sure you have enabled
@code{yas-minor-mode} first).")
(license license:gpl3+))))
+(define-public emacs-ivy-rich
+ (package
+ (name "emacs-ivy-rich")
+ (version "0.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/Yevgnen/ivy-rich/archive/"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "14r3mx5rkd4wz0ls5pv5w6c7la3z9iy93d3jfind3xyg4kywy95c"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-ivy" ,emacs-ivy)))
+ (home-page "https://github.com/Yevgnen/ivy-rich")
+ (synopsis "More friendly interface for @code{ivy}")
+ (description
+ "This package extends @code{ivy} by showing more information in the
+minibuffer for each candidate. It adds columns showing buffer modes, file
+sizes, docstrings, etc. If @code{emacs-all-the-icons} is installed, it can
+show icons as well.")
+ (license license:gpl3+)))
+
(define-public emacs-avy
(package
(name "emacs-avy")
@@ -7688,17 +7714,17 @@ value of the access token.")
(define-public emacs-circe
(package
(name "emacs-circe")
- (version "2.6")
+ (version "2.10")
(source
(origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/jorgenschaefer/circe.git")
(commit (string-append "v" version))))
- (file-name (string-append name "-" version "-checkout"))
+ (file-name (git-file-name name version))
(sha256
(base32
- "19h3983zy3f15cgs86irvbdzz55qyjm48qd7gjlzcxplr7vnnh0j"))))
+ "10gi14kwxd81blddpvqh95lgmpbfgp0m955naxix3bs3r6a75n4s"))))
(build-system emacs-build-system)
;; In order to securely connect to an IRC server using TLS, Circe requires
;; the GnuTLS binary.