summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 791bb8a0ce..2f9de403af 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -113,6 +113,7 @@
;;; Copyright © 2022 Peter Polidoro <peter@polidoro.io>
;;; Copyright © 2022 Luis Felipe López Acevedo <luis.felipe.la@protonmail.com>
;;; Copyright © 2022 Thomas Albers Raviola <thomas@thomaslabs.org>
+;;; Copyright © 2022 Haider Mirza <haider@haider.gq>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -18639,6 +18640,28 @@ files, allowing for actions to be performed based on search criteria.")
Chinese to English.")
(license license:gpl3+)))
+(define-public emacs-org-auto-tangle
+ (package
+ (name "emacs-org-auto-tangle")
+ (version "0.4.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/yilkalargaw/org-auto-tangle")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1zb7vcmhmjiqpbbhqrqci689rnpn10p985cs5jk9sgg66xsbrgs3"))))
+ (build-system emacs-build-system)
+ (propagated-inputs (list emacs-async))
+ (home-page "https://github.com/yilkalargaw/org-auto-tangle")
+ (synopsis "Automatically tangle code blocks on save")
+ (description
+ "@code{org-auto-tangle} allows you to automatically tangle code blocks
+whenever saving an @code{org-mode} file.")
+ (license license:bsd-2)))
+
(define-public emacs-org-auto-expand
(let ((commit "4938d5f6460e2f8f051ba9ac000b291bfa43ef62")
(revision "1"))