summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm63
1 files changed, 30 insertions, 33 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index fde0c8ce0f..ce01f65bfd 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -9027,39 +9027,36 @@ after buffer changes.")
(file-name (git-file-name name version))))
(build-system emacs-build-system)
(arguments
- `(#:tests? #t
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'fix-realgud:run-process-void-error
- ;; See: https://github.com/realgud/realgud/issues/269.
- (lambda _
- (substitute* '("realgud/debugger/gdb/gdb.el"
- "realgud/debugger/gub/gub.el")
- (("^\\(require 'load-relative\\).*" anchor)
- (string-append anchor
- "(require-relative-list \
-'(\"../../common/run\") \"realgud:\")\n")))
- #t))
- (add-after 'expand-load-path 'fix-autogen-script
- (lambda _
- (substitute* "autogen.sh"
- (("./configure") "sh configure"))
- #t))
- (add-after 'fix-autogen-script 'autogen
- (lambda _
- (setenv "CONFIG_SHELL" "sh")
- (invoke "sh" "autogen.sh")))
- (add-after 'fix-autogen-script 'set-home
- (lambda _
- (setenv "HOME" (getenv "TMPDIR"))
- #t))
- (add-before 'patch-el-files 'remove-realgud-pkg.el
- (lambda _
- ;; FIXME: `patch-el-files' crashes on this file with error:
- ;; unable to locate "bashdb".
- (delete-file "./test/test-regexp-bashdb.el")
- #t)))
- #:include (cons* ".*\\.el$" %default-include)))
+ (list
+ #:tests? #t
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'fix-realgud:run-process-void-error
+ ;; See: https://github.com/realgud/realgud/issues/269.
+ (lambda _
+ (substitute* '("realgud/debugger/gdb/gdb.el"
+ "realgud/debugger/gub/gub.el")
+ (("^\\(require 'load-relative\\).*" anchor)
+ (string-append anchor
+ "(require-relative-list \
+'(\"../../common/run\") \"realgud:\")\n")))))
+ (add-after 'expand-load-path 'fix-autogen-script
+ (lambda _
+ (substitute* "autogen.sh"
+ (("./configure") "sh configure"))))
+ (add-after 'fix-autogen-script 'autogen
+ (lambda _
+ (setenv "CONFIG_SHELL" "sh")
+ (invoke "sh" "autogen.sh")))
+ (add-after 'fix-autogen-script 'set-home
+ (lambda _
+ (setenv "HOME" (getenv "TMPDIR"))))
+ (add-before 'patch-el-files 'remove-realgud-pkg.el
+ (lambda _
+ ;; FIXME: `patch-el-files' crashes on this file with error:
+ ;; unable to locate "bashdb".
+ (delete-file "./test/test-regexp-bashdb.el"))))
+ #:include #~(cons* ".*\\.el$" %default-include)))
(native-inputs
(list autoconf automake emacs-test-simple))
(propagated-inputs