summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 94d050eb8b..de2ac45066 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -15492,6 +15492,28 @@ query them from the comfort of your editor.")
buffer's environment.")
(license license:gpl3+)))
+(define-public emacs-enlive
+ (package
+ (name "emacs-enlive")
+ (version "0.0.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/zweifisch/enlive")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "08j6b79vy8ry4ad1abk3hvxjbb4ylrhkvrbrnq1gcikl4h1p2v63"))))
+ (build-system emacs-build-system)
+ (home-page "http://github.com/zweifisch/enlive")
+ (synopsis "Query HTML document with CSS selectors in Emacs")
+ (description
+ "Enlive is an Emacs library that allows the user to query HTML documents
+from within Elisp using a DSL similar to CSS selectors.")
+ (license license:gpl3+)))
+
(define-public emacs-envrc
(package
(name "emacs-envrc")