summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm361
1 files changed, 301 insertions, 60 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 81ae90ea31..9e276d9d26 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -31,7 +31,7 @@
;;; Copyright © 2017 Peter Mikkelsen <petermikkelsen10@gmail.com>
;;; Copyright © 2017, 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017 Mike Gerwitz <mtg@gnu.org>
-;;; Copyright © 2017, 2018, 2019, 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2017, 2018, 2019, 2020, 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2018 Sohom Bhattacharjee <soham.bhattacharjee15@gmail.com>
;;; Copyright © 2018, 2019 Mathieu Lirzin <mthl@gnu.org>
;;; Copyright © 2018, 2019, 2020, 2021 Pierre Neidhardt <mail@ambrevar.xyz>
@@ -41,7 +41,7 @@
;;; Copyright © 2018 Alex Branham <alex.branham@gmail.com>
;;; Copyright © 2018 Thorsten Wilms <t_w_@freenet.de>
;;; Copyright © 2018, 2019, 2020 Pierre Langlois <pierre.langlois@gmx.com>
-;;; Copyright © 2018, 2019, 2020 Brett Gilio <brettg@gnu.org>
+;;; Copyright © 2018, 2019, 2020, 2021 Brett Gilio <brettg@gnu.org>
;;; Copyright © 2019, 2020 Dimakakos Dimos <bendersteed@teknik.io>
;;; Copyright © 2019, 2020 Brian Leung <bkleung89@gmail.com>
;;; Copyright © 2019 mikadoZero <mikadozero@yandex.com>
@@ -88,7 +88,8 @@
;;; Copyright © 2020 Nicolò Balzarotti <nicolo@nixo.xyz>
;;; Copyright © 2020 André A. Gomes <andremegafone@gmail.com>
;;; Copyright © 2020 Jonathan Rostran <rostranjj@gmail.com>
-;;; Copyright © 2020 Noah Evans <noah@nevans.me>
+;;; Copyright © 2020, 2021 Noah Evans <noah@nevans.me>
+;;; Copyright © 2020 Brit Butler <brit@kingcons.io>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -130,6 +131,7 @@
#:use-module (gnu packages databases)
#:use-module (gnu packages dictionaries)
#:use-module (gnu packages djvu)
+ #:use-module (gnu packages ebook)
#:use-module (gnu packages emacs)
#:use-module (gnu packages guile)
#:use-module (gnu packages gtk)
@@ -1844,6 +1846,34 @@ like. It can be linked with various Emacs mail clients (Message and Mail
mode, Rmail, Gnus, MH-E, and VM). BBDB is fully customizable.")
(license license:gpl3+)))
+(define-public emacs-counsel-bbdb
+ (package
+ (name "emacs-counsel-bbdb")
+ (version "20181128.1320")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://melpa.org/packages/counsel-bbdb-"
+ version ".el"))
+ (sha256
+ (base32
+ "03g3lk8hz9a17vf5r16x054bhyk8xsbnfq0div8ig13fmhqi159q"))))
+ (build-system emacs-build-system)
+ (propagated-inputs `(("emacs-ivy" ,emacs-ivy)))
+ (home-page "https://github.com/redguard/counsel-bbdb")
+ (synopsis "Ivy interface for BBDB")
+ (description "This Ivy extension enables the use of @code{ivy-mode} to input
+email addresses from BBDB efficiently. The main functions are:
+@table @code
+@item counsel-bbdb-complete-mail to input email addresses;
+@item counsel-bbdb-reload' to reload contacts from BBDB database;
+@item counsel-bbdb-expand-mail-alias to expand mail alias.
+@end table
+Since @code{counsel-bbdb} is based on @code{ivy-mode}, all Ivy key bindings
+are supported. For example, after @samp{C-u M-x counsel-bbdb-complete-mail},
+you can press @samp{C-M-n} to input multiple email addresses.")
+ (license license:gpl3+)))
+
(define-public emacs-bluetooth
(package
(name "emacs-bluetooth")
@@ -2071,14 +2101,14 @@ as a library for other Emacs packages.")
(define-public emacs-auctex
(package
(name "emacs-auctex")
- (version "13.0.3")
+ (version "13.0.4")
(source
(origin
(method url-fetch)
(uri (string-append "https://elpa.gnu.org/packages/"
"auctex-" version ".tar"))
(sha256
- (base32 "1ljpkr0z15fyh907jbgky238dvci5vqi3xhvslyhblhp8sg9cbsi"))))
+ (base32 "1362dqb8mcaddda9849gqsj6rzlfq18xprddb74j02884xl7hq65"))))
(build-system emacs-build-system)
;; We use 'emacs' because AUCTeX requires dbus at compile time
;; ('emacs-minimal' does not provide dbus).
@@ -2253,7 +2283,7 @@ Lock key.")
(define-public emacs-chronometrist
(package
(name "emacs-chronometrist")
- (version "0.5.6")
+ (version "0.6.3")
(source
(origin
(method git-fetch)
@@ -2262,7 +2292,7 @@ Lock key.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0g54pxvid1hlynlnfx99sl027q2mr2f4axsvnf0vb3v48zm0n5cw"))))
+ (base32 "0ql72qh0bshv62nksv6awz5nqfhmgs8hkyvm7wvzfq64yrwghw50"))))
(build-system emacs-build-system)
(arguments
`(#:phases
@@ -4664,18 +4694,19 @@ for Flow files.")
(define-public emacs-flycheck-grammalecte
(package
(name "emacs-flycheck-grammalecte")
- (version "1.2")
+ (version "1.3")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://git.deparis.io/"
- "flycheck-grammalecte/snapshot/"
- "flycheck-grammalecte-" version ".tar.xz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.umaneti.net/flycheck-grammalecte/")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
- (base32 "1mzmzyik843r4j0ibpwqrxmb0g4xmirrf3lxr010bddkmmxf749a"))))
+ (base32 "1f1gapvs9j89qr474103dqgsiyb96phlnsmq5hiv4ba242blg9lb"))))
(build-system emacs-build-system)
(arguments
- `(#:include '("\\.(el|py)$")
+ `(#:include (cons "\\.py$" %default-include)
#:exclude '("^test-profile.el$")
#:emacs ,emacs ;need libxml support
#:phases
@@ -4690,28 +4721,22 @@ for Flow files.")
(substitute* '("conjugueur.py" "flycheck-grammalecte.py")
(("/usr/bin/env python3?") python3))
#t)))
- (add-before 'build 'link-to-grammalecte
- ;; XXX: The Python part of the package requires grammalecte, but
- ;; the library is not specified in PYTHONPATH, since we're not
- ;; using Python build system. As a workaround, we symlink
- ;; grammalecte libraries here.
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (grammalecte (assoc-ref inputs "grammalecte"))
- (version ,(version-major+minor (package-version python))))
- (with-directory-excursion
- (string-append out "/share/emacs/site-lisp")
- (symlink (string-append grammalecte "/lib/"
- "python" version "/site-packages/"
- "grammalecte")
- "grammalecte"))
- #t))))))
+ (add-after 'unpack 'specify-grammalecte-location
+ (lambda* (#:key inputs #:allow-other-keys)
+ (make-file-writable "flycheck-grammalecte.el")
+ (emacs-substitute-variables "flycheck-grammalecte.el"
+ ("flycheck-grammalecte--grammalecte-directory"
+ (string-append (assoc-ref inputs "grammalecte")
+ "/lib/python"
+ ,(version-major+minor (package-version python))
+ "/site-packages/grammalecte")))
+ #t)))))
(inputs
`(("grammalecte" ,grammalecte)
("python" ,python)))
(propagated-inputs
`(("emacs-flycheck" ,emacs-flycheck)))
- (home-page "https://git.deparis.io/flycheck-grammalecte/")
+ (home-page "https://git.umaneti.net/flycheck-grammalecte/")
(synopsis "Integrate Grammalecte with Flycheck")
(description
"Integrate the French grammar and typography checker Grammalecte with
@@ -6344,6 +6369,57 @@ drill sessions to aid in memorization. In these sessions you are shown flash
cards created in Org mode.")
(license license:gpl3+)))
+(define-public emacs-anki-editor
+ ;; Last release was in 2018.
+ (let ((commit "546774a453ef4617b1bcb0d1626e415c67cc88df")
+ (revision "0")
+ (version "0.3.3"))
+ (package
+ (name "emacs-anki-editor")
+ (version (git-version version revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/louietan/anki-editor")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1if610hq5j8rbjh1caw5bwbgnsn231awwxqbpwvrh966kdxzl4qf"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-dash" ,emacs-dash)
+ ("emacs-request" ,emacs-request)))
+ (home-page "https://github.com/louietan/anki-editor")
+ (synopsis "Minor mode for making Anki cards with Org mode")
+ (description
+ "This package is for people who use Anki as a spaced repetition system
+(SRS) but would like to make cards in Org mode.")
+ (license license:gpl3+))))
+
+(define-public emacs-org-mime
+ (package
+ (name "emacs-org-mime")
+ (version "0.2.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/org-mime/org-mime")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0vchyd80ybvr6317dwm50nxcgxfrpc0bz6259vnrh24p5sb8shbj"))))
+ (build-system emacs-build-system)
+ (home-page "http://github.com/org-mime/org-mime")
+ (synopsis "Send HTML email using Org mode HTML export")
+ (description
+ "This program sends HTML email using Org-mode HTML export.
+This approximates a WYSiWYG HTML mail editor from within Emacs, and can be
+useful for sending tables, fontified source code, and inline images in
+email.")
+ (license license:gpl3+)))
+
(define-public emacs-org-superstar
(package
(name "emacs-org-superstar")
@@ -6983,6 +7059,60 @@ any one of several ways: literally, as a regexp, as an initialism, in the flex
style, or as multiple word prefixes.")
(license license:gpl3+)))
+(define-public emacs-consult
+ ;; There are no tagged releases upstream on GitHub, instead we are using the
+ ;; most recent commit.
+ (let ((commit "ef6bb73a4a46e686826968fa25169e2d59b9a087")
+ (revision "0"))
+ (package
+ (name "emacs-consult")
+ (version (git-version "0.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/minad/consult")
+ (commit commit)))
+ (sha256
+ (base32 "00cnwg2knd820wwx6zg71rr0whpdhqm64gm3qx1mgklk79g7daih"))
+ (file-name (git-file-name name version))))
+ (build-system emacs-build-system)
+ (propagated-inputs `(("emacs-flycheck" ,emacs-flycheck)
+ ("emacs-selectrum" ,emacs-selectrum)))
+ (home-page "https://github.com/minad/consult")
+ (synopsis "Consulting completing-read")
+ (description "This package provides various handy commands based on the
+Emacs completion function completing-read, which allows to quickly select from a
+list of candidates.")
+ (license license:gpl3+))))
+
+(define-public emacs-marginalia
+ ;; There are no tagged releases upstream on GitHub, instead we are using the
+ ;; most recent commit.
+ (let ((commit "401993562dbf636054dd64988e44d19b5030867f")
+ (revision "0"))
+ (package
+ (name "emacs-marginalia")
+ (version (git-version "0.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/minad/marginalia")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1j0k9ija5paidj7yvbagkkayz9bjwhia9yhmd2q4490ginbbxshs"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/minad/marginalia")
+ (synopsis "Marginalia in the minibuffer")
+ (description
+ "This package provides Marginalia mode which adds marginalia to the
+minibuffer completions. Marginalia are marks or annotations placed at the
+margin of the page of a book or in this case helpful colorful annotations
+placed at the margin of the minibuffer for your completion candidates.")
+ (license license:gpl3+))))
+
(define-public emacs-smartparens
(package
(name "emacs-smartparens")
@@ -9923,8 +10053,8 @@ extensions.")
(license license:gpl3+)))
(define-public emacs-evil-collection
- (let ((commit "8c256263ad100fecd6246c6c55cbb19dab717c39")
- (revision "18"))
+ (let ((commit "323bb7d85848a6a142ae14f39c3a073ce6423e20")
+ (revision "19"))
(package
(name "emacs-evil-collection")
(version (git-version "0.0.3" revision commit))
@@ -9936,7 +10066,7 @@ extensions.")
(file-name (git-file-name name version))
(sha256
(base32
- "0hz1yfv5g016dm99bwnibbmyhbi21qlc39ckd7p3s82az89hgf2n"))))
+ "1pf51kj93i1k2ivkjgwcvgxj8shrl8h7rkg578jl4k4awargf0nz"))))
(build-system emacs-build-system)
(propagated-inputs
`(("emacs-evil" ,emacs-evil)
@@ -9976,9 +10106,9 @@ being deleted, changed, yanked, or pasted when using evil commands")
(license license:gpl3+))))
(define-public emacs-goto-chg
- (let ((commit "1829a13026c597e358f716d2c7793202458120b5")
+ (let ((commit "2af612153bc9f5bed135d25abe62f46ddaa9027f")
(version "1.7.3")
- (revision "1"))
+ (revision "2"))
(package
(name "emacs-goto-chg")
(version (git-version version revision commit))
@@ -9991,10 +10121,8 @@ being deleted, changed, yanked, or pasted when using evil commands")
(file-name (git-file-name name version))
(sha256
(base32
- "1y603maw9xwdj3qiarmf1bp13461f9f5ackzicsbynl0i9la3qki"))))
+ "1awmvihqgw6kspx192bcp9xp56xqbma90wlhxfxmidx3bvxghwpv"))))
(build-system emacs-build-system)
- (propagated-inputs
- `(("emacs-undo-tree" ,emacs-undo-tree)))
(home-page "https://github.com/emacs-evil/goto-chg")
(synopsis "Go to the last change in the Emacs buffer")
(description
@@ -11575,14 +11703,14 @@ information via a consistent and well-integrated user interface.")
(define-public emacs-adaptive-wrap
(package
(name "emacs-adaptive-wrap")
- (version "0.7")
+ (version "0.8")
(source
(origin
(method url-fetch)
(uri (string-append "https://elpa.gnu.org/packages/"
"adaptive-wrap-" version ".el"))
(sha256
- (base32 "10fb8gzvkbnrgzv28n1rczs03dvapr7rvi0kd73j6yf1zg2iz6qp"))))
+ (base32 "1gs1pqzywvvw4prj63vpj8abh8h14pjky11xfl23pgpk9l3ldrb0"))))
(build-system emacs-build-system)
(home-page "https://elpa.gnu.org/packages/adaptive-wrap.html")
(synopsis "Smart line-wrapping with wrap-prefix")
@@ -12031,14 +12159,14 @@ and cangjie.")
(define-public emacs-posframe
(package
(name "emacs-posframe")
- (version "0.8.3")
+ (version "0.8.4")
(source
(origin
(method url-fetch)
(uri (string-append "https://elpa.gnu.org/packages/"
- "posframe-" version ".el"))
+ "posframe-" version ".tar"))
(sha256
- (base32 "05m56aw2yxik0pgcvyr5c92j2mwfksxgq1syzvik6161gy8hdd0g"))))
+ (base32 "1sn35ibp5y4y80l1xm4b8i94ld953a9gbkk99zqd9mrq9bwjyhdp"))))
(build-system emacs-build-system)
;; emacs-minimal does not include the function font-info.
(arguments
@@ -12766,6 +12894,29 @@ JSONRPC is a generic Remote Procedure Call protocol designed around
JSON objects.")
(license license:gpl3+)))
+(define-public emacs-jsonnet-mode
+ (package
+ (name "emacs-jsonnet-mode")
+ (version "0.1.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tminor/jsonnet-mode")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0vi7415n90d1z2ww1hld0gdp6v7z4rd6f70h476dp2x4hydk293i"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-dash" ,emacs-dash)))
+ (home-page "https://github.com/mgyucht/jsonnet-mode")
+ (synopsis "Major mode for editing jsonnet files")
+ (description "This package provides syntax highlighting, indenting,
+formatting, and utility methods for jsonnet files.")
+ (license license:gpl3+)))
+
(define-public emacs-restclient
(let ((commit "ac8aad6c6b9e9d918062fa3c89c22c2f4ec48bc3")
(version "0")
@@ -12879,8 +13030,8 @@ the actual transformations.")
(license license:gpl2+))))
(define-public emacs-dired-hacks
- (let ((commit "886befe113fae397407c804f72c45613d1d43535")
- (revision "2"))
+ (let ((commit "d1a2bda6aa8f890cb367297ed93aee6d3b5ba388")
+ (revision "3"))
(package
(name "emacs-dired-hacks")
(version (git-version "0.0.1" revision commit))
@@ -12892,7 +13043,7 @@ the actual transformations.")
(file-name (git-file-name name version))
(sha256
(base32
- "1cvibg90ggyrivpjmcfprpi2fx7dpa68f8kzg08s88gw5ib75djl"))))
+ "12m81a9kjhs4cyq3lym0vp5nx6z3sfnypyzrnia76x6rjvixjf6y"))))
(build-system emacs-build-system)
(propagated-inputs
`(("emacs-dash" ,emacs-dash)
@@ -13512,14 +13663,14 @@ database of references on life sciences.")
(define-public emacs-websocket
(package
(name "emacs-websocket")
- (version "1.13")
+ (version "1.13.1")
(source
(origin
(method url-fetch)
(uri (string-append "https://elpa.gnu.org/packages/"
"websocket-" version ".tar"))
(sha256
- (base32 "0jnarx53csmx5fivzp5vhvvj3m8s03zwc6hjl0spz5zb6icqclsa"))))
+ (base32 "1x664zswas0fpml7zaj59zy97avrm49zb80zd69rlkqzz1m45psc"))))
(build-system emacs-build-system)
(home-page "https://elpa.gnu.org/packages/websocket.html")
(synopsis "Emacs WebSocket client and server")
@@ -13667,6 +13818,36 @@ through them using @key{C-c C-SPC}.")
messaging service.")
(license license:gpl3+))))
+(define-public emacs-helm-slack
+ (let ((commit "465f6220f3f5bee4d95492991fca1290c89534eb")
+ (revision "1"))
+ (package
+ (name "emacs-helm-slack")
+ (version (git-version "0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/yuya373/helm-slack")
+ (commit commit)))
+ (file-name (git-file-name name commit))
+ (sha256
+ (base32
+ "0p1s1kl8v68qjprqkf034cz911qzbqxbscqgpn0c3mbm3yfx81f7"))))
+ (build-system emacs-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ ;; HOME needs to exist for source compilation.
+ (add-before 'build 'set-HOME
+ (lambda _ (setenv "HOME" "/tmp") #t)))))
+ (propagated-inputs `(("emacs-slack", emacs-slack)))
+ (home-page "https://github.com/yuya373/helm-slack")
+ (synopsis "Helm extension for emacs-slack")
+ (description "This package provides an helm extension for emacs-slack
+Slack client.")
+ (license license:gpl3+))))
+
+
(define-public emacs-bash-completion
(package
(name "emacs-bash-completion")
@@ -13949,7 +14130,7 @@ Features:
(define-public emacs-evil-matchit
(package
(name "emacs-evil-matchit")
- (version "2.3.9")
+ (version "2.3.10")
(source
(origin
(method git-fetch)
@@ -13958,7 +14139,7 @@ Features:
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "1jk5qkqz3c4fnh6d2y889k5ycz8ipbkmzk4i8bl86xv9rhis1pv9"))))
+ (base32 "14nrc46290q54y7wv25251f2kqc0z8i9byl09xkgjijqldl9vdxa"))))
(build-system emacs-build-system)
(propagated-inputs
`(("emacs-evil" ,emacs-evil)))
@@ -16073,6 +16254,32 @@ dumb text search, @code{elisp-refs} actually parses the code, so it's never
confused by comments or @code{foo-bar} matching @code{foo}.")
(license license:gpl3+)))
+(define-public emacs-crdt
+ (let ((commit "44068ae505adf2c3a7bdbf6723a25fc45d6d1666")
+ (revision "0"))
+ (package
+ (name "emacs-crdt")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://code.librehq.com/qhong/crdt.el")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "130fkhvi757pfnbz70g6nw2n71k89cwwx7yzvsd5v177228c8w7w"))))
+ (build-system emacs-build-system)
+ (home-page "https://code.librehq.com/qhong/crdt.el")
+ (synopsis "Real-time collaborative editing environment")
+ (description
+ "@code{crdt.el} is a real-time collaborative editing environment for
+Emacs using Conflict-free Replicated Data Types. With it, you can share
+multiple buffer in one session, and see other users’ cursor and region. It
+also synchronizes Org mode folding status. It should work with all of Org
+mode.")
+ (license license:gpl3+))))
+
(define-public emacs-crux
(let ((commit "308f17d914e2cd79cbc809de66d02b03ceb82859")
(revision "2"))
@@ -18134,16 +18341,16 @@ appropriate directory if no @code{eshell} session is active.")
(define-public emacs-eshell-syntax-highlighting
(package
(name "emacs-eshell-syntax-highlighting")
- (version "0.2")
+ (version "0.3")
(source
(origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/akreisher/eshell-syntax-highlighting")
- (commit version)))
+ (commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0id27874wsb5y169030x8g1ldpa1mnskv1s2j3ygqiyh5fvpfash"))))
+ (base32 "1fb9aa85a3hx1rcmv71j6sc3y278452p1y4dabpwy07avb6apd0p"))))
(build-system emacs-build-system)
(home-page "https://github.com/akreisher/eshell-syntax-highlighting")
(synopsis "Add syntax highlighting to Eshell")
@@ -20083,7 +20290,7 @@ correctly.")
(define-public emacs-helm-sly
(package
(name "emacs-helm-sly")
- (version "0.5.1")
+ (version "0.7.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -20092,7 +20299,7 @@ correctly.")
(file-name (git-file-name name version))
(sha256
(base32
- "13s2dj09mcdwlibjlahyyq2dxjkjlpxs88dbdyvcd64249jmahsx"))))
+ "090vq8c4scf9byn8xic71b02n4c8frhz1y1x1brxn6iar44dmzm5"))))
(build-system emacs-build-system)
(propagated-inputs
`(("emacs-helm" ,emacs-helm)
@@ -20957,6 +21164,25 @@ with emacs. It displays the output of the @code{repo status} command in a
buffer and launches Magit from the status buffer for the project at point.")
(license license:gpl3+)))
+(define-public emacs-repology
+ (package
+ (name "emacs-repology")
+ (version "1.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://elpa.gnu.org/packages/"
+ "repology-" version ".tar"))
+ (sha256
+ (base32 "0y12496wafx95izah8vvv1x86k1m8kysm5mlhvshkp0zbpvmb5iq"))))
+ (build-system emacs-build-system)
+ (home-page "https://elpa.gnu.org/packages/repology.html")
+ (synopsis "Repology API access via Elisp")
+ (description
+ "This package provides tools to query Repology API (see
+@url{https://repology.org/api}), process results, and display them.")
+ (license license:gpl3+)))
+
(define-public emacs-alect-themes
(package
(name "emacs-alect-themes")
@@ -22583,6 +22809,21 @@ through Dash docsets.")
(sha256
(base32 "19gc05k2p1l8wlkrqij9cw6d61hzknd6a9n64kzlpi87cpbav3lv"))))
(build-system emacs-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-paths
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((calibre (assoc-ref inputs "calibre")))
+ (make-file-writable "calibredb-core.el")
+ (emacs-substitute-variables "calibredb-core.el"
+ ("calibredb-program"
+ (string-append calibre "/bin/calibredb"))
+ ("calibredb-fetch-metadata-program"
+ (string-append calibre "/bin/fetch-ebook-metadata"))))
+ #t)))))
+ (inputs
+ `(("calibre" ,calibre)))
(propagated-inputs
`(("emacs-dash" ,emacs-dash)
("emacs-s" ,emacs-s)
@@ -24902,7 +25143,7 @@ pattern guessed from thing under current cursor position.
(define-public emacs-helm-selector
(package
(name "emacs-helm-selector")
- (version "0.5")
+ (version "0.6.1")
(home-page "https://github.com/emacs-helm/helm-selector")
(source
(origin
@@ -24913,7 +25154,7 @@ pattern guessed from thing under current cursor position.
(file-name (git-file-name name version))
(sha256
(base32
- "1cv659sqmrvk316fp7mjc58vvbcg1j6s2q4rwgqrpbyszrxl3i63"))))
+ "01lh1df0bnas1p7xlqc4i1jd67f8lxgq0q2zsvx10z8828i76j3v"))))
(build-system emacs-build-system)
(propagated-inputs
`(("emacs-helm" ,emacs-helm)))
@@ -25761,7 +26002,7 @@ comments or emails.")
(define-public emacs-trashed
(package
(name "emacs-trashed")
- (version "1.9.0")
+ (version "2.1.2")
(source
(origin
(method git-fetch)
@@ -25770,7 +26011,7 @@ comments or emails.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "13grdi12iwlw4fiphdfmvclfpbr6ajlgfbfyi7v41z8k3rxz4ypz"))))
+ (base32 "0lfza55nbb62nmr27cwpcz2ad1vm95piq4nfd8zvkwqbn6klwmm6"))))
(build-system emacs-build-system)
(home-page "https://github.com/shingo256/trashed/")
(synopsis "View and edit system trash can in Emacs")