summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm362
1 files changed, 197 insertions, 165 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index d343b1dc6e..fc221a2678 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -14,7 +14,7 @@
;;; Copyright © 2016, 2017 Roel Janssen <roel@gnu.org>
;;; Copyright © 2016, 2017 Nikita <nikita@n0.is>
;;; Copyright © 2016, 2019 Alex Griffin <a@ajgrf.com>
-;;; Copyright © 2016–2022 Nicolas Goaziou <mail@nicolasgoaziou.fr>
+;;; Copyright © 2016-2022 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2016, 2017, 2018 Alex Vong <alexvong1995@gmail.com>
;;; Copyright © 2016, 2017, 2018, 2019, 2020, 2021 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2017 Christopher Baines <mail@cbaines.net>
@@ -106,6 +106,7 @@
;;; Copyright © 2021 la snesne <lasnesne@lagunposprasihopre.org>
;;; Copyright © 2021 Brian Kubisiak <brian@kubisiak.com>
;;; Copyright © 2021, 2022 Taiju HIGASHI <higashi@taiju.info>
+;;; Copyright © 2022 Brandon Lucas <br@ndon.dk>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -286,7 +287,7 @@ e.g. emacs-geiser-guile for Guile.")
(define-public emacs-geiser-guile
(package
(name "emacs-geiser-guile")
- (version "0.20.1")
+ (version "0.21.1")
(source
(origin
(method git-fetch)
@@ -295,22 +296,22 @@ e.g. emacs-geiser-guile for Guile.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "0bpsih99rvcjwllv631y1nz8vxymbz1x2n1l0qsljpn8g3cgrfbr"))))
+ (base32 "0fk5rr7mjmb4waiagi80dhddas5mrsgqr0flag5v5b0piblixxq6"))))
(build-system emacs-build-system)
(arguments
- '(#:include (cons "^src/" %default-include)
- #:phases
- (modify-phases %standard-phases
- (add-after 'make-autoloads 'patch-autoloads
- (lambda* (#:key outputs #:allow-other-keys)
- (substitute* (string-append
- (elpa-directory (assoc-ref outputs "out"))
- "/geiser-guile-autoloads.el")
- ;; Activating implementations fails when Geiser is not yet
- ;; loaded, so let's defer that until it is.
- (("\\(geiser-activate-implementation .*\\)" all)
- (string-append
- "(eval-after-load 'geiser-impl '" all ")"))))))))
+ (list
+ #:include #~(cons "^src/" %default-include)
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'make-autoloads 'patch-autoloads
+ (lambda _
+ (substitute* (string-append (elpa-directory #$output)
+ "/geiser-guile-autoloads.el")
+ ;; Activating implementations fails when Geiser is not yet
+ ;; loaded, so let's defer that until it is.
+ (("\\(geiser-activate-implementation .*\\)" all)
+ (string-append
+ "(eval-after-load 'geiser-impl '" all ")"))))))))
(inputs
(list guile-3.0))
(propagated-inputs
@@ -2590,14 +2591,14 @@ as a library for other Emacs packages.")
(define-public emacs-auctex
(package
(name "emacs-auctex")
- (version "13.0.15")
+ (version "13.0.16")
(source
(origin
(method url-fetch)
(uri (string-append "https://elpa.gnu.org/packages/"
"auctex-" version ".tar"))
(sha256
- (base32 "1rm8s02d1mx5sw7yj65zlr07xhimnmvqav7f45nz2h8bwka02c3c"))))
+ (base32 "1r9piq4js45knw8sf73kk8jjinmx4m2mdinc98xrklnwcffw7hjf"))))
(build-system emacs-build-system)
;; We use 'emacs' because AUCTeX requires dbus at compile time
;; ('emacs-minimal' does not provide dbus).
@@ -3705,16 +3706,16 @@ kmonad's configuration files (@file{.kbd}).")
(define-public emacs-keycast
(package
(name "emacs-keycast")
- (version "1.1.1")
+ (version "1.1.3")
(source
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/tarsius/keycast.git")
+ (url "https://github.com/tarsius/keycast")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "09xr0h2ag3pzlz455gv5h915vn1dz56gqx61jx3n7fc4a794pqxw"))))
+ (base32 "0s31b3kal4j08waa2fwz5d6269wsdywb60a7h4r5vzsrr238lks3"))))
(build-system emacs-build-system)
(home-page "https://github.com/tarsius/keycast")
(synopsis "Show current command and its key in the mode line")
@@ -5057,7 +5058,7 @@ displays the priority part of a heading as your preferred string value.")
(define-public emacs-org-fragtog
(package
(name "emacs-org-fragtog")
- (version "0.4.0")
+ (version "0.4.1")
(source
(origin
(method git-fetch)
@@ -5066,7 +5067,7 @@ displays the priority part of a heading as your preferred string value.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "0ra4sfy48p8pm1c7h8wlmbl68r4s0f4qc49xapvs550pm4mf3hiq"))))
+ (base32 "1912nlnk5v20szlmxr6y7chvms294z0p0hzdfgi8i3c7yrz7lmsj"))))
(build-system emacs-build-system)
(propagated-inputs
(list emacs-org))
@@ -8115,28 +8116,25 @@ them easier to distinguish from other, less important buffers.")
(license license:expat)))
(define-public emacs-embark
- ;; XXX: Upstream did not tag last release. Commit hash below matches
- ;; version bump.
- (let ((commit "5ebe2dfd91868ec525ea34ffd45941c5e9ce5358"))
- (package
- (name "emacs-embark")
- (version "0.14")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/oantolin/embark")
- (commit commit)))
- (sha256
- (base32 "07siy3kxx06nklsw0aysfy0ijssqbql4v43vs60kwvzs875w4d2s"))
- (file-name (git-file-name name version))))
- (build-system emacs-build-system)
- (propagated-inputs
- (list emacs-avy emacs-consult))
- (home-page "https://github.com/oantolin/embark")
- (synopsis "Emacs mini-buffer actions rooted in keymaps")
- (description
- "This package provides a sort of right-click contextual menu for Emacs
+ (package
+ (name "emacs-embark")
+ (version "0.15")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/oantolin/embark")
+ (commit version)))
+ (sha256
+ (base32 "08wj0p3plvblbmfmn4vsanhldr2csrnm1lhk3g1nic5v26yi5l64"))
+ (file-name (git-file-name name version))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ (list emacs-avy emacs-consult))
+ (home-page "https://github.com/oantolin/embark")
+ (synopsis "Emacs mini-buffer actions rooted in keymaps")
+ (description
+ "This package provides a sort of right-click contextual menu for Emacs
offering you relevant @emph{actions} to use on a @emph{target} determined by
the context.
@@ -8150,7 +8148,7 @@ get offered actions like deleting, copying, renaming, visiting in another
window, running a shell command on the file, etc. For buffers the actions
include switching to or killing the buffer. For package names the actions
include installing, removing or visiting the homepage.")
- (license license:gpl3+))))
+ (license license:gpl3+)))
(define-public emacs-prescient
(package
@@ -8204,7 +8202,7 @@ interface.")
(define-public emacs-orderless
(package
(name "emacs-orderless")
- (version "0.6")
+ (version "0.7")
(source
(origin
(method git-fetch)
@@ -8212,7 +8210,7 @@ interface.")
(url "https://github.com/oantolin/orderless")
(commit version)))
(sha256
- (base32 "1javw5n3h3iv7f433b2ack49aka1jdpp8yxnaahzg5qbvr80hnay"))
+ (base32 "0m9nyz80j0qnn14drbgk8vn5yr7sv0z6yiz8w95ahcw2qwlgyjs7"))
(file-name (git-file-name name version))))
(build-system emacs-build-system)
(arguments
@@ -8249,8 +8247,6 @@ style, or as multiple word prefixes.")
(base32 "051fjp03lj3b5kkzpdhk78g2lj37v973q0f012zld1n6937srj6h"))
(file-name (git-file-name name version))))
(build-system emacs-build-system)
- (propagated-inputs
- (list emacs-flycheck emacs-selectrum))
(home-page "https://github.com/minad/consult")
(synopsis "Consulting completing-read")
(description "This package provides various handy commands based on the
@@ -9117,33 +9113,30 @@ window layout easily.")
(license license:gpl3+)))
(define-public emacs-iedit
- ;; Last release version was in 2016.
- (let ((commit "e2c100cdd67b7d82835d281ac2cd1bf4f374bc8f")
- (revision "1"))
- (package
- (name "emacs-iedit")
- (version (git-version "0.9.9.9" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/victorhge/iedit")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0wr3w2id95wx2rma8n1ifjrv9rx37ly26ijc5zi58id0yrip3hnc"))))
- (build-system emacs-build-system)
- (home-page "https://www.emacswiki.org/emacs/Iedit")
- (synopsis "Edit multiple regions in the same way simultaneously")
- (description
- "This package is an Emacs minor mode and allows you to edit one
+ (package
+ (name "emacs-iedit")
+ (version "0.9.9.9.9")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/victorhge/iedit")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "02jdyrff88n69d4kadjaac38gwcv28lhiqqa93rlqzdvmgqsbwak"))))
+ (build-system emacs-build-system)
+ (home-page "https://www.emacswiki.org/emacs/Iedit")
+ (synopsis "Edit multiple regions in the same way simultaneously")
+ (description
+ "This package is an Emacs minor mode and allows you to edit one
occurrence of some text in a buffer (possibly narrowed) or region, and
simultaneously have other occurrences edited in the same way.
You can also use Iedit mode as a quick way to temporarily show only the buffer
lines that match the current text being edited. This gives you the effect of
a temporary @code{keep-lines} or @code{occur}.")
- (license license:gpl3+))))
+ (license license:gpl3+)))
(define-public emacs-zoutline
(package
@@ -11480,7 +11473,7 @@ Lua programming language}.")
(define-public emacs-ebuild-mode
(package
(name "emacs-ebuild-mode")
- (version "1.54")
+ (version "1.55")
(source
(origin
(method url-fetch)
@@ -11489,17 +11482,17 @@ Lua programming language}.")
"ebuild-mode-" version ".tar.xz"))
(file-name (string-append name "-" version ".tar.xz"))
(sha256
- (base32 "0a4j3lriphv7f11qzjxynxv9jn5vj68qdgwklpviaqvisvcgvmnh"))))
+ (base32 "1bs2s5g79vrbk8544lvp388cdbig0s121kwk0h10hif4kp56ka9w"))))
(build-system emacs-build-system)
(arguments
- '(#:phases
- (modify-phases %standard-phases
- (add-after 'install 'install-doc
- (lambda* (#:key outputs #:allow-other-keys)
- (invoke "make" "ebuild-mode.info")
- (install-file "ebuild-mode.info"
- (string-append (assoc-ref outputs "out")
- "/share/info")))))))
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'install 'install-doc
+ (lambda _
+ (invoke "make" "ebuild-mode.info")
+ (install-file "ebuild-mode.info"
+ (string-append #$output "/share/info")))))))
(native-inputs
(list texinfo))
(home-page "https://devmanual.gentoo.org")
@@ -13840,13 +13833,13 @@ containing words from the Rime project.")
(define-public emacs-pyim
(package
(name "emacs-pyim")
- (version "4.0.3")
+ (version "4.1.0")
(source
(origin
(method url-fetch)
(uri (string-append "https://elpa.gnu.org/packages/pyim-" version ".tar"))
(sha256
- (base32 "110d9d8xglnyv0cn0slwk3msgqq8rs01xq2qmx5ya7i2v77gd5ql"))))
+ (base32 "1q4b3y72gbkl5z31brlnjqjl30lgqm2d1zlqrbkqnnfy5hjgazk9"))))
(build-system emacs-build-system)
(propagated-inputs
(list emacs-async emacs-pyim-basedict emacs-popup emacs-posframe
@@ -13904,14 +13897,14 @@ methods from a given list.")
(define-public emacs-posframe
(package
(name "emacs-posframe")
- (version "1.1.5")
+ (version "1.1.6")
(source
(origin
(method url-fetch)
(uri (string-append "https://elpa.gnu.org/packages/"
"posframe-" version ".tar"))
(sha256
- (base32 "1kyd3r926hhs03mmpyvbjjyqcbvqrxk62rrscgfyl7rqi9ar56i0"))))
+ (base32 "0aqbvgsvkhd174mb3vv9bszw7iawnf6nsqjzlwzgv1z2hrxb27h2"))))
(build-system emacs-build-system)
;; emacs-minimal does not include the function font-info.
(arguments
@@ -14015,7 +14008,7 @@ which code derived from Kelvin H's org-page.")
(define-public emacs-meow
(package
(name "emacs-meow")
- (version "1.2.1")
+ (version "1.3.0")
(source
(origin
(method git-fetch)
@@ -14024,7 +14017,7 @@ which code derived from Kelvin H's org-page.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "048y1sgsl7amcsq8pxw9m2fws1zcjwbsqs1lnsz30dx6qasdmjf1"))))
+ (base32 "082f013f8gbd67s6q9636lqhlhwlbg6z6n7icrqfj9x6671phwgn"))))
(build-system emacs-build-system)
(home-page "https://github.com/meow-edit/meow")
(synopsis "Yet another modal editing on Emacs")
@@ -14437,14 +14430,14 @@ Emacs.")
(define-public emacs-eglot
(package
(name "emacs-eglot")
- (version "1.7")
+ (version "1.8")
(source
(origin
(method url-fetch)
(uri (string-append "https://elpa.gnu.org/packages/"
"eglot-" version ".tar"))
(sha256
- (base32 "1zvs144hxq2mmq1h0ynx9hy7yyccb46f3pjg9mgq8v9cw5y678vk"))))
+ (base32 "1n04jnf3wwpxafrzfd02l53wf90brjc8p835f84k0n0rjxin99k5"))))
(build-system emacs-build-system)
(propagated-inputs
(list emacs-eldoc emacs-jsonrpc emacs-project))
@@ -14553,6 +14546,30 @@ running tests easier.")
(description "This package provides a simple testing library for Emacs.")
(license license:gpl3+)))
+(define-public emacs-org-transclusion
+ (package
+ (name "emacs-org-transclusion")
+ (version "1.1.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/nobiot/org-transclusion")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0qvc8f4i44d8mgkzfi9yld664cmapkbmjv4bf0l8va417ck5sm92"))))
+ (build-system emacs-build-system)
+ (home-page "https://nobiot.github.io/org-transclusion/")
+ (synopsis "Enable transclusion with Org Mode")
+ (description "Org-transclusion lets you insert a copy of text content via
+a file link or ID link within an Org file. It lets you have the same content
+present in different buffers at the same time without copy-and-pasting it.
+Edit the source of the content, and you can refresh the transcluded copies to
+the up-to-date state. Org-transclusion keeps your files clear of the
+transcluded copies, leaving only the links to the original content.")
+ (license license:gpl3+)))
+
(define-public emacs-disable-mouse
(package
(name "emacs-disable-mouse")
@@ -14662,14 +14679,14 @@ highlighting.")
(define-public emacs-jsonrpc
(package
(name "emacs-jsonrpc")
- (version "1.0.14")
+ (version "1.0.15")
(source
(origin
(method url-fetch)
(uri (string-append "https://elpa.gnu.org/packages/"
- "jsonrpc-" version ".el"))
+ "jsonrpc-" version ".tar"))
(sha256
- (base32 "069l0sqkambam4ikj9id36kdw1jdjna8v586d51m64hiz96rmvm6"))))
+ (base32 "1hx378rg12jz2zm105cvrqk0nqyzsn04l59d903l98d6lbd96rsw"))))
(build-system emacs-build-system)
(home-page "http://elpa.gnu.org/packages/jsonrpc.html")
(synopsis "JSON-RPC library")
@@ -15078,7 +15095,7 @@ library.")
(build-system emacs-build-system)
(arguments
`(#:emacs ,emacs)) ;need libxml support
- (inputs
+ (propagated-inputs
(list emacs-plz emacs-ts))
(home-page "https://github.com/alphapapa/ement.el")
(synopsis "Matrix client for Emacs")
@@ -21720,7 +21737,7 @@ source code.")
(define-public emacs-rustic
(package
(name "emacs-rustic")
- (version "2.4")
+ (version "2.5")
(source
(origin
(method git-fetch)
@@ -21729,7 +21746,7 @@ source code.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "1w7db1d712rjw55prb3kdcag4z1skk56837q1ig9d2bj4mkhqa2s"))))
+ (base32 "1jx8gzcm9ka2chpq51jx4mfa12wqrj2dsrpxwylfcb9qkqjncbn5"))))
(build-system emacs-build-system)
(propagated-inputs
(list emacs-dash
@@ -23345,7 +23362,7 @@ according to their use.")
(define-public emacs-dtrt-indent
(package
(name "emacs-dtrt-indent")
- (version "1.4")
+ (version "1.6")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -23354,7 +23371,7 @@ according to their use.")
(file-name (git-file-name name version))
(sha256
(base32
- "11r68sh3yrrfib7pixnazispwsffrygmgplffrv8qq57xrqzyxih"))))
+ "1kad2inc9k2z65if26vfiw098yklzxdx9fw8a6yicb87jgc1cz36"))))
(build-system emacs-build-system)
(home-page "https://github.com/jscheid/dtrt-indent")
(synopsis "Minor mode that guesses the indentation offset")
@@ -26519,29 +26536,27 @@ color. Designed for 256-color terminals. Comes in light and dark!")
(license license:gpl3+))))
(define-public emacs-spacemacs-theme
- (let ((commit "f79c40fb241e204539fde97200abae91e828e585")
- (revision "1"))
- (package
- (name "emacs-spacemacs-theme")
- (version (git-version "0" revision commit)) ;no release yet
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/nashamri/spacemacs-theme")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "1l2kkiyrskkpx8f901v0wrzaah1wjg15zdyv88spj3mh3hwd3b6n"))))
- (build-system emacs-build-system)
- (home-page "https://github.com/nashamri/spacemacs-theme")
- (synopsis
- "Light and dark theme for spacemacs that supports GUI and terminal")
- (description
- "Spacemacs theme is an Emacs color theme that started as
+ (package
+ (name "emacs-spacemacs-theme")
+ (version "0.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/nashamri/spacemacs-theme")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "15l9hb8f08nkxsaj8pxbg2mip4pp2msnrl0nvlq22zg40gh7pqsn"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/nashamri/spacemacs-theme")
+ (synopsis
+ "Light and dark theme for spacemacs that supports GUI and terminal")
+ (description
+ "Spacemacs theme is an Emacs color theme that started as
a theme for Spacemacs. The theme comes with dark and light variants
and it should work well with 256 color terminals.")
- (license license:gpl3+))))
+ (license license:gpl3+)))
(define-public emacs-elixir-mode
(package
@@ -28417,7 +28432,7 @@ snippets for Emacs.")
(define-public emacs-org-roam
(package
(name "emacs-org-roam")
- (version "2.1.0")
+ (version "2.2.0")
(source
(origin
(method git-fetch)
@@ -28426,58 +28441,55 @@ snippets for Emacs.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "092xn0sqc7b7f6pdf7m6c3giqqbh6fq02mfz8qrg0wmx4ds1isqp"))))
+ (base32 "0q3nhw05wnqh1qgggxsj8wki4ihciqlkic2x7qbcsskjqm73j1r7"))))
(build-system emacs-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- ;; Move the extensions source files to the top level, which is included in
- ;; the EMACSLOADPATH.
- (add-after 'unpack 'move-source-files
- (lambda _
- (let ((el-files (find-files "./extensions" ".*\\.el$")))
- (for-each (lambda (f)
- (rename-file f (basename f)))
- el-files))
- #t))
- (add-after 'move-source-files 'patch-exec-paths
- (lambda* (#:key inputs #:allow-other-keys)
- (make-file-writable "org-roam-graph.el")
- (emacs-substitute-variables "org-roam-graph.el"
- ("org-roam-graph-executable"
- (string-append (assoc-ref inputs "graphviz")
- "/bin/dot")))))
- (add-after 'install 'install-image
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- (install-file "doc/images/org-ref-citelink.png"
- (string-append out "/share/info/images")))))
- (add-after 'install-image 'make-info
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- (with-directory-excursion "doc"
- (invoke "makeinfo" "-o" "org-roam.info" "org-roam.texi")
- (install-file "org-roam.info"
- (string-append out "/share/info")))))))))
- (inputs
- (list graphviz))
- (native-inputs
- (list texinfo))
- (propagated-inputs
- (list emacs-dash
- emacs-emacsql-sqlite3
- emacs-f
- emacs-magit
- emacs-org
- emacs-s))
- (home-page "https://github.com/org-roam/org-roam/")
- (synopsis "Non-hierarchical note-taking with Org mode")
- (description "Emacs Org Roam is a solution for taking non-hierarchical
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; Move the extensions source files to the top level, which
+ ;; is included in the EMACSLOADPATH.
+ (add-after 'unpack 'move-source-files
+ (lambda _
+ (let ((el-files (find-files "./extensions" ".*\\.el$")))
+ (for-each (lambda (f)
+ (rename-file f (basename f)))
+ el-files))))
+ (add-after 'move-source-files 'patch-exec-paths
+ (lambda* (#:key inputs #:allow-other-keys)
+ (make-file-writable "org-roam-graph.el")
+ (emacs-substitute-variables "org-roam-graph.el"
+ ("org-roam-graph-executable"
+ (search-input-file inputs "/bin/dot")))))
+ (add-after 'install 'install-image
+ (lambda* (#:key outputs #:allow-other-keys)
+ (install-file "doc/images/org-ref-citelink.png"
+ (string-append #$output "/share/info/images"))))
+ (add-after 'install-image 'make-info
+ (lambda* (#:key outputs #:allow-other-keys)
+ (with-directory-excursion "doc"
+ (invoke "makeinfo" "-o" "org-roam.info" "org-roam.texi")
+ (install-file "org-roam.info"
+ (string-append #$output "/share/info"))))))))
+ (inputs
+ (list graphviz))
+ (native-inputs
+ (list texinfo))
+ (propagated-inputs
+ (list emacs-dash
+ emacs-emacsql-sqlite3
+ emacs-f
+ emacs-magit
+ emacs-org
+ emacs-s))
+ (home-page "https://github.com/org-roam/org-roam/")
+ (synopsis "Non-hierarchical note-taking with Org mode")
+ (description "Emacs Org Roam is a solution for taking non-hierarchical
notes with Org mode. Notes are captured without hierarchy and are connected
by tags. Notes can be found and created quickly. Org Roam should also work
as a plug-and-play solution for anyone already using Org mode for their
personal wiki.")
- (license license:gpl3+)))
+ (license license:gpl3+)))
(define-public emacs-org-roam-bibtex
(package
@@ -29737,3 +29749,23 @@ Unlike Emacs' generic ASM mode, it understands NASM-specific syntax.")
wraps GNU Global calls and integration to editor using this API with
project.el and xref.el.")
(license license:gpl3+))))
+
+(define-public emacs-fennel-mode
+ (package
+ (name "emacs-fennel-mode")
+ (version "0.4.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/technomancy/fennel-mode")
+ (commit version)))
+ (sha256
+ (base32 "0dwas3ivhxdyw6njkcadc8c17cirq325cmby04qls8zkmrvlil1w"))))
+ (build-system emacs-build-system)
+ (home-page "https://gitlab.com/technomancy/fennel-mode")
+ (synopsis "Emacs major-mode for editing Fennel code")
+ (description
+ "Fennel mode provides font-lock, indentation, navigation, and REPL for
+ Fennel code within Emacs.")
+ (license license:gpl3+)))