summaryrefslogtreecommitdiff
path: root/gnu/packages/elf.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/elf.scm')
-rw-r--r--gnu/packages/elf.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/elf.scm b/gnu/packages/elf.scm
index eaa9ab5f51..9b120751d2 100644
--- a/gnu/packages/elf.scm
+++ b/gnu/packages/elf.scm
@@ -56,6 +56,14 @@
`(#:configure-flags (list (string-append "LDFLAGS=-Wl,-rpath="
(assoc-ref %outputs "out")
"/lib"))
+
+ ;; Disable tests on MIPS (without changing
+ ;; the arguments list on other systems).
+ ,@(if (string-prefix? "mips" (or (%current-target-system)
+ (%current-system)))
+ '(#:tests? #f)
+ '())
+
#:phases
(modify-phases %standard-phases
;; No reason has been found for this test to reliably fail on aarch64-linux.