summaryrefslogtreecommitdiff
path: root/gnu/packages/education.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/education.scm')
-rw-r--r--gnu/packages/education.scm19
1 files changed, 13 insertions, 6 deletions
diff --git a/gnu/packages/education.scm b/gnu/packages/education.scm
index 99e7b669b4..ed1401c39b 100644
--- a/gnu/packages/education.scm
+++ b/gnu/packages/education.scm
@@ -274,7 +274,7 @@ easy.")
(define-public snap
(package
(name "snap")
- (version "6.0.0")
+ (version "6.1.4")
(source
(origin
(method git-fetch)
@@ -283,7 +283,7 @@ easy.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1j5hcnms12hpnl2ba7haf00l08rkpb5wpfsgax07p838q5dc7cam"))))
+ (base32 "0qvnm5jg2hlf32say531m8nmp3aib93mqnllw1g289s58fzk5li6"))))
(build-system trivial-build-system)
(arguments
`(#:modules ((guix build utils))
@@ -612,14 +612,14 @@ Portuguese, Spanish and Italian.")
(define-public fet
(package
(name "fet")
- (version "5.45.1")
+ (version "5.46.0")
(source
(origin
(method url-fetch)
(uri (string-append "https://www.lalescu.ro/liviu/fet/download/"
"fet-" version ".tar.bz2"))
(sha256
- (base32 "1pg47jk6fw46fr7m32l1ypm1zyjfz1ik5f333ynqqr705f1c0ij5"))))
+ (base32 "1vcsm12lqf84mz9ppw2knjyv5ss2ws0dblbp418hll91dry7m49a"))))
(build-system gnu-build-system)
(arguments
`(#:phases
@@ -651,14 +651,14 @@ hours.")
(define-public klavaro
(package
(name "klavaro")
- (version "3.10")
+ (version "3.11")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/klavaro/klavaro-"
version ".tar.bz2"))
(sha256
- (base32 "0jnzdrndiq6m0bwgid977z5ghp4q61clwdlzfpx4fd2ml5x3iq95"))))
+ (base32 "1rkxaqb62w4mv86fcnmr32lq6y0h4hh92wmsy5ddb9a8jnzx6r7w"))))
(build-system gnu-build-system)
(native-inputs
`(("intltool" ,intltool)
@@ -758,6 +758,13 @@ adjust the level of difficulty.")
(ice-9 match))
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'disable-update-check
+ ;; Don't ‘phone home’ unasked to check for updates.
+ (lambda _
+ (substitute* "aqt/update.py"
+ (("requests\\.post")
+ "throw.an.exception.instead"))
+ #t))
(delete 'configure) ;no configure script
(add-after 'install 'wrap
(lambda* (#:key inputs outputs #:allow-other-keys)