summaryrefslogtreecommitdiff
path: root/gnu/packages/education.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/education.scm')
-rw-r--r--gnu/packages/education.scm51
1 files changed, 44 insertions, 7 deletions
diff --git a/gnu/packages/education.scm b/gnu/packages/education.scm
index d6c2cd02c3..cba061f195 100644
--- a/gnu/packages/education.scm
+++ b/gnu/packages/education.scm
@@ -7,6 +7,7 @@
;;; Copyright © 2018, 2019, 2020 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2020 Robert Smith <robertsmith@posteo.net>
;;; Copyright © 2020 Guy Fleury Iteriteka <gfleury@disroot.org>
+;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -39,6 +40,7 @@
#:use-module (gnu packages gettext)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnome)
+ #:use-module (gnu packages golang)
#:use-module (gnu packages gtk)
#:use-module (gnu packages image)
#:use-module (gnu packages javascript)
@@ -68,6 +70,7 @@
#:use-module (guix utils)
#:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system go)
#:use-module (guix build-system python)
#:use-module (guix build-system qt)
#:use-module (guix build-system trivial)
@@ -114,7 +117,7 @@
("texi2html" ,texi2html)
("glib:bin" ,glib "bin")
("pkg-config" ,pkg-config)))
- (home-page "http://gcompris.net")
+ (home-page "https://gcompris.net")
(synopsis "Educational software suite")
(description "GCompris is an educational software suite comprising of
numerous activities for children aged 2 to 10. Some of the activities are
@@ -386,7 +389,10 @@ to open the application in a web browser, for offline usage.")
Type=Application~%"
out)))
#t))))))
- (inputs `(("python-pyqt" ,python-pyqt)))
+ (native-inputs
+ `(("unzip" ,unzip)))
+ (inputs
+ `(("python-pyqt" ,python-pyqt)))
(synopsis "School tools for physically disabled children")
(description "ToutEnClic is intended to facilitate the schooling
of physically disabled children in ordinary schools. It is both
@@ -606,14 +612,14 @@ Portuguese, Spanish and Italian.")
(define-public fet
(package
(name "fet")
- (version "5.44.4")
+ (version "5.45.0")
(source
(origin
(method url-fetch)
(uri (string-append "https://www.lalescu.ro/liviu/fet/download/"
"fet-" version ".tar.bz2"))
(sha256
- (base32 "1bji4910v6adhngdh5ajz5bxam9z3yqnh8d1h1xajy6npm6qq3nx"))))
+ (base32 "04jns6wc20rz6cp410znsllknhp4zlf4rn8wgv712855nffs42c6"))))
(build-system gnu-build-system)
(arguments
`(#:phases
@@ -645,15 +651,14 @@ hours.")
(define-public klavaro
(package
(name "klavaro")
- (version "3.09")
+ (version "3.10")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/klavaro/klavaro-"
version ".tar.bz2"))
(sha256
- (base32
- "12gml7h45b1w9s318h0d5wxw92h7pgajn2kh57j0ak9saq0yb0wr"))))
+ (base32 "0jnzdrndiq6m0bwgid977z5ghp4q61clwdlzfpx4fd2ml5x3iq95"))))
(build-system gnu-build-system)
(native-inputs
`(("intltool" ,intltool)
@@ -976,3 +981,35 @@ comparison flags, input-output devices, and a set of binary instructions.
The package includes a compiler, a virtual machine, a GUI for the virtual
machine, and more.")
(license license:gpl3+)))
+
+(define-public exercism
+ (package
+ (name "exercism")
+ (version "3.0.13")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/exercism/cli")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "17gvz9a0sn4p36hf4l77bxhhfipf4x998iay31layqwbnzmb4xy7"))
+ (patches (search-patches "exercism-disable-self-update.patch"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/exercism/cli/exercism"
+ #:unpack-path "github.com/exercism/cli"))
+ (inputs
+ `(("github.com/blang/semver" ,go-github-com-blang-semver)
+ ("github.com/spf13/cobra" ,go-github-com-spf13-cobra)
+ ("github.com/spf13/pflag" ,go-github-com-spf13-pflag)
+ ("github.com/spf13/viper" ,go-github-com-spf13-viper)
+ ("golang.org/x/net" ,go-golang-org-x-net)
+ ("golang.org/x/text" ,go-golang-org-x-text)))
+ (home-page "https://exercism.io")
+ (synopsis "Mentored learning for programming languages")
+ (description "Commandline client for exercism.io, a free service providing
+mentored learning for programming languages.")
+ (license license:expat)))