summaryrefslogtreecommitdiff
path: root/gnu/packages/docker.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/docker.scm')
-rw-r--r--gnu/packages/docker.scm19
1 files changed, 9 insertions, 10 deletions
diff --git a/gnu/packages/docker.scm b/gnu/packages/docker.scm
index 3dd706cbe9..4beba12c11 100644
--- a/gnu/packages/docker.scm
+++ b/gnu/packages/docker.scm
@@ -48,7 +48,7 @@
#:use-module (gnu packages version-control)
#:use-module (gnu packages virtualization))
-(define %docker-version "19.03.11")
+(define %docker-version "19.03.12")
(define-public python-docker-py
(package
@@ -66,7 +66,6 @@
(arguments '(#:tests? #f))
(inputs
`(("python-requests" ,python-requests-2.20)
- ("python-ipaddress" ,python-ipaddress)
("python-six" ,python-six)
("python-urllib3" ,python-urllib3-1.24)
("python-websocket-client" ,python-websocket-client)))
@@ -179,7 +178,7 @@ Python without keeping their credentials in a Docker configuration file.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/containerd/containerd.git")
+ (url "https://github.com/containerd/containerd")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
@@ -257,7 +256,7 @@ network attachments.")
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/docker/libnetwork.git")
+ (url "https://github.com/docker/libnetwork")
(commit commit)))
(file-name (git-file-name name version))
(sha256
@@ -311,11 +310,11 @@ built-in registry server of Docker.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/docker/engine.git")
+ (url "https://github.com/docker/engine")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1pmbggxbazipl24hxiaccbj32379zv79xba76l78v5131ihx922h"))
+ (base32 "1dj6llfcgcbpq9q9j6b4wb0anbn1g5wzm8ikq2lyhg54i3154m93"))
(patches
(search-patches "docker-fix-tests.patch"))))
(build-system gnu-build-system)
@@ -601,11 +600,11 @@ provisioning etc.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/docker/cli.git")
+ (url "https://github.com/docker/cli")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1y9ymv70r1hndblr64h19q34arxl2f3dqqi2qcrai5zfimcml6lr"))))
+ (base32 "1bynmnaykhh1m42v6bxparlpm9kajpqsvlrlwgz1b9ivcklf5ik6"))))
(build-system go-build-system)
(arguments
`(#:import-path "github.com/docker/cli"
@@ -671,7 +670,7 @@ provisioning etc.")
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/savoirfairelinux/cqfd.git")
+ (url "https://github.com/savoirfairelinux/cqfd")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
@@ -709,7 +708,7 @@ defined in a per-project configuration file.")
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/krallin/tini.git")
+ (url "https://github.com/krallin/tini")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256