summaryrefslogtreecommitdiff
path: root/gnu/packages/django.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/django.scm')
-rw-r--r--gnu/packages/django.scm23
1 files changed, 11 insertions, 12 deletions
diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index 43339720f2..aa4411c5a2 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -47,13 +47,13 @@
(define-public python-django
(package
(name "python-django")
- (version "3.1.1")
+ (version "3.1.3")
(source (origin
(method url-fetch)
(uri (pypi-uri "Django" version))
(sha256
(base32
- "0bzwy58hrxbsh7szak1yfh7qvvfnpdpi8ay1x7d3pvbkm1f15j2r"))))
+ "13rz3v0bwk8i3xcccn5awbafahab3cyk8wwv57v2xazdzxspgf0l"))))
(build-system python-build-system)
(arguments
'(#:phases
@@ -132,13 +132,13 @@ to the @dfn{don't repeat yourself} (DRY) principle.")
(define-public python-django-2.2
(package
(inherit python-django)
- (version "2.2.16")
+ (version "2.2.17")
(source (origin
(method url-fetch)
(uri (pypi-uri "Django" version))
(sha256
(base32
- "1535g2r322cl4x52fb0dmzlbg23539j2wx6027j54p22xvjlbkv2"))))
+ "0qdq0h2gw45j0h9j22c2sdn49ybl7jsrcyraskb9snknsyj70lyg"))))
(native-inputs
`(;; XXX: In 2.2 and 3.0, selenium is required for the test suite.
("python-selenium" ,python-selenium)
@@ -862,14 +862,13 @@ settings.py and easily use them in your project.")
(define-public python-django-q
(package
(name "python-django-q")
- (version "1.3.3")
+ (version "1.3.4")
(source
(origin
(method url-fetch)
(uri (pypi-uri "django-q" version))
(sha256
- (base32
- "1fs29767940akbsn3vdzw2rqnn9v77b0b55bi7fvydny1rk7fw6y"))))
+ (base32 "03z1pf6wlf47i7afr79a8fiiidfk1vq19yaqnv0m4qdny7f58gaj"))))
(build-system python-build-system)
;; FIXME: Tests require disque, Redis, MongoDB, Docker.
(arguments '(#:tests? #f))
@@ -1013,14 +1012,14 @@ Django projects, which allows association of a number of tags with any
(define-public python-djangorestframework
(package
(name "python-djangorestframework")
- (version "3.11.1")
+ (version "3.12.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "djangorestframework" version))
(sha256
(base32
- "0chbl1d0m1x23mmpdj7y85k3n32lpxrhcdl07ywnylfj9dd2vl3d"))))
+ "0jb22psb823vh5fj9az63p5lgyax9ygjy2faah16ajxvvsp54i6m"))))
(build-system python-build-system)
(arguments
'(;; No included tests
@@ -1052,7 +1051,7 @@ provides features like a Web-browsable API and authentication policies.")
("python-six" ,python-six)))
(home-page "https://github.com/divio/django-sekizai")
(synopsis "Template blocks for Django projects")
- (description "Sekizai means blocks in Japanese, and thats what this app
+ (description "Sekizai means blocks in Japanese, and that is what this app
provides. A fresh look at blocks. With @code{django-sekizai} you can define
placeholders where your blocks get rendered and at different places in your
templates append to those blocks. This is especially useful for css and
@@ -1193,7 +1192,7 @@ FileFields during tests.")
(home-page "https://github.com/django-auth-ldap/django-auth-ldap")
(synopsis "Django LDAP authentication backend")
(description
- "This packages provides a LDAP authentication backend for Django.")
+ "This package provides an LDAP authentication backend for Django.")
(license license:bsd-2)))
(define-public python-django-logging-json
@@ -1291,6 +1290,6 @@ to ElasticSearch.")
(description
"The main goal of Django URL Filter is to provide an easy URL interface
for filtering data. It allows the user to safely filter by model attributes
-and also allows to specify the lookup type for each filter (very much like
+and also specify the lookup type for each filter (very much like
Django's filtering system in ORM).")
(license license:expat)))