summaryrefslogtreecommitdiff
path: root/gnu/packages/disk.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/disk.scm')
-rw-r--r--gnu/packages/disk.scm18
1 files changed, 10 insertions, 8 deletions
diff --git a/gnu/packages/disk.scm b/gnu/packages/disk.scm
index 484126a3ea..f8d284cf24 100644
--- a/gnu/packages/disk.scm
+++ b/gnu/packages/disk.scm
@@ -175,13 +175,15 @@ tmpfs/ramfs filesystems.")
(inputs
`(("lvm2" ,lvm2)
("readline" ,readline)
- ("util-linux" ,util-linux)))
+ ("util-linux" ,util-linux "lib")))
(native-inputs
`(("gettext" ,gettext-minimal)
+
;; For the tests.
("e2fsprogs" ,e2fsprogs)
("perl" ,perl)
- ("python" ,python-2)))
+ ("python" ,python-2)
+ ("util-linux" ,util-linux)))
(home-page "https://www.gnu.org/software/parted/")
(synopsis "Disk partition editor")
(description
@@ -205,7 +207,7 @@ tables. It includes a library and command-line utility.")
(inputs
`(("gettext" ,gettext-minimal)
("guile" ,guile-1.8)
- ("util-linux" ,util-linux)
+ ("util-linux" ,util-linux "lib")
("parted" ,parted)))
;; The build neglects to look for its own headers in its own tree. A next
;; release should fix this, but may never come: GNU fdisk looks abandoned.
@@ -245,7 +247,7 @@ tables, and it understands a variety of different formats.")
`(("gettext" ,gettext-minimal)
("ncurses" ,ncurses)
("popt" ,popt)
- ("util-linux" ,util-linux))) ; libuuid
+ ("util-linux" ,util-linux "lib"))) ;libuuid
(arguments
`(#:test-target "test"
#:phases
@@ -435,7 +437,7 @@ and can dramatically shorten the lifespan of the drive if left unchecked.")
;; as '/dev/disk/by-id'
`(#:tests? #f))
(inputs
- `(("util-linux" ,util-linux)
+ `(("util-linux" ,util-linux "lib")
("parted" ,parted)
("glib" ,glib)
("gtkmm" ,gtkmm)
@@ -663,7 +665,7 @@ automatically finding out which program to use for what file type.")
(inputs
`(("cryptsetup" ,cryptsetup)
("nss" ,nss)
- ("libblkid" ,util-linux)
+ ("libblkid" ,util-linux "lib")
("lvm2" ,lvm2) ; for "-ldevmapper"
("glib" ,glib)
("gpgme" ,gpgme)))
@@ -716,7 +718,7 @@ passphrases.")
("json-c" ,json-c)
("keyutils" ,keyutils)
("kmod" ,kmod)
- ("util-linux" ,util-linux)))
+ ("util-linux" ,util-linux "lib")))
(arguments
`(#:configure-flags
(list "--disable-asciidoctor" ; use docbook-xsl instead
@@ -885,7 +887,7 @@ LVM D-Bus API).")
("libelf" ,libelf)
("elfutils" ,elfutils)
("json-glib" ,json-glib)
- ("libblkid" ,util-linux)))
+ ("libblkid" ,util-linux "lib")))
(home-page "https://rmlint.rtfd.org")
(synopsis "Remove duplicates and other lint from the file system")
(description "@command{rmlint} finds space waste and other broken things