summaryrefslogtreecommitdiff
path: root/gnu/packages/disk.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/disk.scm')
-rw-r--r--gnu/packages/disk.scm9
1 files changed, 4 insertions, 5 deletions
diff --git a/gnu/packages/disk.scm b/gnu/packages/disk.scm
index c457bfd1bf..a9880d7abb 100644
--- a/gnu/packages/disk.scm
+++ b/gnu/packages/disk.scm
@@ -448,8 +448,8 @@ to recover data more efficiently by only reading the necessary blocks.")
(build-system gnu-build-system)
(arguments
`(#:configure-flags (list "--enable-compat-symlinks")
- #:make-flags (list (string-append "PREFIX=" %output)
- "CC=gcc")))
+ #:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out"))
+ (string-append "CC=" ,(cc-for-target)))))
(native-inputs
`(("autoconf" ,autoconf)
("automake" ,automake)
@@ -573,7 +573,7 @@ and can dramatically shorten the lifespan of the drive if left unchecked.")
`(("util-linux" ,util-linux "lib")
("parted" ,parted)
("glib" ,glib)
- ("gtkmm" ,gtkmm)
+ ("gtkmm" ,gtkmm-3)
("libxml2" ,libxml2)))
(native-inputs
`(("intltool" ,intltool)
@@ -962,8 +962,7 @@ to create devices with respective mappings for the ATARAID sets discovered.")
("nss" ,nss)
("parted" ,parted)
("volume-key" ,volume-key)
- ;; ("xfsprogs" ,xfsprogs) ; TODO: Package?
- ))
+ ("xfsprogs" ,xfsprogs)))
(home-page "https://github.com/storaged-project/libblockdev")
(synopsis "Library for manipulating block devices")
(description