summaryrefslogtreecommitdiff
path: root/gnu/packages/disk.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/disk.scm')
-rw-r--r--gnu/packages/disk.scm31
1 files changed, 24 insertions, 7 deletions
diff --git a/gnu/packages/disk.scm b/gnu/packages/disk.scm
index d7bf726830..bdd24a315c 100644
--- a/gnu/packages/disk.scm
+++ b/gnu/packages/disk.scm
@@ -11,6 +11,7 @@
;;; Copyright © 2017 Stefan Reichör <stefan@xsteve.at>
;;; Copyright © 2018 Vasile Dumitrascu <va511e@yahoo.com>
;;; Copyright © 2018 Eric Bavier <bavier@member.fsf.org>
+;;; Copyright © 2018 Rutger Helling <rhelling@mykolab.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -53,6 +54,7 @@
#:use-module (gnu packages guile)
#:use-module (gnu packages compression)
#:use-module (gnu packages vim)
+ #:use-module (gnu packages w3m)
#:use-module (gnu packages xml))
(define-public parted
@@ -464,15 +466,15 @@ a card with a smaller capacity than stated.")
(define-public duperemove
(package
(name "duperemove")
- (version "v0.11.beta4")
+ (version "0.11")
(source (origin
(method url-fetch)
(uri (string-append
- "https://github.com/markfasheh/duperemove/archive/"
+ "https://github.com/markfasheh/duperemove/archive/v"
version ".tar.gz"))
(sha256
(base32
- "1h5nk03kflfnzihvn2rvfz1h623x1zpkn9hp29skd7n3f2bc5k7x"))
+ "0rjmmh42yqw9a5j6sp31cqwxk3s97dsi4xz0wpxpllj7bsp3aiw5"))
(file-name (string-append name "-" version ".tar.gz"))))
(build-system gnu-build-system)
(native-inputs
@@ -481,11 +483,10 @@ a card with a smaller capacity than stated.")
`(("glib" ,glib)
("sqlite" ,sqlite)))
(arguments
- `(#:tests? #f ;no test suite
+ `(#:tests? #f ; no test suite
#:phases
(modify-phases %standard-phases
- ;; no configure script
- (delete 'configure))
+ (delete 'configure)) ; no configure script
#:make-flags (list (string-append "PREFIX=" %output)
"CC=gcc")))
(home-page "https://github.com/markfasheh/duperemove")
@@ -517,12 +518,28 @@ Duperemove can also take input from the @command{fdupes} program.")
(base32
"1lnzkrxcnlwnyi3z0v8ybyp8d5rm26qm35rr68kbs2lbs06inha0"))))
(build-system python-build-system)
+ (inputs
+ `(("w3m" ,w3m)))
(native-inputs ;for tests
`(("python-pytest" ,python-pytest)
("python-pylint" ,python-pylint)
("python-flake8" ,python-flake8)
("which" ,which)))
- (arguments '(#:test-target "test"))
+ (arguments
+ '(#:test-target "test"
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'configure 'wrap-program
+ ;; Tell 'ranger' where 'w3mimgdisplay' is.
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (ranger (string-append out "/bin/ranger"))
+ (w3m (assoc-ref inputs "w3m"))
+ (w3mimgdisplay (string-append w3m
+ "/libexec/w3m/w3mimgdisplay")))
+ (wrap-program ranger
+ `("W3MIMGDISPLAY_PATH" ":" prefix (,w3mimgdisplay)))
+ #t))))))
(home-page "https://ranger.github.io/")
(synopsis "Console file manager")
(description "ranger is a console file manager with Vi key bindings. It