summaryrefslogtreecommitdiff
path: root/gnu/packages/disk.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/disk.scm')
-rw-r--r--gnu/packages/disk.scm50
1 files changed, 47 insertions, 3 deletions
diff --git a/gnu/packages/disk.scm b/gnu/packages/disk.scm
index 79e187e283..235df8ce9e 100644
--- a/gnu/packages/disk.scm
+++ b/gnu/packages/disk.scm
@@ -689,7 +689,7 @@ passphrases.")
(define-public ndctl
(package
(name "ndctl")
- (version "69")
+ (version "70.1")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -698,7 +698,7 @@ passphrases.")
(file-name (git-file-name name version))
(sha256
(base32
- "1l7p0ycj27d4z07gf9qp796xpg16kfsg3rwx6plhilbhip1as4w7"))))
+ "09ymdibcr18vpmyf2n0xrnzgccfvr7iy3p2l5lbh7cgz7djyl5wq"))))
(build-system gnu-build-system)
(native-inputs
`(("asciidoc" ,asciidoc)
@@ -1038,6 +1038,50 @@ of choice for all light thinking Unix addicts!")
(home-page "https://savannah.nongnu.org/projects/hddtemp/")
(synopsis "Report the temperature of hard drives from S.M.A.R.T. information")
(description "@command{hddtemp} is a small utility that gives you the
-temperature of your hard drive by reading S.M.A.R.T. informations (for drives
+temperature of your hard drive by reading S.M.A.R.T. information (for drives
that support this feature).")
(license license:gpl2+)))
+
+(define-public memkind
+ (package
+ (name "memkind")
+ (version "1.10.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/memkind/memkind.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "11iz887f3cp5pzf1bzm644wzab8gkbhz3b7x1w6pcps71yd94ylj"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(;; memkind patched jemalloc to add je_arenalookupx,
+ ;; je_check_reallocatex--i.e. they forked jemalloc.
+ ;("jemalloc" ,jemalloc)
+ ("ndctl" ,ndctl)
+ ("numactl" ,numactl)))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)))
+ (arguments
+ `(#:tests? #f ; Tests require a NUMA-enabled system.
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'autogen-jemalloc
+ (lambda _
+ (with-directory-excursion "jemalloc"
+ (substitute* "Makefile.in"
+ (("/bin/sh") (which "sh")))
+ (invoke "autoconf")
+ (substitute* "configure"
+ (("/bin/sh") (which "sh"))))
+ #t)))))
+ (home-page "https://github.com/memkind/memkind")
+ (synopsis "Heap manager with memory kinds (for NUMA)")
+ (description "This package provides a user-extensible heap manager
+built on top of jemalloc which enables control of memory characteristics
+and a partitioning of the heap between kinds of memory (for NUMA).")
+ (license license:bsd-3)))