summaryrefslogtreecommitdiff
path: root/gnu/packages/disk.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/disk.scm')
-rw-r--r--gnu/packages/disk.scm51
1 files changed, 48 insertions, 3 deletions
diff --git a/gnu/packages/disk.scm b/gnu/packages/disk.scm
index 652bb22f21..040aa38ebf 100644
--- a/gnu/packages/disk.scm
+++ b/gnu/packages/disk.scm
@@ -19,6 +19,7 @@
;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
;;; Copyright © 2020 Raghav Gururajan <raghavgururajan@disroot.org>
;;; Copyright © 2021 Michael Rohleder <mike@rohleder.de>
+;;; Copyright © 2021 Mathieu Othacehe <othacehe@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1067,19 +1068,27 @@ since they are better handled by external tools.")
(define-public xfe
(package
(name "xfe")
- (version "1.43.2")
+ (version "1.44")
(source
(origin
(method url-fetch)
(uri
(string-append "mirror://sourceforge/xfe/xfe/" version "/"
- "xfe-" version ".tar.gz"))
+ "xfe-" version ".tar.xz"))
(sha256
- (base32 "1fl51k5jm2vrfc2g66agbikzirmp0yb0lqhmsssixfb4mky3hpzs"))))
+ (base32 "1dihq03jqjllb69r78d9ihjjadi39v7sgzdf68qpxz5xhp8i8k2r"))))
(build-system gnu-build-system)
(arguments
`(#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'patch-potfiles
+ (lambda _
+ ;; To add missing entry 'intl/plural.c' to potfiles list.
+ ;; Refer to https://sourceforge.net/p/xfe/bugs/257/
+ (substitute* "po/POTFILES.in"
+ (("src/help.h")
+ (string-append "src/help.h\n"
+ "intl/plural.c")))))
(add-after 'unpack 'patch-bin-dirs
(lambda* (#:key inputs #:allow-other-keys)
(let* ((bash (assoc-ref inputs "bash"))
@@ -1253,3 +1262,39 @@ and a partitioning of the heap between kinds of memory (for NUMA).")
(description "mmc-utils is a command-line tool for configuring and
inspecting MMC storage devices from userspace.")
(license license:gpl2))))
+
+(define-public bmaptools
+ (package
+ (name "bmaptools")
+ (version "3.6")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/intel/bmap-tools")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "01xzrv5nvd2nvj91lz4x9s91y9825j9pj96z0ap6yvy3w2dgvkkl"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ ;; XXX: Remove failing test.
+ (invoke "nosetests" "-v"
+ "--exclude" "test_bmap_helpers"))))))
+ (native-inputs
+ `(("python-mock" ,python-mock)
+ ("python-nose" ,python-nose)))
+ (propagated-inputs
+ `(("python-six" ,python-six)))
+ (home-page "https://github.com/intel/bmap-tools")
+ (synopsis "Create block map for a file or copy a file using block map")
+ (description "Bmaptool is a tool for creating the block map (bmap) for a
+file and copying files using the block map. The idea is that large files,
+like raw system image files, can be copied or flashed a lot faster and more
+reliably with @code{bmaptool} than with traditional tools, like @code{dd} or
+@code{cp}.")
+ (license license:gpl2)))