summaryrefslogtreecommitdiff
path: root/gnu/packages/disk.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/disk.scm')
-rw-r--r--gnu/packages/disk.scm43
1 files changed, 40 insertions, 3 deletions
diff --git a/gnu/packages/disk.scm b/gnu/packages/disk.scm
index bf0897b083..652bb22f21 100644
--- a/gnu/packages/disk.scm
+++ b/gnu/packages/disk.scm
@@ -13,7 +13,7 @@
;;; Copyright © 2018 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2018 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2018, 2019, 2020 Pierre Neidhardt <mail@ambrevar.xyz>
-;;; Copyright © 2019 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2019, 2021 Leo Famulari <leo@famulari.name>
;;; Copyright © 2019 Pierre Langlois <pierre.langlois@gmx.com>
;;; Copyright © 2020 Pkill -9 <pkill9@runbox.com>
;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
@@ -494,14 +494,14 @@ and a @command{fsck.vfat} compatibility symlink for use in an initrd.")
(define-public sdparm
(package
(name "sdparm")
- (version "1.11")
+ (version "1.12")
(source
(origin
(method url-fetch)
(uri (string-append "http://sg.danny.cz/sg/p/"
"sdparm-" version ".tar.xz"))
(sha256
- (base32 "1nqjc4w2w47zavcbf5xmm53x1zbwgljaw1lpajcdi537cgy32fa8"))))
+ (base32 "1gmdxr36allrgap2j4dv238d8awkj327ww0jjwpjwrpbvfpyzjf4"))))
(build-system gnu-build-system)
(home-page "http://sg.danny.cz/sg/sdparm.html")
(synopsis "Provide access to SCSI device parameters")
@@ -1216,3 +1216,40 @@ that support this feature).")
built on top of jemalloc which enables control of memory characteristics
and a partitioning of the heap between kinds of memory (for NUMA).")
(license license:bsd-3)))
+
+(define-public mmc-utils
+ (let ((commit "e9654ebc4a6a48642848822c4a1355a9de4958d1")
+ (revision "0"))
+ (package
+ (name "mmc-utils")
+ (version (git-version "0.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.kernel.org/pub/scm/linux/kernel/git/cjb/mmc-utils.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1dbsppsmky0r4z6kxwczrw8pih8bhc2pb61gsvs986r4xy6jr17a"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; No test suite
+ #:make-flags (list (string-append "prefix=" (assoc-ref %outputs "out"))
+ (string-append "CC=" ,(cc-for-target)))
+ #:phases
+ (modify-phases %standard-phases
+ ;; No ./configure script
+ (delete 'configure)
+ ;; The Makefile's "install-man" target is a no-op.
+ (add-after 'install 'install-doc
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (man1 (string-append out "/share/man/man1")))
+ (install-file "man/mmc.1" man1)))))))
+ (home-page "https://git.kernel.org/pub/scm/linux/kernel/git/cjb/mmc-utils.git/")
+ (synopsis "Configure MMC storage devices from userspace")
+ (description "mmc-utils is a command-line tool for configuring and
+inspecting MMC storage devices from userspace.")
+ (license license:gpl2))))