summaryrefslogtreecommitdiff
path: root/gnu/packages/dillo.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/dillo.scm')
-rw-r--r--gnu/packages/dillo.scm63
1 files changed, 0 insertions, 63 deletions
diff --git a/gnu/packages/dillo.scm b/gnu/packages/dillo.scm
deleted file mode 100644
index 6e0c4d17a9..0000000000
--- a/gnu/packages/dillo.scm
+++ /dev/null
@@ -1,63 +0,0 @@
-;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2016 Kei Kebreau <kei@openmailbox.org>
-;;;
-;;; This file is part of GNU Guix.
-;;;
-;;; GNU Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; GNU Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
-
-(define-module (gnu packages dillo)
- #:use-module ((guix licenses) #:prefix license:)
- #:use-module (guix packages)
- #:use-module (gnu packages)
- #:use-module (gnu packages compression)
- #:use-module (gnu packages fltk)
- #:use-module (gnu packages fontutils)
- #:use-module (gnu packages perl)
- #:use-module (gnu packages pkg-config)
- #:use-module (gnu packages image)
- #:use-module (gnu packages tls)
- #:use-module (gnu packages xorg)
- #:use-module (guix download)
- #:use-module (guix build-system gnu))
-
-(define-public dillo
- (package
- (name "dillo")
- (version "3.0.5")
- (source (origin
- (method url-fetch)
- (uri (string-append "http://www.dillo.org/download/"
- name "-" version ".tar.bz2"))
- (sha256
- (base32
- "12ql8n1lypv3k5zqgwjxlw1md90ixz3ag6j1gghfnhjq3inf26yv"))))
- (build-system gnu-build-system)
- (arguments `(#:configure-flags '("--enable-ssl" "--enable-ipv6")))
- (native-inputs `(("pkg-config" ,pkg-config)))
- (inputs `(("fltk" ,fltk)
- ("fontconfig" ,fontconfig)
- ("libjpeg" ,libjpeg)
- ("libpng" ,libpng)
- ("libxcursor" ,libxcursor)
- ("libxft" ,libxft)
- ("libxi" ,libxi)
- ("libxinerama" ,libxinerama)
- ("openssl" ,openssl)
- ("perl" ,perl)
- ("zlib" ,zlib)))
- (synopsis "Very small and fast graphical web browser")
- (description "Dillo is a minimalistic web browser particularly intended for
-older or slower computers and embedded systems.")
- (home-page "http://www.dillo.org")
- (license license:gpl3+)))