summaryrefslogtreecommitdiff
path: root/gnu/packages/diffoscope.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/diffoscope.scm')
-rw-r--r--gnu/packages/diffoscope.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/diffoscope.scm b/gnu/packages/diffoscope.scm
index da4de83373..b4279a3fb5 100644
--- a/gnu/packages/diffoscope.scm
+++ b/gnu/packages/diffoscope.scm
@@ -111,6 +111,13 @@
(string-append "['" (which "stat") "',"))
(("\\['getfacl',")
(string-append "['" (which "getfacl") "',")))))
+ (add-after 'unpack 'xb-tool-external-tool
+ ;; Fixed upstream, remove this phase when updating to
+ ;; diffoscope 213
+ (lambda _
+ (substitute* "diffoscope/external_tools.py"
+ ((".debian.: .libxmlb-dev.")
+ "\"debian\": \"libxmlb-dev\", \"guix\": \"libxmlb\""))))
(add-after 'build 'build-man-page
(lambda* (#:key (make-flags '()) #:allow-other-keys)
(apply invoke "make" "-C" "doc" make-flags)))