summaryrefslogtreecommitdiff
path: root/gnu/packages/diffoscope.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/diffoscope.scm')
-rw-r--r--gnu/packages/diffoscope.scm30
1 files changed, 19 insertions, 11 deletions
diff --git a/gnu/packages/diffoscope.scm b/gnu/packages/diffoscope.scm
index f5387f8501..9480f1f226 100644
--- a/gnu/packages/diffoscope.scm
+++ b/gnu/packages/diffoscope.scm
@@ -72,7 +72,7 @@
(define-public diffoscope
(package
(name "diffoscope")
- (version "148")
+ (version "151")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -81,7 +81,7 @@
(file-name (git-file-name name version))
(sha256
(base32
- "0siv5z8iqgkzl51dmv69ifqids6hqmiir00yyl1aaqbginrwyhyv"))))
+ "1lv44ngqij9dp3xk9jj95w7an7h03iac6b2ifpq33j5fffswa1sm"))))
(build-system python-build-system)
(arguments
`(#:phases (modify-phases %standard-phases
@@ -132,17 +132,25 @@
(("\\['getfacl',")
(string-append "['" (which "getfacl") "',")))
#t))
+ (add-after 'build 'build-man-page
+ (lambda* (#:key (make-flags '()) #:allow-other-keys)
+ (apply invoke "make" "-C" "doc" make-flags)))
(add-before 'check 'writable-test-data
(lambda _
- ;; tests may need needs write access to tests
- ;; directory
+ ;; Tests may need write access to tests directory.
(for-each make-file-writable (find-files "tests"))
#t))
(add-before 'check 'delete-failing-test
(lambda _
- ;; this requires /sbin to be on the path
+ ;; This requires /sbin to be in $PATH.
(delete-file "tests/test_tools.py")
- #t)))))
+ #t))
+ (add-after 'install 'install-man-page
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (man (string-append out "/share/man/man1")))
+ (install-file "doc/diffoscope.1" man)
+ #t))))))
(inputs `(("rpm" ,rpm) ;for rpm-python
("python-file" ,python-file)
("python-debian" ,python-debian)
@@ -151,14 +159,15 @@
("acl" ,acl) ;for getfacl
("colordiff" ,colordiff)
("xxd" ,xxd)))
- ;; Below are modules used for tests.
- (native-inputs `(("python-pytest" ,python-pytest)
+ (native-inputs `(("help2man" ,help2man)
+ ;; Below are modules used for tests.
+ ("python-pytest" ,python-pytest)
("python-chardet" ,python-chardet)
("python-binwalk" ,python-binwalk)
("python-h5py" ,python-h5py)
("python-pypdf2" ,python-pypdf2)
("python-progressbar33" ,python-progressbar33)
- ;; test suite skips tests when tool is missing
+ ;; The test suite skips tests when these are missing.
,@(match (%current-system)
;; ghc is only available on x86 currently.
((or "x86_64-linux" "i686-linux")
@@ -171,8 +180,7 @@
((or "x86_64-linux")
`(("enjarify" ,enjarify)
;; no unversioned openjdk available
- ("openjdk:jdk" ,openjdk12 "jdk")
- ))
+ ("openjdk:jdk" ,openjdk12 "jdk")))
(_
`()))
("abootimg" ,abootimg)