summaryrefslogtreecommitdiff
path: root/gnu/packages/datastructures.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/datastructures.scm')
-rw-r--r--gnu/packages/datastructures.scm24
1 files changed, 14 insertions, 10 deletions
diff --git a/gnu/packages/datastructures.scm b/gnu/packages/datastructures.scm
index 0f106b7ce9..b996a537cf 100644
--- a/gnu/packages/datastructures.scm
+++ b/gnu/packages/datastructures.scm
@@ -21,6 +21,7 @@
(define-module (gnu packages datastructures)
#:use-module (gnu packages)
+ #:use-module (gnu packages autotools)
#:use-module (gnu packages perl)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
@@ -55,20 +56,23 @@ and heaps.")
(define-public marisa
(package
(name "marisa")
- (version "0.2.5")
+ (version "0.2.6")
(source
(origin
(method url-fetch)
- (uri (string-append "https://github.com/s-yata/marisa-trie"
- "/releases/download/v" version "/" name "-"
- version ".tar.gz"))
+ (uri (string-append "https://github.com/s-yata/marisa-trie/files/"
+ "4832504/marisa-" version ".tar.gz"))
(sha256
- (base32 "19ifrcmnbr9whaaf4ly3s9ndyiq9sjqhnfkrxbz9zsb44w2n36hf"))))
+ (base32 "1pk6wmi28pa8srb4szybrwfn71jldb61c5vgxsiayxcyg1ya4qqh"))))
(build-system gnu-build-system)
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)))
(home-page "https://github.com/s-yata/marisa-trie")
(synopsis "Trie data structure C++ library")
- (description "Matching Algorithm with Recursively Implemented
-StorAge (MARISA) is a static and space-efficient trie data structure C++
+ (description "@acronym{MARISA, Matching Algorithm with Recursively
+Implemented StorAge} is a static and space-efficient trie data structure C++
library.")
;; Dual-licensed, according to docs/readme.en.html (source files lack
@@ -82,7 +86,7 @@ library.")
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/sparsehash/sparsehash.git")
+ (url "https://github.com/sparsehash/sparsehash")
(commit (string-append name "-" version))))
(file-name (git-file-name name version))
(sha256
@@ -157,7 +161,7 @@ queues, stacks, and doubly-linked lists.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/troydhanson/uthash.git")
+ (url "https://github.com/troydhanson/uthash")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
@@ -259,7 +263,7 @@ equivalent succinct data structure are (most of the time) identical.")
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/y-256/libdivsufsort.git")
+ (url "https://github.com/y-256/libdivsufsort")
(commit version)))
(file-name (git-file-name name version))
(sha256