summaryrefslogtreecommitdiff
path: root/gnu/packages/databases.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/databases.scm')
-rw-r--r--gnu/packages/databases.scm124
1 files changed, 86 insertions, 38 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index cafcf04448..ff81b24518 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -17,7 +17,7 @@
;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2016 Andy Patterson <ajpatter@uwaterloo.ca>
;;; Copyright © 2016 Danny Milosavljevic <dannym+a@scratchpost.org>
-;;; Copyright © 2016, 2017, 2018, 2019, 2020, 2021 Marius Bakke <marius@gnu.org>
+;;; Copyright © 2016-2022 Marius Bakke <marius@gnu.org>
;;; Copyright © 2017, 2018 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2017, 2020 Thomas Danckaert <post@thomasdanckaert.be>
;;; Copyright © 2017 Jelle Licht <jlicht@fsfe.org>
@@ -54,6 +54,7 @@
;;; Copyright © 2021 Alexandre Hannud Abdo <abdo@member.fsf.org>
;;; Copyright © 2021 Simon Tournier <zimon.toutoune@gmail.com>
;;; Copyright © 2021 jgart <jgart@dismail.de>
+;;; Copyright © 2021 Foo Chuan Wei <chuanwei.foo@hotmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -510,14 +511,14 @@ mapping from string keys to string values.")
(define-public memcached
(package
(name "memcached")
- (version "1.6.12")
+ (version "1.6.13")
(source
(origin
(method url-fetch)
(uri (string-append
"https://memcached.org/files/memcached-" version ".tar.gz"))
(sha256
- (base32 "0ii3z2mhjrimc6mv5z5x6bwp1s2bbzppja4m3pnmd5zgh9gs74gj"))))
+ (base32 "1m5mhw9ybb8qcyi6hb5kwpqanqmlnz27r54ccabc4y7nhpfvl6mx"))))
(build-system gnu-build-system)
(inputs
(list libevent cyrus-sasl))
@@ -654,35 +655,93 @@ replacement for the code@{python-memcached} library.")
auto-completion and syntax highlighting.")
(license license:bsd-3)))
+(define-public python-pgspecial
+ (package
+ (name "python-pgspecial")
+ (version "1.13.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pgspecial" version))
+ (sha256
+ (base32 "00ddkf565rjcxmfml1z4mmkns1aq8x5s5g85xmnz2scln42y4irq"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ (list python-click python-sqlparse python-psycopg2))
+ (home-page "https://github.com/dbcli/pgspecial")
+ (synopsis
+ "Python implementation of PostgreSQL meta commands (backslash commands)")
+ (description
+ "This Python package provides an API to execute meta-commands (AKA
+\"special\", or \"backslash commands\") on PostgreSQL.")
+ (license license:bsd-3)))
+
+(define-public pgcli
+ (package
+ (name "pgcli")
+ (version "3.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pgcli" version))
+ (sha256
+ (base32 "1dy6yzak696107pqv83296h0xhc3ahlfaydm80593gwn37krgpkc"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ (list python-cli-helpers
+ python-click
+ python-configobj
+ python-pendulum
+ python-pgspecial
+ python-prompt-toolkit
+ python-psycopg2
+ python-pygments
+ python-setproctitle
+ python-sqlparse))
+ (native-inputs
+ (list python-ipython-sql))
+ (home-page "https://www.pgcli.com")
+ (synopsis "PostgreSQL CLI with autocompletion and syntax highlighting")
+ (description
+ "@code{pgcli} is a command line interface for PostgreSQL with
+autocompletion and syntax highlighting.")
+ (license license:bsd-3)))
+
(define-public mycli
(package
(name "mycli")
(version "1.24.1")
(source
- (origin
- (method url-fetch)
- (uri (pypi-uri "mycli" version))
- (sha256
- (base32 "0rij9nw20zhqr7cqnkm8daw8b1wdc9zb6ny1ji9qz5557nz9i3bl"))))
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "mycli" version))
+ (sha256
+ (base32 "0rij9nw20zhqr7cqnkm8daw8b1wdc9zb6ny1ji9qz5557nz9i3bl"))))
(build-system python-build-system)
(arguments
- `(#:tests? #f)) ; tests expect a running MySQL
+ '(#:tests? #f ; tests expect a running MySQL
+ #:phases (modify-phases %standard-phases
+ (add-after 'unpack 'loosen-requirements
+ (lambda _
+ ;; Permit newer versions of sqlparse.
+ (substitute* "setup.py"
+ (("<0\\.4\\.0") "<0.5.0")))))))
(propagated-inputs
- (list python-cli-helpers
- python-click
- python-configobj
- python-cryptography
- python-prompt-toolkit
- python-pyaes
- python-pygments
- python-pymysql
- python-pyperclip
- python-sqlparse))
+ (list python-cli-helpers
+ python-click
+ python-configobj
+ python-cryptography
+ python-prompt-toolkit
+ python-pyaes
+ python-pygments
+ python-pymysql
+ python-pyperclip
+ python-sqlparse))
(home-page "https://www.mycli.net")
(synopsis
- "Terminal Client for MySQL with AutoCompletion and Syntax Highlighting")
+ "Terminal Client for MySQL with AutoCompletion and Syntax Highlighting")
(description
- "MyCLI is a command line interface for MySQL, MariaDB, and Percona with
+ "MyCLI is a command line interface for MySQL, MariaDB, and Percona with
auto-completion and syntax highlighting.")
(license license:bsd-3)))
@@ -3052,18 +3111,6 @@ designed for efficient and high-performing database access, adapted into a
simple and Pythonic domain language.")
(license license:x11)))
-(define-public python-sqlalchemy-1.3
- (package
- (inherit python-sqlalchemy)
- (version "1.3.20")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "SQLAlchemy" version))
- (sha256
- (base32 "18b9am7bsqc4nj3d2h5r93i002apczxfvpfpcqbd6f0385zmrwnj"))))
- (propagated-inputs '())))
-
(define-public python2-sqlalchemy
(package-with-python2 python-sqlalchemy))
@@ -3091,14 +3138,14 @@ framework.")
(define-public python-sqlalchemy-utils
(package
(name "python-sqlalchemy-utils")
- (version "0.32.21")
+ (version "0.38.2")
(source
(origin
(method url-fetch)
(uri (pypi-uri "SQLAlchemy-Utils" version))
(sha256
(base32
- "1myn71dn8j74xglyh46f12sh8ywb7j0j732rzwq70kvwwnq32m73"))))
+ "1d6fq81489kqzxmk3l6f39sinw206lzs392frmpr5lsjzg9xc0cy"))))
(build-system python-build-system)
(arguments
'(#:tests? #f)) ; FIXME: Many tests require a running database server.
@@ -3651,13 +3698,13 @@ is designed to have a low barrier to entry.")
(define-public python-sqlparse
(package
(name "python-sqlparse")
- (version "0.4.1")
+ (version "0.4.2")
(source (origin
(method url-fetch)
(uri (pypi-uri "sqlparse" version))
(sha256
(base32
- "1s2l0jgi1v7rk7smzb99iamasaz22apfkczsphn3ci4wh8pgv48g"))))
+ "1bkx52c2jh28c528b69qfk2ijfzw1laxx6lim7jr8fi6fh67600c"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -3685,7 +3732,8 @@ is designed to have a low barrier to entry.")
(synopsis "Non-validating SQL parser")
(description "Sqlparse is a non-validating SQL parser for Python. It
provides support for parsing, splitting and formatting SQL statements.")
- (license license:bsd-3)))
+ (license license:bsd-3)
+ (properties '((cpe-name . "sqlparse")))))
(define-public python-sql
(package