summaryrefslogtreecommitdiff
path: root/gnu/packages/databases.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/databases.scm')
-rw-r--r--gnu/packages/databases.scm99
1 files changed, 83 insertions, 16 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index e2eb0f396d..0e6ad4e291 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -42,6 +42,7 @@
;;; Copyright © 2020 Nicolò Balzarotti <nicolo@nixo.xyz>
;;; Copyright © 2020 Tanguy Le Carrour <tanguy@bioneland.org>
;;; Copyright © 2020 Lars-Dominik Braun <ldb@leibniz-psychology.org>
+;;; Copyright © 2020 Guy Fleury Iteriteka <gfleury@disroot.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -147,7 +148,7 @@
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/4store/4store.git")
+ (url "https://github.com/4store/4store")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
@@ -609,6 +610,37 @@ RDBMS systems (which are deep in functionality).")
;; Some parts are licensed under the Apache License
license:asl2.0))))
+(define-public mycli
+ (package
+ (name "mycli")
+ (version "1.21.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "mycli" version))
+ (sha256
+ (base32
+ "1q9p0yik9cpvpxjs048anvhicfcna84mpl7axv9bwgr48w40lqwg"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f)) ; tests expect a running MySQL
+ (propagated-inputs
+ `(("python-cli-helpers" ,python-cli-helpers)
+ ("python-click" ,python-click)
+ ("python-configobj" ,python-configobj)
+ ("python-cryptography" ,python-cryptography)
+ ("python-prompt-toolkit" ,python-prompt-toolkit)
+ ("python-pygments" ,python-pygments)
+ ("python-pymysql" ,python-pymysql)
+ ("python-sqlparse" ,python-sqlparse)))
+ (home-page "http://mycli.net")
+ (synopsis
+ "Terminal Client for MySQL with AutoCompletion and Syntax Highlighting")
+ (description
+ "MyCLI is a command line interface for MySQL, MariaDB, and Percona with
+auto-completion and syntax highlighting.")
+ (license license:bsd-3)))
+
;; XXX When updating, check whether boost-for-mysql is still needed.
;; It might suffice to patch ‘cmake/boost.cmake’ as done in the past.
(define-public mysql
@@ -938,7 +970,7 @@ as a drop-in replacement of MySQL.")
(define-public mariadb-connector-c
(package
(name "mariadb-connector-c")
- (version "3.1.8")
+ (version "3.1.9")
(source (origin
(method url-fetch)
(uri (string-append
@@ -947,7 +979,7 @@ as a drop-in replacement of MySQL.")
version "-src.tar.gz"))
(sha256
(base32
- "0yrzhsxmjiwkhchagx8dymzhvxl3k5h40wn9wpicqjvgjb9k8523"))))
+ "1izjzf7yzjqzlk8dkp327fa9lawsv2hnnlnr7g5lshyx5azrk38h"))))
(inputs
`(("openssl" ,openssl)))
(build-system cmake-build-system)
@@ -1401,7 +1433,7 @@ which uses SQL to describe changes.")
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/coffeeandscripts/sqlcrush.git")
+ (url "https://github.com/coffeeandscripts/sqlcrush")
(commit commit)))
(file-name (git-file-name name version))
(sha256
@@ -1481,15 +1513,14 @@ extremely small.")
(define-public perl-dbix-class
(package
(name "perl-dbix-class")
- (version "0.082841")
+ (version "0.082842")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://cpan/authors/id/R/RI/RIBASUSHI/"
"DBIx-Class-" version ".tar.gz"))
(sha256
- (base32
- "1gf3hgv8f9rnr8bl4ljgsqk4aliphmvljhsk4282kvdc4mcgh1fp"))))
+ (base32 "1rh7idjjbibc1zmiaaarask434lh0lx7f2xyfwmy37k9fa0xcpmh"))))
(build-system perl-build-system)
(native-inputs
`(("perl-dbd-sqlite" ,perl-dbd-sqlite)
@@ -1517,7 +1548,7 @@ extremely small.")
("perl-path-class" ,perl-path-class)
("perl-scalar-list-utils" ,perl-scalar-list-utils)
("perl-scope-guard" ,perl-scope-guard)
- ("perl-sql-abstract" ,perl-sql-abstract)
+ ("perl-sql-abstract-classic" ,perl-sql-abstract-classic)
("perl-sub-name" ,perl-sub-name)
("perl-text-balanced" ,perl-text-balanced)
("perl-try-tiny" ,perl-try-tiny)))
@@ -1782,6 +1813,42 @@ structures you provide it, so that you don't have to modify your code every
time your data changes.")
(license license:perl-license)))
+(define-public perl-sql-abstract-classic
+ (package
+ (name "perl-sql-abstract-classic")
+ (version "1.91")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/R/RI/RIBASUSHI/"
+ "SQL-Abstract-Classic-" version ".tar.gz"))
+ (sha256
+ (base32 "0a7g13hs3kdxrjn43sfli09mgsi9d6w0dfw6hlk268av17yisgaf"))))
+ (build-system perl-build-system)
+ (native-inputs
+ `(("perl-test-deep" ,perl-test-deep)
+ ("perl-test-exception" ,perl-test-exception)
+ ("perl-test-warn" ,perl-test-warn)))
+ (propagated-inputs
+ `(("perl-mro-compat" ,perl-mro-compat)
+ ("perl-sql-abstract" ,perl-sql-abstract)))
+ (home-page "https://metacpan.org/release/SQL-Abstract-Classic")
+ (synopsis "Generate SQL from Perl data structures")
+ (description
+ "This module is nearly identical to @code{SQL::Abstract} 1.81, and exists
+to preserve the ability of users to opt into the new way of doing things in
+later versions according to their own schedules.
+
+It is an abstract SQL generation module based on the concepts used by
+@code{DBIx::Abstract}, with several important differences, especially when it
+comes to @code{WHERE} clauses. These concepts were modified to make the SQL
+easier to generate from Perl data structures.
+
+The underlying idea is for this module to do what you mean, based on the data
+structures you provide it. You shouldn't have to modify your code every time
+your data changes, as this module figures it out.")
+ (license license:perl-license)))
+
(define-public perl-sql-splitstatement
(package
(name "perl-sql-splitstatement")
@@ -1909,8 +1976,8 @@ sets, bitmaps and hyperloglogs.")
(version "1.2.77")
(source (origin
(method url-fetch)
- (uri (string-append "http://fallabs.com/kyotocabinet/pkg/"
- name "-" version ".tar.gz"))
+ (uri (string-append "https://fallabs.com/kyotocabinet/pkg/"
+ "kyotocabinet-" version ".tar.gz"))
(sha256
(base32
"1rlx4307adbzd842b4npq6cwlw8h010ingxaz3qz1ijc70lr72an"))))
@@ -1922,7 +1989,7 @@ sets, bitmaps and hyperloglogs.")
(string-append "LDFLAGS=-Wl,-rpath="
(assoc-ref %outputs "out") "/lib"))))
(inputs `(("zlib" ,zlib)))
- (home-page "http://fallabs.com/kyotocabinet/")
+ (home-page "https://fallabs.com/kyotocabinet/")
(synopsis
"Kyoto Cabinet is a modern implementation of the DBM database")
(description
@@ -2125,7 +2192,7 @@ virtual address space — not physical RAM.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/drycpp/lmdbxx.git")
+ (url "https://github.com/drycpp/lmdbxx")
(commit version)))
(file-name (git-file-name name version))
(sha256
@@ -2354,7 +2421,7 @@ for ODBC.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/brianb/mdbtools.git")
+ (url "https://github.com/brianb/mdbtools")
(commit version)))
(file-name (git-file-name name version))
(sha256
@@ -2553,13 +2620,13 @@ Database API 2.0T.")
(define-public python-sqlalchemy
(package
(name "python-sqlalchemy")
- (version "1.3.15")
+ (version "1.3.18")
(source
(origin
(method url-fetch)
(uri (pypi-uri "SQLAlchemy" version))
(sha256
- (base32 "0iglkvymfp35zm5pxy5kzqvcv96kkas0chqdx7xpla86sspa9k64"))))
+ (base32 "1rwc6ss1cnz3kxx0p9p6xw0w79r8qw03lcc29k31yb3rcigvfbys"))))
(build-system python-build-system)
(native-inputs
`(("python-cython" ,python-cython) ; for C extensions
@@ -3090,7 +3157,7 @@ transforms idiomatic python function calls to well-formed SQL queries.")
(source
(origin (method git-fetch)
(uri (git-reference
- (url "https://github.com/kayak/pypika.git")
+ (url "https://github.com/kayak/pypika")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256