summaryrefslogtreecommitdiff
path: root/gnu/packages/cursynth.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/cursynth.scm')
-rw-r--r--gnu/packages/cursynth.scm53
1 files changed, 0 insertions, 53 deletions
diff --git a/gnu/packages/cursynth.scm b/gnu/packages/cursynth.scm
deleted file mode 100644
index 80f86da241..0000000000
--- a/gnu/packages/cursynth.scm
+++ /dev/null
@@ -1,53 +0,0 @@
-;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
-;;;
-;;; This file is part of GNU Guix.
-;;;
-;;; GNU Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; GNU Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
-
-(define-module (gnu packages cursynth)
- #:use-module (guix packages)
- #:use-module (guix licenses)
- #:use-module (guix download)
- #:use-module (guix build-system gnu)
- #:use-module (gnu packages)
- #:use-module (gnu packages pkg-config)
- #:use-module (gnu packages ncurses)
- #:use-module (gnu packages linux))
-
-(define-public cursynth
- (package
- (name "cursynth")
- (version "1.5")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "mirror://gnu/cursynth/cursynth-"
- version ".tar.gz"))
- (sha256
- (base32 "1dhphsya41rv8z6yqcv9l6fwbslsds4zh1y56zizi39nd996d40v"))
- (patches (list (search-patch "cursynth-wave-rand.patch")))))
- (build-system gnu-build-system)
- (native-inputs `(("pkg-config" ,pkg-config)))
- ;; TODO: See https://github.com/iyoko/cursynth/issues/4 which currently
- ;; prevents us from using pulseaudio
- (inputs `(("ncurses" ,ncurses)
- ("alsa" ,alsa-lib)))
- (home-page "http://www.gnu.org/software/cursynth")
- (synopsis "Polyphonic and MIDI subtractive music synthesizer using curses")
- (description "GNU cursynth is a polyphonic synthesizer that runs
-graphically in the terminal. It is built on a full-featured subtractive
-synthesis engine. Notes and parameter changes may be entered via MIDI or the
-computer's keyboard.")
- (license gpl3+)))