summaryrefslogtreecommitdiff
path: root/gnu/packages/curl.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/curl.scm')
-rw-r--r--gnu/packages/curl.scm84
1 files changed, 27 insertions, 57 deletions
diff --git a/gnu/packages/curl.scm b/gnu/packages/curl.scm
index c61a56256c..9a9d788ceb 100644
--- a/gnu/packages/curl.scm
+++ b/gnu/packages/curl.scm
@@ -11,6 +11,7 @@
;;; Copyright © 2019, 2021 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
;;; Copyright © 2020 Dale Mellor <guix-devel-0brg6b@rdmp.org>
+;;; Copyright © 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2021 Jean-Baptiste Volatier <jbv@pm.me>
;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
;;;
@@ -45,7 +46,6 @@
#:use-module (gnu packages guile)
#:use-module (gnu packages kerberos)
#:use-module (gnu packages libidn)
- #:use-module (gnu packages openldap)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
@@ -57,29 +57,25 @@
(define-public curl
(package
(name "curl")
- (replacement curl-7.77.0)
- (version "7.74.0")
+ (version "7.79.1")
(source (origin
(method url-fetch)
(uri (string-append "https://curl.haxx.se/download/curl-"
version ".tar.xz"))
(sha256
(base32
- "12w7gskrglg6qrmp822j37fmbr0icrcxv7rib1fy5xiw80n5z7cr"))
+ "129n9hi7rbg3s112chyadhp4y27ppb5i65n12wm77aw2255zf1h6"))
(patches (search-patches "curl-use-ssl-cert-env.patch"))))
(build-system gnu-build-system)
(outputs '("out"
"doc")) ;1.2 MiB of man3 pages
- (inputs `(("gnutls" ,gnutls)
- ("libidn" ,libidn)
- ("openldap" ,openldap)
- ("mit-krb5" ,mit-krb5)
- ("nghttp2" ,nghttp2 "lib")
- ("zlib" ,zlib)))
+ (inputs (list gnutls libidn mit-krb5
+ `(,nghttp2 "lib") zlib))
(native-inputs
- `(("perl" ,perl)
+ `(("nghttp2" ,nghttp2)
+ ("perl" ,perl)
("pkg-config" ,pkg-config)
- ("python" ,python-wrapper)))
+ ("python" ,python-minimal-wrapper)))
(native-search-paths
;; These variables are introduced by curl-use-ssl-cert-env.patch.
(list (search-path-specification
@@ -112,8 +108,7 @@
;; Do not save the configure options to avoid unnecessary references.
(substitute* "curl-config.in"
(("@CONFIGURE_OPTIONS@")
- "\"not available\""))
- #t))
+ "\"not available\""))))
(add-after
'install 'move-man3-pages
(lambda* (#:key outputs #:allow-other-keys)
@@ -122,18 +117,17 @@
(doc (assoc-ref outputs "doc")))
(mkdir-p (string-append doc "/share/man"))
(rename-file (string-append out "/share/man/man3")
- (string-append doc "/share/man/man3"))
- #t)))
- (replace
- 'check
- (lambda _
- (substitute* "tests/runtests.pl"
- (("/bin/sh") (which "sh")))
+ (string-append doc "/share/man/man3")))))
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (substitute* "tests/runtests.pl"
+ (("/bin/sh") (which "sh")))
- ;; The top-level "make check" does "make -C tests quiet-test", which
- ;; is too quiet. Use the "test" target instead, which is more
- ;; verbose.
- (invoke "make" "-C" "tests" "test"))))))
+ (when tests?
+ ;; The top-level "make check" does "make -C tests quiet-test", which
+ ;; is too quiet. Use the "test" target instead, which is more
+ ;; verbose.
+ (invoke "make" "-C" "tests" "test")))))))
(synopsis "Command line tool for transferring data with URL syntax")
(description
"curl is a command line tool for transferring data with URL syntax,
@@ -147,14 +141,8 @@ tunneling, and so on.")
"See COPYING in the distribution."))
(home-page "https://curl.haxx.se/")))
-;; This package exists mainly to bootstrap CMake. It must not depend on
-;; anything that uses cmake-build-system.
(define-public curl-minimal
- (hidden-package
- (package/inherit
- curl
- (name "curl-minimal")
- (inputs (alist-delete "openldap" (package-inputs curl))))))
+ (deprecated-package "curl-minimal" curl))
(define-public curl-ssh
(package/inherit curl
@@ -167,21 +155,6 @@ tunneling, and so on.")
,@(package-inputs curl)))
(properties `((hidden? . #t)))))
-(define-public curl-7.77.0
- (package
- (inherit curl)
- (version "7.77.0")
- (source
- (origin
- (inherit (package-source curl))
- (uri (string-append "https://curl.haxx.se/download/curl-"
- version ".tar.xz"))
- (patches (search-patches "curl-7.76-use-ssl-cert-env.patch"
- "curl-7.77-tls-priority-string.patch"))
- (sha256
- (base32
- "0jsrc97vbghvljic997r9nypc9qqddcil2lzvv032br8ahn5hr0g"))))))
-
(define-public kurly
(package
(name "kurly")
@@ -214,9 +187,8 @@ tunneling, and so on.")
(string-append man "/kurly.1")))
#t))))))
(inputs
- `(("go-github-com-alsm-ioprogress" ,go-github-com-alsm-ioprogress)
- ("go-github-com-aki237-nscjar" ,go-github-com-aki237-nscjar)
- ("go-github-com-urfave-cli" ,go-github-com-urfave-cli)))
+ (list go-github-com-alsm-ioprogress go-github-com-aki237-nscjar
+ go-github-com-urfave-cli))
(synopsis "Command-line HTTP client")
(description "kurly is an alternative to the @code{curl} program written in
Go. kurly is designed to operate in a similar manner to curl, with select
@@ -287,10 +259,9 @@ not offer a replacement for libcurl.")
;; The build system does not actually compile the Scheme module.
;; So we can compile it and put it in the right place in one go.
(invoke "guild" "compile" curl.scm "-o" curl.go)))))))
- (native-inputs `(("pkg-config" ,pkg-config)))
+ (native-inputs (list pkg-config))
(inputs
- `(("curl" ,curl)
- ("guile" ,guile-3.0)))
+ (list curl guile-3.0))
(home-page "http://www.lonelycactus.com/guile-curl.html")
(synopsis "Curl bindings for Guile")
(description "@code{guile-curl} is a project that has procedures that allow
@@ -303,8 +274,7 @@ FTP servers. It is based on the curl library.")
(inherit guile-curl)
(name "guile2.2-curl")
(inputs
- `(("curl" ,curl)
- ("guile" ,guile-2.2)))))
+ (list curl guile-2.2))))
(define-public curlpp
(package
@@ -325,7 +295,7 @@ FTP servers. It is based on the curl library.")
'(#:tests? #f))
;; The installed version needs the header files from the C library.
(propagated-inputs
- `(("curl" ,curl)))
+ (list curl))
(synopsis "C++ wrapper around libcURL")
(description
"This package provides a free and easy-to-use client-side C++ URL
@@ -356,7 +326,7 @@ more!")
'(#:install-plan
'(("./h2c" "bin/"))))
(inputs
- `(("perl" ,perl)))
+ (list perl))
(home-page "https://curl.se/h2c/")
(synopsis "Convert HTTP headers to a curl command line")
(description