summaryrefslogtreecommitdiff
path: root/gnu/packages/cups.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/cups.scm')
-rw-r--r--gnu/packages/cups.scm12
1 files changed, 3 insertions, 9 deletions
diff --git a/gnu/packages/cups.scm b/gnu/packages/cups.scm
index c705bbc514..d83211ede2 100644
--- a/gnu/packages/cups.scm
+++ b/gnu/packages/cups.scm
@@ -125,12 +125,6 @@
(("/usr/local/lib/cups/filter")
(string-append out "/lib/cups/filter")))
#t)))
- (add-after 'unpack 'patch-for-poppler
- (lambda _
- (substitute* "filter/pdf.cxx"
- (("GooString \\*field_name;" m)
- (string-append "const " m)))
- #t))
(add-after 'install 'wrap-filters
(lambda* (#:key inputs outputs #:allow-other-keys)
;; Some filters expect to find 'gs' in $PATH. We cannot
@@ -250,7 +244,7 @@ device-specific programs to convert and print many types of files.")
(license license:asl2.0)))
(define-public cups
- (package (inherit cups-minimal)
+ (package/inherit cups-minimal
(name "cups")
(arguments
`(;; Three tests fail:
@@ -421,14 +415,14 @@ should only be used as part of the Guix cups-pk-helper service.")
(define-public hplip
(package
(name "hplip")
- (version "3.20.3")
+ (version "3.20.5")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/hplip/hplip/" version
"/hplip-" version ".tar.gz"))
(sha256
(base32
- "0sh6cg7yjc11x1cm4477iaslj9n8ksghs85hqwgfbk7m5b2pw2a1"))
+ "0nj79r61fzddwwzf8kcc0qkp4y9qx46v15iarz6h6y3v91wbsjq0"))
(modules '((guix build utils)))
(patches (search-patches "hplip-remove-imageprocessor.patch"))
(snippet